Partager via


Erreur « Mémoire insuffisante ou ressources système » lors de l’accès à la liste de contacts à partir d’un dossier public

Symptômes

Vous disposez d’un dossier public qui contient une liste de contacts dans Microsoft Exchange Server. Lorsque vous essayez d’accéder à la liste de contacts dans Microsoft Outlook en mode en ligne, le message d’erreur suivant s’affiche :

Désolé... Nous rencontrons des difficultés à ouvrir cet élément. Cela peut être temporaire, mais si vous le voyez à nouveau, vous pouvez redémarrer Outlook. Mémoire insuffisante ou ressources système. Fermez des fenêtres ou des programmes, puis réessayez.

Capture d’écran du message d’erreur dans la fenêtre Microsoft Outlook.

Cause

Il n’existe aucune limite spécifique au nombre de contacts pour une liste de contacts. Toutefois, il existe une limite de mémoire pour récupérer les propriétés des membres de liste de contacts (telles que DisplayName ou EmailAddresses) dans Exchange Server. Si les membres de la liste de contacts ont des noms longs ou des adresses e-mail, davantage de mémoire est nécessaire pour récupérer les propriétés dans Outlook en mode en ligne. Ce problème se produit si la limite de mémoire est dépassée.

Solution de contournement

Pour contourner ce problème, appliquez l’une des méthodes ci-dessous.

Méthode 1 : Utiliser Outlook sur le web pour accéder à la liste de contacts

Dans Outlook sur le web, ajoutez le dossier public aux Favoris, puis accédez à la liste de contacts. Pour accéder à la liste de contacts, sélectionnez l’icône Personnes, développez Dossiers publics, puis sélectionnez le dossier public Contact.

Méthode 2 : Utiliser Outlook en mode Exchange mis en cache

Note: Outlook récupère les informations du fichier de données local (.ost) en mode Exchange mis en cache.

  1. Téléchargez les dossiers publics en mode Exchange mis en cache.
  2. Ajoutez des dossiers publics aux Favoris dans Outlook, puis accédez à la liste de contacts.

Méthode 3 : Utiliser l’outil MFCMAPI pour fractionner la liste de contacts

Utilisez l’outil MFCMAPI pour fractionner la liste de contacts. Ensuite, réessayez pour accéder à la liste de contacts.

  1. Démarrez l’outil MFCMAPI.

  2. Sélectionnez Session>Ouverture de session.

  3. Double-cliquez sur Dossiers publics, développez la liste IPM_SUBTREE, puis double-cliquez sur le dossier public qui contient la liste de contacts.

  4. Sélectionnez la liste de contacts, puis actions>Exporter le message.

  5. Exportez la liste de contacts au format FICHIER MSG (UNICODE) (par exemple, Brokenlist.msg).

    Capture d’écran de l’exportation de la liste de contacts avec le format de fichier MSG.

  6. Double-cliquez pour ouvrir l’élément exporté et modifier la liste de contacts. Supprimez certains membres de la liste de contacts et modifiez le nom de la liste (par exemple, Splitlist.msg).

  7. Double-cliquez sur le dossier public dans la liste IPM_SUBTREE, puis sélectionnezImportation> de dossier>à partir du groupe msg pour importer la liste de contacts mise à jour.

Pour modifier les contacts restants dans la liste des contacts, répétez les étapes 4 à 7.