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Impossible de développer ou d’afficher le contenu d’un dossier public dans Outlook

Symptômes

Lorsque vous essayez de développer un dossier public ou d’afficher le contenu d’un dossier public dans Microsoft Outlook, le message d’erreur suivant s’affiche :

Impossible d’afficher le dossier. Les problèmes réseau empêchent la connexion à Microsoft Exchange.

Cause

Le problème se produit si trop d’utilisateurs (plus de 2 000) se connectent à la même boîte aux lettres de dossiers publics. Le problème peut se produire pour les raisons suivantes :

  • Affectation déséquilibré des utilisateurs aux boîtes aux lettres de dossiers publics. Par défaut, la boîte aux lettres de dossiers publics à laquelle un utilisateur se connecte est automatiquement sélectionnée par un algorithme Exchange qui équilibre la charge des utilisateurs entre les boîtes aux lettres de dossiers publics. Trop de connexions utilisateur à la même boîte aux lettres de dossier public peuvent se produire si les administrateurs de locataire remplacent l’attribution automatique de boîtes aux lettres de dossiers publics.

  • Dossier public fortement utilisé. Une utilisation intensive peut entraîner l’création d’un trop grand nombre de connexions à la boîte aux lettres de dossiers publics qui héberge le contenu du dossier public.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Vérifiez que vous disposez d’une affectation équilibrée des utilisateurs aux boîtes aux lettres de dossiers publics. Procédez comme suit :

    1. Déterminez le nombre d’utilisateurs affectés à chaque boîte aux lettres de dossiers publics de service de hiérarchie. Pour une boîte aux lettres de dossiers publics Exchange Online, exécutez les commandes suivantes dans Exchange Online PowerShell :

      $mbxs = Get-EXOMailbox -ResultSize unlimited -Properties EffectivePublicFolderMailbox
      $mbxs | sort EffectivePublicFolderMailbox | group EffectivePublicFolderMailbox
      

      Pour un dossier public local, exécutez les commandes PowerShell suivantes dans Exchange Management Shell (EMS) :

      $mbxs = Get-Mailbox -ResultSize unlimited
      $mbxs | sort EffectivePublicFolderMailbox | group EffectivePublicFolderMailbox
      

      L’exemple suivant montre la sortie de commande pour une affectation équilibrée d’utilisateurs aux boîtes aux lettres de dossiers publics. Presque le même nombre d’utilisateurs sont affectés à chaque boîte aux lettres de dossiers publics. La gestion d’une charge équilibrée est considérée comme une bonne pratique, car elle réduit la probabilité d’avoir trop de connexions utilisateur à une boîte aux lettres de dossier public.

      Count   Name    Group
      -----   ----    -----
      270     pfmbx1  { hross, nitya.patel, rperrera, sthakkar… }
      259     pfmbx2  { aida.kamaria, rflores, qamar.mounir, kcarter… }
      240     pfmbx3  { gabriel.diaz, nihad.samaha, kmclean, veronica.berg… }
      

      L’exemple suivant montre la sortie de la commande pour une affectation déséquilibré d’utilisateurs aux boîtes aux lettres de dossiers publics. Plus de 90 % des utilisateurs sont affectés à la même boîte aux lettres de dossiers publics. Une charge déséquilibré augmente la probabilité que certains utilisateurs rencontrent des problèmes de connexion si de nombreux utilisateurs tentent d’accéder à cette boîte aux lettres de dossiers publics en même temps.

      Count   Name    Group
      -----   ----    -----
      2710    pfmbx2  { fabiopena, robert.anic, epereira, fadila.baz… }
      5       pfmbx3  { elizabeth.garcia, lponos, laura.cunha, joni.shah… }
      
    2. Si vous avez déterminé, à l’étape précédente, qu’il existe une affectation déséquilibré des utilisateurs aux boîtes aux lettres de dossiers publics, définissez la valeur du DefaultPublicFolderMailbox paramètre sur Null pour chaque boîte aux lettres utilisateur. Pour une boîte aux lettres de dossiers publics Exchange Online, exécutez la commande suivante dans Exchange Online PowerShell :

      Get-EXOMailbox -ResultSize unlimited | Set-Mailbox -DefaultPublicFolderMailbox $null
      

      Pour une boîte aux lettres de dossiers publics locale, exécutez la commande PowerShell suivante dans ems :

      Get-Mailbox -ResultSize unlimited | Set-Mailbox -DefaultPublicFolderMailbox $null
      

      Après avoir exécuté la commande, le système affecte automatiquement une boîte aux lettres de dossiers publics pour chaque utilisateur de manière à équilibrer la charge.

  2. Si votre organization a un dossier public fortement utilisé auquel plus de 2 000 utilisateurs peuvent accéder simultanément, procédez comme suit :

    1. Déterminez la boîte aux lettres de dossier public qui contient le contenu du dossier public fortement utilisé. Exécutez la commande PowerShell suivante:

      Get-PublicFolder -Identity <public folder path and name> | FL ContentMailboxName
      
    2. Obtenez la liste des boîtes aux lettres de dossiers publics dans votre organization avec les dossiers publics qu’elles hébergent. Exécutez les commandes PowerShell suivantes :

      $pfs = Get-PublicFolder -Recurse
      $pfs | sort ContentMailboxName | group ContentMailboxName
      

      L’exemple suivant montre la sortie de la commande :

      Count   Name    Group
      -----   ----    -----
      1       PFMBX   { IPM\_SUBTREE }
      7       PFMBX2  { HeavilyUsedPF, PF2, PF3… }
      2       PFMBX3  { PF4, PF5 }
      2       PFMBX4  { PF6, PF7 }
      

      Remarque : pour obtenir uniquement la liste des boîtes aux lettres de dossiers publics, exécutez l’applet de commande PowerShell suivante :

      Get-Mailbox -PublicFolder
      
    3. Dans la liste que vous avez obtenue à l’étape précédente, identifiez au moins deux boîtes aux lettres de dossiers publics qui n’ont pas de dossiers publics fortement utilisés. Créez des dossiers publics dans ces boîtes aux lettres pour héberger le contenu fortement utilisé. Pour créer un dossier public dans une boîte aux lettres de dossiers publics, exécutez l’applet de commande PowerShell suivante :

      New-PublicFolder -Name <public folder name> -Mailbox <public folder mailbox>
      

      Par exemple, si le dossier public fortement utilisé existe dans la boîte aux lettres de dossiers publics PFMBX2 et que vous avez moins utilisé le contenu dans les boîtes aux lettres de dossiers publics PFMBX3 et PFMBX4, créez les dossiers publics.

      Remarque

      Ne créez pas les dossiers publics dans la boîte aux lettres de dossiers publics de la hiérarchie principale.

    4. Utilisez le client de bureau Outlook pour distribuer le contenu du dossier public fortement utilisé aux nouveaux dossiers publics que vous avez créés à l’étape précédente.

  3. Si le problème persiste une fois que vous avez effectué les étapes précédentes, il est possible que les boîtes aux lettres de dossiers publics existantes soient surchargées même si leur charge est équilibrée. Dans ce cas, créez des boîtes aux lettres de dossiers publics supplémentaires. Une fois que vous avez créé des boîtes aux lettres de dossiers publics, le système les équilibre automatiquement.