Notes
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Symptômes
Lorsque vous demandez des données à partir de listes Microsoft SharePoint dans Microsoft Access, vous pouvez recevoir l’un des messages d’erreur suivants :
- Des erreurs se sont produites lors de l’exécution de la requête en bloc ou de l’envoi de données au serveur. Reconnectez les tables pour résoudre les conflits ou ignorer les modifications en attente.
- Toutes les tables SharePoint sont déconnectées.
- Mise à jour impossible. La base de données ou l'objet est en lecture seule.
- Le moteur de base de données Microsoft Office Access n’a pas pu trouver l’objet «< nom> de la table liée ». Assurez-vous que l'objet existe et que vous avez correctement saisi son nom et son chemin d'accès.
- La table liée '<linked table name>' n’est pas disponible. Microsoft Access ne peut pas contacter le serveur. Vérifiez votre connexion réseau ou contactez l’administrateur du serveur.
- Vous ne disposez pas des autorisations nécessaires pour utiliser l’objet «< nom> de la table liée ». Demandez l’autorisation requise à votre administrateur système ou à la personne ayant créé cet objet.
Vous pouvez également rencontrer l’un des problèmes suivants :
- Access se ferme de façon inattendue ou se bloque lorsque vous essayez d’ouvrir une table liée.
- L’accès apparaît bloqué lorsque vous essayez d’ouvrir une table liée.
Cause
Quand Access demande des éléments de liste à partir d’une liste SharePoint, Access attend une période finie pour que ces données soient retournées. Plus précisément, si Access ne reçoit pas les données du lot donné après 30 secondes, il abandonne la demande et peut renvoyer le lot en tant que nouvelle requête. Si Access rencontre des échecs lors de l’envoi de ces lots, le programme peut abandonner et retourner un message d’erreur.
Voici quelques conditions susceptibles de provoquer ce problème :
- Il y a un problème avec l’intégrité de Microsoft SharePoint Server, par exemple, il s’exécute lentement.
- Vous disposez d’une connexion à faible bande passante.
- Vous disposez d’une liste ou d’une bibliothèque de documents SharePoint volumineuse ou complexe.
- Il y a une longue distance entre vous et le serveur.
- La liste ou la bibliothèque de documents SharePoint contient plus de 255 colonnes.
- Vous êtes limité lorsque vous utilisez SharePoint Online. Pour plus d’informations sur la limitation dans SharePoint Online, voir Éviter d’être limité ou bloqué dans SharePoint Online.
Résolution
Pour résoudre le problème, utilisez l’une des méthodes suivantes :
Méthode 1 : Réduisez le temps de réponse en évitant les conditions susceptibles d’entraîner les problèmes.
Méthode 2 : Réduisez la quantité de données demandées au serveur à l’aide d’une vue dans SharePoint, puis en liant Access à cette vue.
Pour plus d’informations sur la création d’une table liée qui utilise l’affichage SharePoint, voir ImporterSharePointList, action de macro.
Méthode 3 : Augmenter le délai d’attente dans Access en ajoutant l’entrée de Registre DataFetchTimeout
Importante
Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.
Remarque
L’entrée de Registre DataFetchTimeout initialement appliquée uniquement aux demandes de lecture quand Access synchronise ses données mises en cache avec la liste SharePoint. À compter de Access 2016 builds 16.0.9215.5830, cette entrée de Registre s’applique également aux opérations d’insertion, de mise à jour et de suppression.
Ajouter l’entrée de Registre DataFetchTimeout dans Access 2010
Appliquez le package de correctif logiciel suivant :
Description du package de correctifs logiciels Access 2010 (Stslist-x-none.msp) : 28 juin 2011
Ouvrez le Registre Rédacteur, puis recherchez et sélectionnez la sous-clé de Registre suivante :
Pour l’accès 32 bits sur Windows 32 bits ou l’accès 64 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Access Connectivity Engine\Engines
Pour l’accès 32 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Access Connectivity Engine\Engines
Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
Tapez DataFetchTimeout, puis appuyez sur Entrée.
Cliquez avec le bouton droit sur DataFetchTimeout, puis cliquez sur Modifier.
Sélectionnez Décimal dans Base, tapez 90000 dans la zone Données de la valeur, puis cliquez sur OK.
Si la valeur ne résout pas le problème, essayez une valeur plus élevée. DataFetchTimeout est en millisecondes.
Fermez l’Éditeur du Registre.
Ajouter l’entrée de Registre DataFetchTimeout dans Access 2013
Ouvrez le Registre Rédacteur, puis recherchez et sélectionnez la sous-clé de Registre suivante :
Pour l’accès 32 bits sur Windows 32 bits ou l’accès 64 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Access Connectivity Engine\Engines
Pour l’accès 32 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\15.0\Access Connectivity Engine\Engines
Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
Tapez DataFetchTimeout, puis appuyez sur Entrée.
Cliquez avec le bouton droit sur DataFetchTimeout, puis cliquez sur Modifier.
Sélectionnez Décimal dans Base, tapez 90000 dans la zone Données de la valeur, puis cliquez sur OK.
Si la valeur ne résout pas le problème, essayez une valeur plus élevée. DataFetchTimeout est en millisecondes.
Fermez l’Éditeur du Registre.
Ajoutez l’entrée de Registre DataFetchTimeout dans Access 2016
Ouvrez le Registre Rédacteur, puis recherchez et sélectionnez la sous-clé de Registre suivante :
Pour l’installation MSI d’Access
Pour l’accès 32 bits sur Windows 32 bits ou l’accès 64 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Access Connectivity Engine\Engines
Pour l’accès 32 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\16.0\Access Connectivity Engine\Engines
Pour l’installation « Démarrer en un clic » d’Access
Pour l’accès 32 bits sur Windows 32 bits ou l’accès 64 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Microsoft\Office\16.0\Access Connectivity Engine\Engines
Pour l’accès 32 bits sur Windows 64 bits
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\16.0\Access Connectivity Engine\Engines
Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
Tapez DataFetchTimeout, puis appuyez sur Entrée.
Cliquez avec le bouton droit sur DataFetchTimeout, puis cliquez sur Modifier.
Sélectionnez Décimal dans Base, tapez 90000 dans la zone Données de la valeur, puis cliquez sur OK.
Si la valeur ne résout pas le problème, essayez une valeur plus élevée. DataFetchTimeout est en millisecondes.
Fermez l’Éditeur du Registre.