« Connect-MsolService : l’exception de type a été levée » lorsque vous utilisez connect-MSOLService pour vous connecter à Microsoft 365, Azure ou Intune

Problème

Lorsque vous essayez d’utiliser l’applet de commande connect-MSOLService dans le module Microsoft Azure Active Directory pour Windows PowerShell vous connecter à un service cloud Microsoft tel que Microsoft 365, Azure ou Microsoft Intune, votre tentative échoue. Vous pouvez également recevoir le message d’erreur suivant :

Connect-MsolService: Exception of type 'Microsoft.Online.Administration.Automation.MicrosoftOnlineException' was thrown.

Remarque

Les modules PowerShell Azure AD et MSOnline sont déconseillés à compter du 30 mars 2024. Pour en savoir plus, lisez la mise à jour déconseillée. Après cette date, la prise en charge de ces modules est limitée à l’assistance à la migration vers le Kit de développement logiciel (SDK) Microsoft Graph PowerShell et aux correctifs de sécurité. Les modules déconseillés continueront de fonctionner jusqu’au 30 mars 2025.

Nous vous recommandons de migrer vers Microsoft Graph PowerShell pour interagir avec Microsoft Entra ID (anciennement Azure AD). Pour les questions courantes sur la migration, reportez-vous au FAQ sur la migration. Note: Les versions 1.0.x de MSOnline peuvent être interrompues après le 30 juin 2024.

Cause

Ce problème peut se produire pour une ou plusieurs des raisons suivantes :

  • Le module Azure Active Directory pour Windows PowerShell client riche ne peut pas se connecter au service. Cela est souvent le résultat de problèmes de préparation de l’ordinateur client.
  • L’ID utilisateur utilisé pour l’authentification unique (SSO) est activé, et un problème d’ordinateur client empêche la communication de l’authentification unique avec Services ADFS (AD FS), avec le système d’authentification Microsoft Entra ou avec les deux.

Solution

Pour résoudre ce problème, procédez comme suit :

  1. Résoudre les problèmes de connectivité client microsoft 365 riche. Pour plus d’informations, consultez Comment résoudre les problèmes des applications non-navigateur qui ne peuvent pas se connecter à Microsoft 365, Azure ou Intune.
  2. Résolvez les problèmes courants de configuration du client qui limitent l’authentification unique. Pour plus d’informations, consultez Se connecter à Microsoft 365, Azure ou Intune à l’aide de l’authentification unique ne fonctionne pas à partir de certains appareils.

Informations supplémentaires

Pour plus d’informations sur le module Azure Active Directory pour Windows PowerShell, consultez applets de commande Microsoft Entra.

Encore besoin d’aide ? Accédez au site web de la Communauté Microsoft ou Microsoft Entra Forums.