Partager via


Les messages actionnables s’affichent de manière incorrecte

Symptômes

Les messages actionnables sont rendus de manière incorrecte dans Microsoft Outlook.

La capture d’écran suivante montre un message actionnable qui s’affiche correctement.

Capture d’écran d’un message actionnable qui est affiché correctement.

La capture d’écran suivante montre le même message actionnable s’il est affiché de manière incorrecte.

Capture d’écran d’un message actionnable rendu de manière incorrecte.

Cause

Pour afficher correctement les messages actionnables, Outlook utilise la requête GET suivante pour obtenir l’URL du point de terminaison du protocole Actions à partir du service de découverte automatique V2 : https://outlook.office365.com/autodiscover/autodiscover.json/v1.0/<user email address>?protocol=actions.

Si la demande réussit, le service de découverte automatique V2 renvoie le code http status 200 et fournit l’URL demandée dans le corps de la réponse. Par exemple, le corps de la réponse peut être { "Protocol": "Actions", "Url": https://outlook.office365.com/actionsb2netcore }.

Toutefois, si le service de découverte automatique V2 est désactivé sur l’ordinateur de l’utilisateur sur lequel Outlook est installé, la requête GET échoue et Outlook ne peut pas se connecter au point de terminaison du protocole Actions.

Remarque

Le service de découverte automatique V2 est désactivé si l’entrée de DisableAutodiscoverV2Service Registre existe sous la Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover sous-clé et si la valeur DWORD de l’entrée DisableAutodiscoverV2Service est 1.

Résolution

Pour résoudre le problème, procédez comme suit pour activer le service de découverte automatique V2 sur l’ordinateur de l’utilisateur sur lequel Outlook est installé.

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour pallier à toute éventualité, sauvegardez le Registre avant de le modifier afin de pouvoir le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

  1. Si l’ordinateur de l’utilisateur est joint à un domaine et que votre organization contrôle la découverte automatique à l’aide de stratégie de groupe, assurez-vous que l’option Disable the Autodiscover V2 service n’est pas activée dans la stratégie de groupe Désactiver la découverte automatique.

  2. Exécutez regedit sur l’ordinateur de l’utilisateur sur lequel Outlook est installé.

  3. Accédez à la sous-clé de Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover Registre.

  4. Définissez la valeur DWORD de l’entrée 0 de DisableAutodiscoverV2Service Registre sur ou supprimez l’entrée de Registre.

  5. Supprimez les fichiers de cache de découverte automatique suivants :

    1. %LocalAppData%\Microsoft\Outlook\<any nom> de fichier partiel - Autodiscover.xml

    2. %LocalAppData%\Microsoft\Outlook\16\<any nom> de fichier.xml

    3. %LocalAppData%\Microsoft\Outlook\16\<any nom> de fichier.json

  6. Redémarrez Outlook.