Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Symptômes
Lorsque vous cliquez sur un dossier pendant que vous utilisez Microsoft Outlook, vous recevez l’un des messages d’erreur suivants :
Message d’erreur 1
Il n’y a pas assez de mémoire libre pour exécuter ce programme. Quittez un ou plusieurs programmes, puis réessayez.
Message d’erreur 2
Impossible d’afficher le dossier. Il n’y a pas assez de mémoire libre pour exécuter ce programme. Quittez un ou plusieurs programmes, puis réessayez.
Message d’erreur 3
Impossible d’afficher le dossier. Il n’y a pas assez de mémoire libre pour exécuter ce programme. Quittez un ou plusieurs programmes, puis réessayez.
Vous pouvez rencontrer ce problème plus fréquemment si vous utilisez des compléments dans Outlook.
Cause
Ce problème se produit car la mémoire est insuffisante pour afficher le dossier. Cela peut être dû à plusieurs raisons différentes. L’une de ces raisons est que des personnalisations, telles que la définition d’un filtre, ont été apportées à l’affichage des dossiers. Certains compléments dans Outlook s’abonnent à de nombreux dossiers dans tout ou partie des magasins du profil. Chaque abonnement MAPI utilise de la mémoire partagée. Par conséquent, de grandes combinaisons d’éléments et de dossiers peuvent épuiser la mémoire disponible.
Solution de contournement
Importante
Suivez attentivement les étapes de cette section. Des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Avant de modifier le Registre, sauvegardez-le pour restauration en cas de problèmes.
Pour contourner le problème décrit dans la section « Symptômes », augmentez la mémoire disponible. Pour augmenter la taille du tas de mémoire, procédez comme suit :
Quittez Outlook.
Sélectionnez Démarrer, Exécuter, tapez regedit, puis sélectionnez OK.
Recherchez puis sélectionnez la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem
Dans le menu Modifier , pointez sur Nouveau, puis sélectionnez Valeur DWORD.
Tapez SharedMemMaxSize, puis appuyez sur Entrée.
Cliquez avec le bouton droit sur SharedMemMaxSize, puis sélectionnez Modifier.
Dans la zone Données de la valeur , tapez 300000. Utilisez la valeur par défaut Base de hexadécimal.
Sélectionnez OK.
Recherchez puis sélectionnez la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook
Remarque
Vous devrez peut-être créer les sous-clés Applications et Outlook si elles n’existent pas.
Dans le menu Modifier , pointez sur Nouveau, puis sélectionnez Valeur DWORD.
Tapez SharedMemMaxSize, puis appuyez sur Entrée.
Dans la zone Données de la valeur , tapez 300000. Utilisez la valeur par défaut Base de hexadécimal.
Sélectionnez OK.
Dans le menu Fichier, sélectionnez Quitter pour fermer l’Éditeur du Registre.
Remarque
Si la définition des deux valeurs de Registre sur 0x300000 ne résout pas le problème, vous pouvez augmenter la taille de ces valeurs jusqu’à 0x800000.
Informations supplémentaires
Si un fichier de données Outlook volumineux (.pst) est ouvert dans Outlook, vous pouvez fermer le fichier .pst ou réduire le nombre de dossiers dans le fichier .pst pour résoudre le problème.
Si de nombreux compléments sont activés dans Outlook, vous pouvez les désactiver ou les désinstaller pour déterminer si cela résout le problème.
Pour plus d’informations, consultez l’article suivant de la Base de connaissances :
269794 appel MAPI Advise() retourne 0x8007000E (E_OUTOFMEMORY)