Email ne parvient pas à se synchroniser avec Microsoft Dynamics 365 lorsqu’il est encodé avec PEC
Cet article fournit une solution à un problème où le courrier électronique ne parvient pas à se synchroniser avec Microsoft Dynamics 365 lorsqu’il est encodé avec PEC.
S’applique à : Microsoft Dynamics CRM
Numéro de la base de connaissances d’origine : 4490718
Introduction
Que sont les e-mails PEC ?
Les e-mails PEC sont des e-mails certifiés qui sont utilisés dans certains pays/régions et qui ont la même validité juridique que les e-mails enregistrés (s/mime).
S/MIME (Secure/Multipurpose Internet Mail Extensions) est une méthode largement acceptée, ou plus précisément un protocole, pour envoyer des messages signés numériquement et chiffrés.
S/MIME vous permet de chiffrer les courriers électroniques et les signer numériquement.
Symptômes
Les e-mails PEC ne sont pas synchronisés avec Server-Side Synchronization ou Email Router.
Cause
Server-Side Synchronization et Email Router utilisent les services Web Exchange pour se connecter à un Exchange Server.
PEC et RFC6109 n’utilisent pas d’API via REST ou SOAP, car Server-Side synchronization et Email Router ne pourront pas synchroniser ces e-mails correctement.
Résolution
Lorsqu’un e-mail est chiffré, il crée un jeton qui est envoyé au destinataire de cet e-mail.
Cette relation un-à-un permet à un utilisateur d’envoyer un e-mail à un autre utilisateur et d’être chiffré.
Que se passe-t-il lorsqu’un e-mail chiffré est envoyé :
Comme Dynamics est une application tierce, lorsqu’il tente d’accéder à l’e-mail, il obtient uniquement cet e-mail dans un état chiffré.
Comme le jeton n’existe pas dans Dynamics 365, l’e-mail n’est pas déchiffré.
- Un chiffrement unique chiffre un e-mail.
- L’e-mail est encodé en texte chiffré.
- Email est envoyé et reçu.
- Le récepteur entre une clé de chiffrement pour décoder le message.
PEC et RFC6109 n’utilisent pas d’API via REST ou SOAP, car Server-Side Synchronisation et Email Routeur ne prend pas en charge ce type d’e-mail pour la synchronisation.
Pour que cet e-mail soit synchronisé avec votre organisation Dynamics 365, vous devez supprimer le chiffrement de l’e-mail, ce qui peut être obtenu en transférant l’e-mail.