Le destinataire ne reçoit pas d’e-mails envoyés par un utilisateur Microsoft Dynamics CRM à l’aide du client web Microsoft Dynamics CRM
Cet article fournit une résolution du problème que le destinataire ne peut pas recevoir de messages électroniques envoyés à partir du client web Microsoft Dynamics CRM.
S’applique à : Microsoft Dynamics CRM 2011
Numéro de base de connaissances d’origine : 915827
Symptômes
Lorsqu’un utilisateur Microsoft Dynamics CRM envoie un e-mail à l’aide du client web Microsoft Dynamics CRM 2011, le message électronique est envoyé ou mis en file d’attente. Toutefois, si un problème se produit lorsque l’utilisateur envoie le message électronique, l’utilisateur reçoit l’un des messages d’erreur suivants dans l’activité de messagerie.
Message d’erreur 1
Ce message n’a pas encore été envoyé pour remise. Jusqu’à présent, 1 tentatives ont été effectuées.
Message d’erreur 2
Échec de la remise des messages. Elle doit être renvoyée pour tout traitement supplémentaire.
En outre, vous recevez un message d’erreur semblable au suivant dans le journal des événements MSCRMEmailLog :
Type d’événement :Erreur
Source d’événement :MSCRMEmailLog
Catégorie d’événement :None
ID d’événement :0
Date : Date
Heure : heure
User :N/A
Ordinateur : ComputerName
Description : #61042 - Une erreur s’est produite lors du traitement du message électronique sortant avec l’objet « test 3 aujourd’hui CRM :0001011 » pour SMTP :https://adsrv:81/MS1
pour la remise via adsrv. System.Net.Mail.SmtpException : Échec de l’envoi du courrier. >--- System.Net.WebException : Impossible de se connecter au serveur distant --->
System.Net.Sockets.SocketException : Aucune connexion n’a pu être établie, car l’ordinateur cible l’a refusé activement
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
sur System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket&socket, IPAddress&address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception&exception)
--- Fin du suivi de la pile d’exceptions interne ---
at System.Net.ServicePoint.GetConnection(PooledStream PooledStream, Object owner, Boolean async, IPAddress&address, Socket&abortSocket, Socket&abortSocket6, Int32 timeout)
at System.Net.PooledStream.Activate(Object owningObject, Boolean async, Int32 timeout, GeneralAsyncDelegate asyncCallback)
sur System.Net.PooledStream.Activate(Object owningObject, GeneralAsyncDelegate asyncCallback)
at System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
sur System.Net.Mail.SmtpConnection.GetConnection(Hôte de chaîne, port Int32)
sur System.Net.Mail.SmtpTransport.GetConnection(Hôte de chaîne, port Int32)
sur System.Net.Mail.SmtpClient.GetConnection()
sur System.Net.Mail.SmtpClient.Send(Message MailMessage)
--- Fin du suivi de la pile d’exceptions interne ---
sur System.Net.Mail.SmtpClient.Send(Message MailMessage)
sur Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.SendMessage(MailMessage mailMessage)
sur Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(emailMessage)
chez Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage(emailmessage)
chez Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()Pour plus d’informations, consultez le Centre d’aide et de support à l’adresse
https://go.microsoft.com/fwlink/events.asp
.
Cause
Microsoft Dynamics CRM s’appuie sur le serveur SMTP local pour transférer des messages électroniques vers le serveur Exchange. Ce problème se produit pour l’une des raisons suivantes :
- La configuration SMTP sur le serveur Microsoft Dynamics CRM n’est pas configurée pour transférer les messages électroniques au serveur Exchange.
- Le serveur Exchange n’est pas configuré pour autoriser le relais de messages à partir du serveur Microsoft Dynamics CRM.
Résolution
Pour résoudre ce problème, effectuez les opérations suivantes :
Étape 1 : configurer SMTP sur le serveur Microsoft Dynamics CRM pour transférer des messages électroniques au serveur Exchange
- Sur le serveur Microsoft Dynamics CRM, ouvrez Internet Information Services (IIS). Pour ce faire, sélectionnez Démarrer, sélectionnez Outils d’administration, puis le Gestionnaire des services Internet (IIS).
- Dans le Gestionnaire iis (Internet Information Services), développez Le serveur virtuel SMTP par défaut, cliquez avec le bouton droit sur Domaines, pointez sur Nouveau, puis sélectionnez Domaine.
- Dans l’Assistant Nouveau SMTP, sélectionnez Remote sous Spécifier le type de domaine, puis sélectionnez Suivant.
- Tapez votre nom de domaine dans la zone Nom , puis sélectionnez Terminer.
- Dans le volet droit, cliquez avec le bouton droit sur le nom de domaine que vous avez ajouté aux étapes 2 à 4, puis sélectionnez Propriétés.
- Sous l’onglet Général , activez la case à cocher Autoriser le relais du courrier entrant vers ce domaine , puis sélectionnez Transférer tout le courrier à l’hôte intelligent. Dans la zone sous Transférer tous les messages à l’hôte intelligent, tapez le nom du serveur Exchange, puis sélectionnez OK.
- Redémarrez le service SMTP sur le serveur Microsoft Dynamics CRM. Pour ce faire, sélectionnez Démarrer, sélectionnez Outils d’administration, puis Services. Cliquez avec le bouton droit sur Smtp (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.
Étape 2 : configurer le serveur Exchange pour autoriser le relais de messages à partir du serveur Microsoft Dynamics CRM
Exchange Server 2003
Si vous utilisez Microsoft Exchange Server 2003, vous devez d’abord configurer les restrictions de relais, puis vérifier le contrôle connexions.
Configurer les restrictions de relais
Sélectionnez Démarrer, pointez sur Programmes, pointez sur Microsoft Exchange, puis sélectionnez System Manager.
Sélectionnez Serveurs, sélectionnez le nom du serveur Exchange, sélectionnez Protocoles, puis SMTP.
Cliquez avec le bouton droit sur Serveur virtuel SMTP par défaut, sélectionnez Propriétés, puis sélectionnez l’onglet Accès .
Dans la zone Restrictions de relais, sélectionnez Relay.
Vérifiez que l’option Uniquement la liste ci-dessous est sélectionnée, puis ajoutez le serveur Microsoft Dynamics CRM à la liste.
Si vous utilisez Microsoft Dynamics CRM 2011, veillez à ajouter le serveur sur lequel le routeur Exchange est installé dans la liste.
Redémarrez le service SMTP. Pour ce faire, procédez comme suit :
- Sélectionnez Démarrer, pointez sur Programmes, pointez sur Outils d’administration, puis sélectionnez Services.
- Cliquez avec le bouton droit sur Smtp (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.
Vérifier le contrôle Connexions
Sélectionnez Démarrer, pointez sur Programmes, pointez sur Microsoft Exchange, puis sélectionnez System Manager.
Sélectionnez Serveurs, sélectionnez le nom du serveur Exchange, sélectionnez Protocoles, puis SMTP.
Cliquez avec le bouton droit sur Serveur virtuel SMTP par défaut, sélectionnez Propriétés, puis sélectionnez l’onglet Accès .
Dans la zone Contrôle connexions, sélectionnez Connexion.
Par défaut, l’option Tout sauf la liste ci-dessous est sélectionnée. Si le serveur Microsoft Dynamics CRM est ajouté à cette liste, vous devez contacter l’administrateur Exchange pour déterminer la raison pour laquelle le serveur Microsoft Dynamics CRM a été ajouté.
Note
Pour que les messages électroniques Microsoft Dynamics CRM fonctionnent correctement, le serveur Microsoft Dynamics CRM doit être en mesure de se connecter au serveur Exchange.
Si l’option Uniquement la liste ci-dessous est sélectionnée, vous devez ajouter le serveur Microsoft Dynamics CRM à la liste pour lui permettre de se connecter au serveur Exchange.
Si vous avez apporté des modifications aux paramètres de contrôle de connexion, redémarrez le service SMTP. Pour ce faire, procédez comme suit :
- Sélectionnez Démarrer, pointez sur Programmes, pointez sur Outils d’administration, puis sélectionnez Services.
- Cliquez avec le bouton droit sur Smtp (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.
Exchange Server 2007
Si vous utilisez Microsoft Exchange Server 2007, vous devez créer un connecteur de réception Exchange, configurer le connecteur pour l’utilisateur anonyme, configurer les autorisations de protocole pour le connecteur de réception, puis redémarrer le service de transport Microsoft Exchange sur le serveur Exchange.
Créer un connecteur de réception Exchange
Ouvrez le console de gestion Exchange.
Développez Configuration du serveur.
Sélectionnez Transport Hub.
Cliquez avec le bouton droit sur Connecteurs de réception, puis sélectionnez Nouveau connecteur de réception.
Tapez un nom dans la zone Nom .
Dans la liste Sélectionner l’utilisation prévue pour cette liste de connecteurs De réception, sélectionnez Interne, puis Sélectionnez Suivant.
Dans la section Paramètres réseau distants, sélectionnez Ajouter, puis tapez l’adresse IP du serveur Microsoft Dynamics CRM.
Note
Si vous voyez la valeur 0.0.0.0-255.255.255.255.255, sélectionnez Supprimer.
Sélectionnez Suivant, sélectionnez Nouveau, puis Terminer.
Configurer le connecteur pour l’utilisateur anonyme
- Cliquez avec le bouton droit sur le connecteur de réception Exchange que vous avez créé, puis sélectionnez Propriétés.
- Sélectionnez l’onglet Groupes d’autorisations.
- Vérifiez que l’option Spécifier qui est autorisé à se connecter au connecteur de réception est définie sur Utilisateurs anonymes, sélectionnez Appliquer, puis sélectionnez OK.
Configurer les autorisations de protocole pour le connecteur de réception
Note
Les outils de support Windows doivent être installés pour effectuer ces étapes. Seul un administrateur expérimenté doit utiliser l’outil Adsiedit.msc.
- Démarrez l’outil Adsiedit.msc.
- Développez Configuration, développez Services, développez Microsoft Exchange, développez CN= Première organisation, développez Groupes d’administration, développez Groupe d’administration Exchange, développez Serveurs, protocoles, puis développez les connecteurs de réception SMTP.
- Cliquez avec le bouton droit sur le connecteur de réception Exchange que vous avez créé, puis sélectionnez Propriétés.
- Sélectionnez l'onglet Sécurité .
- Sélectionnez Ouverture de session anonyme.
- Activez la case à cocher Envoyer des messages à n’importe quel destinataire et la case Accepter l’expéditeur de domaine faisant autorité, sélectionnez Appliquer, puis ok.
Redémarrer le service de transport Microsoft Exchange sur le serveur Exchange
- Sélectionnez Démarrer, sélectionner Exécuter, taper services.msc, puis OK.
- Cliquez avec le bouton droit sur Le service de transport Microsoft Exchange, puis sélectionnez Redémarrer.