Bulletin de sécurité

Bulletin de sécurité Microsoft MS12-007 - Important

Une vulnérabilité dans la bibliothèque AntiXSS pourrait permettre la divulgation d’informations (2607664)

Date de publication : 10 janvier 2012 | Mise à jour : 16 janvier 2012

Version : 2.1

Informations générales

Résumé

Cette mise à jour de sécurité résout une vulnérabilité signalée en privé dans la bibliothèque Microsoft Anti-Cross Site Scripting (AntiXSS). La vulnérabilité peut autoriser la divulgation d’informations si un attaquant transmet un script malveillant à un site web à l’aide de la fonction de nettoyage de la bibliothèque AntiXSS. Les conséquences de la divulgation de ces renseignements dépendent de la nature de l’information elle-même. Notez que cette vulnérabilité ne permettrait pas à un attaquant d’exécuter du code ou d’élever directement ses droits d’utilisateur, mais qu’elle pourrait être utilisée pour produire des informations qui pourraient être utilisées pour tenter de compromettre davantage le système affecté. Seuls les sites qui utilisent le module de nettoyage de la bibliothèque AntiXSS sont affectés par cette vulnérabilité.

Cette mise à jour de sécurité est considérée comme importante pour la bibliothèque AntiXSS V3.x et la bibliothèque AntiXSS V4.0. Pour plus d’informations, consultez la sous-section Logiciels affectés et non affectés dans cette section.

La mise à jour corrige la vulnérabilité en mettant à niveau la bibliothèque AntiXSS vers une version qui n’est pas affectée par la vulnérabilité. Pour plus d’informations sur la vulnérabilité, consultez la sous-section Forum aux questions (FAQ) pour l’entrée de vulnérabilité spécifique dans la section suivante, Informations sur les vulnérabilités.

Recommandation. Microsoft recommande aux clients d’appliquer la mise à jour dès que possible.

Problèmes connus.L’article de la Base de connaissances Microsoft 2607664 documente les problèmes connus que les clients peuvent rencontrer lors de l’installation de cette mise à jour de sécurité. L’article décrit également les solutions recommandées pour ces problèmes.

Logiciels affectés et non affectés

Les logiciels suivants ont été testés pour déterminer quelles versions ou éditions sont affectées.

Logiciel affecté 

Logiciel Impact maximal sur la sécurité Agrégation de l’indice de gravité Bulletins remplacés par cette mise à jour
Bibliothèque de scripts de site microsoft anti-cross v3.x et bibliothèque de scripts de site anti-cross Microsoft v4.0[1][2] Information Disclosure (divulgation d’informations) Important None

[1]Ce téléchargement met à niveau la bibliothèque Microsoft Anti-Cross Site Scripting (AntiXSS) vers une version plus récente de la bibliothèque microsoft anti-cross site scripting qui n’est pas affectée par la vulnérabilité.

[2]Cette mise à niveau est disponible uniquement à partir du Centre de téléchargement Microsoft. Consultez la section suivante, Forum aux questions (FAQ) relative à cette mise à jour de sécurité.

Pourquoi ce bulletin a-t-il été réédité le11 janvier 2012 ?
Microsoft a réédité ce bulletin pour annoncer que le package de mise à niveau d’origine, AntiXSS Library version 4.2, a été remplacé par la bibliothèque AntiXSS version 4.2.1. La nouvelle version résout un problème d’affectation de noms qui entraînait l’échec de l’installation du package de mise à niveau d’origine dans certaines circonstances. Tous les utilisateurs de la bibliothèque AntiXSS devront effectuer une mise à niveau vers la bibliothèque AntiXSS version 4.2.1 pour s’assurer qu’ils sont protégés contre la vulnérabilité décrite dans ce bulletin.

Je suis développeur à l’aide de la bibliothèque AntiXSS.Ai-je juste besoin de la mise à jour sur mon système ?
Non. Les développeurs qui utilisent la bibliothèque AntiXSS doivent installer la mise à niveau décrite dans ce bulletin, puis déployer la bibliothèque mise à jour sur tous leurs sites web actifs qui utilisent la bibliothèque AntiXSS.

Cette mise à niveaucontient-elle des modifications de fonctionnalités liées à la sécurité ?
Oui. En plus des modifications répertoriées dans la section Informations sur les vulnérabilités de ce bulletin, la mise à niveau vers une version plus récente de la bibliothèque AntiXSS (bibliothèque AntiXSS version 4.2.1) modifie également les fonctionnalités de la façon dont les feuilles de style en cascade (CSS) sont gérées par la bibliothèque AntiXSS. L’entrée HTML dans l’assainisseur qui contient des styles, tels que des balises ou des attributs, sera supprimée. Pour les balises de style, le contenu de la balise est laissé derrière. Ce comportement est cohérent avec le comportement d’autres balises non valides.

Comment faire mettre à niveau ma version de la bibliothèque AntiXSS?
Les clients peuvent obtenir une version plus récente de la bibliothèque microsoft anti-site scripting (bibliothèque AntiXSS version 4.2.1) qui n’est pas affectée par la vulnérabilité en utilisant le lien de téléchargement dans la table Logiciels affectés de la section précédente, Logiciels affectés et non affectés.

Pourquoi la mise à niveauest-elledisponible uniquement à partir du Centre de téléchargement Microsoft ?
Microsoft publie la mise à niveau de la bibliothèque AntiXSS vers le Centre de téléchargement Microsoft uniquement. Étant donné que les développeurs déploient la bibliothèque mise à jour uniquement sur les sites web actifs qui utilisent la bibliothèque AntiXSS, d’autres méthodes de distribution, telles que la mise à jour automatique, ne conviennent pas à ce type de scénario de mise à niveau.

Informations sur la vulnérabilité

Niveaux de gravité et identificateurs de vulnérabilité

Les évaluations de gravité suivantes supposent l’impact maximal potentiel de la vulnérabilité. Pour plus d’informations sur la probabilité, dans les 30 jours suivant la publication de ce bulletin de sécurité, de l’exploitabilité de la vulnérabilité par rapport à son niveau de gravité et à son impact sur la sécurité, consultez l’index d’exploitabilité dans le résumé du bulletin de janvier. Pour plus d’informations, consultez Index d’exploitabilité Microsoft.

Logiciel affecté Vulnérabilité de contournement de bibliothèque AntiXSS - CVE-2012-0007 Agrégation de l’indice de gravité
Bibliothèque de scripts de site microsoft anti-cross v3.x et bibliothèque de scripts de site anti-cross Microsoft v4.0 Important \ Divulgation d’informations Important

Vulnérabilité de contournement de bibliothèque AntiXSS - CVE-2012-0007

Une vulnérabilité de divulgation d’informations existe lorsque la bibliothèque Microsoft Anti-Cross Site Scripting (AntiXSS) nettoie incorrectement le code HTML spécialement conçu. Un attaquant qui a réussi à exploiter cette vulnérabilité pourrait effectuer une attaque de script intersites (XSS) sur un site web qui utilise la bibliothèque AntiXSS pour assainir le code HTML fourni par l’utilisateur. Cela pourrait permettre à un attaquant de passer un script malveillant via une fonction de nettoyage et d’exposer des informations non destinées à être divulguées. Les conséquences de la divulgation de ces renseignements dépendent de la nature de l’information elle-même. Notez que cette vulnérabilité ne permettrait pas à un attaquant d’exécuter du code ou d’élever directement ses droits d’utilisateur, mais qu’elle pourrait être utilisée pour produire des informations qui pourraient être utilisées dans le but de compromettre davantage le système affecté.

Pour afficher cette vulnérabilité en tant qu’entrée standard dans la liste Des vulnérabilités et des expositions courantes, consultez CVE-2012-0007.

Facteurs atténuants pour la vulnérabilité de contournement de bibliothèque AntiXSS - CVE-2012-0007

L’atténuation fait référence à un paramètre, à une configuration courante ou à une bonne pratique générale, existant dans un état par défaut, qui pourrait réduire la gravité de l’exploitation d’une vulnérabilité. Les facteurs atténuants suivants peuvent être utiles dans votre situation :

  • Seuls les sites qui utilisent le module de nettoyage de la bibliothèque AntiXSS sont affectés par cette vulnérabilité.

Solutions de contournement de la bibliothèque AntiXSS - CVE-2012-0007

Microsoft n’a identifié aucune solution de contournement pour cette vulnérabilité.

FAQ sur la vulnérabilité de contournement de bibliothèque AntiXSS - CVE-2012-0007

Quelle est l’étendue de la vulnérabilité ? 
Il s’agit d’une vulnérabilité de divulgation d’informations. Un attaquant qui parvient à exploiter cette vulnérabilité peut passer un script malveillant via une fonction de nettoyage et exposer des informations non destinées à être divulguées. Notez que cette vulnérabilité ne permettrait pas à un attaquant d’exécuter du code ou d’élever directement ses droits d’utilisateur, mais qu’elle pourrait être utilisée pour collecter des informations qui pourraient être utilisées dans le but de compromettre davantage le système affecté.

Quelles sont les causes de la vulnérabilité ? 
La vulnérabilité est le résultat de la bibliothèque Microsoft Anti-Cross Site Scripting (AntiXSS) qui évalue de manière incorrecte certains caractères après la détection d’un caractère d’échappement CSS.

Qu’est-ce que la bibliothèque Anti-Cross Site Scripting (AntiXSS) ? 
La bibliothèque Microsoft Anti-Cross Site Scripting (AntiXSS) est une bibliothèque d’encodage conçue pour aider les développeurs à protéger leurs applications web ASP.NET contre les attaques XSS. Il diffère de la plupart des bibliothèques d’encodage en ce qu’il utilise la technique de liste blanche (parfois appelée le principe des inclusions) pour fournir une protection contre les attaques XSS. Cette approche fonctionne en définissant d’abord un ensemble de caractères valide ou autorisé, puis en encodant tout ce qui est extérieur à ce jeu (caractères non valides ou attaques potentielles). L’approche de liste verte offre plusieurs avantages par rapport aux autres schémas d’encodage.

Qu’est-ce qu’un attaquant peut utiliser la vulnérabilité pour faire ? 
Un attaquant qui a réussi à exploiter cette vulnérabilité pourrait effectuer une attaque de script intersites (XSS) sur un site web qui utilise la bibliothèque AntiXSS pour assainir le code HTML fourni par l’utilisateur. Un attaquant peut ensuite passer un script malveillant via une fonction de nettoyage et exposer des informations non destinées à être divulguées. Les conséquences de la divulgation de ces renseignements dépendent de la nature de l’information elle-même. Notez que cette vulnérabilité ne permettrait pas à un attaquant d’exécuter du code ou d’élever directement ses droits d’utilisateur, mais qu’elle pourrait être utilisée pour collecter des informations qui pourraient être utilisées dans le but de compromettre davantage le système affecté.

Comment un attaquant peut-il exploiter lavulnérabilité ? 
Pour exploiter cette vulnérabilité, un attaquant peut envoyer du code HTML spécialement conçu à un site web cible qui utilise le module de nettoyage de la bibliothèque AntiXSS. Lorsque la bibliothèque AntiXSS assainit incorrectement le code HTML, le script malveillant contenu dans le code HTML spécialement conçu peut être exécuté sur le serveur web affecté.

Quels sont les systèmes les plus exposés à la vulnérabilité ? 
Les serveurs web qui utilisent la bibliothèque AntiXSS sont exposés à cette vulnérabilité.

Que fait la mise à jour ? 
La mise à jour corrige la vulnérabilité en mettant à niveau la bibliothèque AntiXSS vers une version qui n’est pas affectée par la vulnérabilité.

Lors de la publication de ce bulletin de sécurité, cette vulnérabilité avait-elle été divulguée publiquement ? 
Non. Microsoft a reçu des informations sur cette vulnérabilité par le biais de la divulgation coordonnée des vulnérabilités.

Lorsque ce bulletin de sécurité a été émis, Microsoft a-t-il reçu des rapports indiquant que cette vulnérabilité était exploitée ? 
Non. Microsoft n’avait reçu aucune information indiquant que cette vulnérabilité avait été utilisée publiquement pour attaquer les clients lors de l’émission initiale de ce bulletin de sécurité.

Autres informations

Remerciements

Microsoft remercie les personnes suivantes d’avoir travaillé avec nous pour aider à protéger les clients :

Microsoft Active Protections Program (MAPP)

Pour améliorer les protections de sécurité pour les clients, Microsoft fournit des informations sur les vulnérabilités aux principaux fournisseurs de logiciels de sécurité avant chaque publication de mise à jour de sécurité mensuelle. Les fournisseurs de logiciels de sécurité peuvent ensuite utiliser ces informations de vulnérabilité pour fournir des protections mises à jour aux clients via leurs logiciels ou appareils de sécurité, tels qu’un antivirus, des systèmes de détection des intrusions basés sur le réseau ou des systèmes de prévention des intrusions basés sur l’hôte. Pour déterminer si les protections actives sont disponibles auprès des fournisseurs de logiciels de sécurité, consultez les sites web de protections actives fournis par les partenaires du programme, répertoriés dans Partenaires du programme Microsoft Active Protections (MAPP).

Support

  • Les clients aux États-Unis et au Canada peuvent bénéficier d’un support technique du support de sécurité ou du 1-866-PCSAFETY. Les appels de support associés aux mises à jour de sécurité ne sont pas facturés. Pour plus d’informations sur les options de support disponibles, consultez Aide et support Microsoft.
  • Les clients internationaux peuvent bénéficier d’un support de la part de leurs filiales Microsoft locales. La prise en charge associée aux mises à jour de sécurité n’est pas facturée. Pour plus d’informations sur la façon de contacter Microsoft pour des problèmes de support, visitez le site web du support international.

Clause d'exclusion de responsabilité

Les informations fournies dans la Base de connaissances Microsoft sont fournies « telles quelles » sans garantie d’aucune sorte. Microsoft rejette toutes les garanties, expresses ou implicites, y compris les garanties de qualité marchande et d’adéquation à un usage particulier. En aucun cas, Microsoft Corporation ou ses fournisseurs ne peuvent être tenus responsables de quelque dommage que ce soit, y compris les dommages directs, indirects, accessoires, consécutifs, la perte de bénéfices commerciaux ou les dommages spéciaux, même si Microsoft Corporation ou ses fournisseurs ont été informés de la possibilité de tels dommages. Certains États n’autorisent pas l’exclusion ou la limitation de responsabilité pour des dommages indirects ou accessoires, de sorte que la limitation ci-dessus peut ne pas s’appliquer.

Révisions

  • V1.0 (10 janvier 2012) : Bulletin publié.
  • V2.0 (11 janvier 2012) : annonce que le package de mise à niveau d’origine, AntiXSS Library version 4.2, a été remplacé par la bibliothèque AntiXSS version 4.2.1. Tous les utilisateurs de la bibliothèque AntiXSS devront effectuer une mise à niveau vers la bibliothèque AntiXSS version 4.2.1 pour s’assurer qu’ils sont protégés contre la vulnérabilité décrite dans ce bulletin. Pour plus d’informations, consultez le FAQ sur la mise à jour.
  • V2.1 (16 janvier 2012) : Ajout d’un lien vers l’article de la Base de connaissances Microsoft 2607664 sous Problèmes connus dans le résumé exécutif. En outre, entrée révisée dans le FORUM aux questions sur la mise à jour pour clarifier la raison pour laquelle la mise à niveau vers la bibliothèque AntiXSS version 4.2.1 est disponible uniquement à partir du Centre de téléchargement Microsoft.

Construit à 2014-04-18T13 :49 :36Z-07 :00