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Problèmes d’identité et d’autorisation SharePoint dans l’approbation de domaine bidirectionnelle

Symptômes

Supposons qu’il existe une approbation de domaine bidirectionnelle entre deux domaines (domaine A et domaine B). Les utilisateurs sont migrés vers le domaine B avec l’historique SID du domaine A, et les utilisateurs sont toujours actifs dans le domaine A. Dans une batterie de serveurs SharePoint qui réside dans l’un des domaines, vous pouvez rencontrer les problèmes suivants :

  • Les utilisateurs de l’un des domaines sont introuvables dans le sélecteur de personnes. Ce comportement peut être cohérent ou intermittent.

  • Lorsque vous essayez d’attribuer des autorisations à un utilisateur, le message d’erreur suivant s’affiche :

    L’utilisateur n’existe pas ou n’est pas unique.

  • Les utilisateurs perdent leurs autorisations sur les sites SharePoint, ou ils ne peuvent pas accéder aux sites SharePoint auxquels des autorisations leur sont attribuées.

  • Les données de profil utilisateur disparaissent de façon aléatoire.

Cause

Ce problème se produit parce que les assemblys .NET sous-jacents utilisés par SharePoint interrogent les comptes d’utilisateur par l’attribut objectSid. Lorsque deux comptes Active Directory partagent un historique SID (l’attribut objectSid d’un compte est répertorié dans l’attribut sidHistory d’un autre compte), les deux comptes sont fondamentalement considérés comme le même compte par Active Directory. Un appel à Active Directory pour récupérer les informations de compte peut renvoyer le compte à partir du domaine A ou du compte du domaine B.

Résolution

Ce scénario n’est pas pris en charge. SharePoint ne peut pas résider dans un domaine qui fait partie d’une approbation de domaine bidirectionnelle où les utilisateurs qui ont des comptes actifs dans les deux domaines partagent l’historique de SID. Chaque compte doit être unique. Pour vous assurer que c’est le cas, vous devez effectuer l’une des opérations suivantes dans Active Directory :

  • Désactivez le compte source.
  • Supprimez l’attribut objectSid du compte source de l’historique SID du compte de destination.

Informations supplémentaires

Encore besoin d’aide ? Accédez au site de la Communauté SharePoint.