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MSSQLSERVER_3201

S’applique à :SQL Server

Détails

Attribut Valeur
Nom du produit SQL Server
ID de l’événement 3201
Source de l’événement MSSQLSERVER
Composant SQLEngine
Nom symbolique BADOPEN
Texte du message Impossible d'ouvrir l'unité de sauvegarde '%ls'. Erreur %ls du système d'exploitation.

Explication

L’erreur se produit quand SQL Server n’est pas en mesure de créer ou d’ouvrir une unité de sauvegarde existante pour effectuer une opération de sauvegarde. Les périphériques de sauvegarde incluent des fichiers, des bandes, un appareil virtuel pour VDI. Le message inclut l’erreur du système d’exploitation déclenchée et retournée lors de l’exécution de l’accès à l’appareil. Cette erreur de système d’exploitation fournit des informations clés pour vous aider à comprendre la cause racine de la défaillance.

L’état de l’erreur peut également fournir des informations utiles. Voici quelques états utiles :

  • État 1 et 3 - créer un fichier de sauvegarde
  • État 2 - ouvrir le fichier de sauvegarde
  • État 5 - bande ouverte
  • État 7 : initialiser un appareil virtuel
  • État 6 : ouvrir un appareil virtuel
  • État 8 : ouvrir et obtenir la propriété d’un périphérique à bande

Causes possibles

Plusieurs raisons peuvent expliquer l’impossibilité d’accéder à un appareil de sauvegarde. Exemples courants :

  • L’appareil de sauvegarde n’est pas disponible ou n’est pas valide. Les exemples typiques d’erreurs de système d’exploitation associées à ce scénario sont les suivants : erreur 2 (le système ne trouve pas le fichier spécifié.), erreur 6 (le handle n’est pas valide), erreur 3 (Le système ne trouve pas le chemin spécifié.)
  • Des autorisations insuffisantes empêchent SQL Server d’y accéder: l’erreur du système d’exploitation de l’appareil 5 (accès refusé.), l’erreur du système d’exploitation 1117 (La demande n’a pas pu être effectuée en raison d’une erreur d’appareil d’E/S.)
  • L’appareil est endommagé ou contient des données endommagées ou endommagées : erreur du système d’exploitation 1117 (Impossible d’effectuer la requête en raison d’une erreur d’E/S. ), erreur du système d’exploitation 21 (L’appareil n’est pas prêt.), erreur du système d’exploitation 23 (erreur de données (vérification de redondance cyclique).), erreur du système d’exploitation 27 (Le lecteur ne trouve pas le secteur demandé).)

Action de l'utilisateur

Pour résoudre les erreurs dans lesquelles l’appareil n’est pas disponible ou non valide, assurez-vous que vous spécifiez l’emplacement correct de l’appareil (chemin d’accès, nom) et assurez-vous que l’appareil existe et est en ligne. Par exemple, utilisez l’Explorateur Windows pour accéder à un fichier de sauvegarde et vous assurer qu’il est présent. Pour la sauvegarde vers l’URL sur un compte de stockage Azure, vous pouvez effectuer un test ping ou PsPing sur le port 443 pour vérifier la connectivité.

Pour résoudre les erreurs d’autorisations insuffisantes, assurez-vous que le compte de démarrage SQL Server a obtenu un accès en lecture et en écriture à l’appareil de sauvegarde. Pour la sauvegarde dans une URL dans un cloud comme Azure, vérifiez qu’il existe un jeton de signature d’accès partagé (SAP) valide ou des identités managées pour accéder à une ressource Azure.

Les données endommagées ou endommagées sur les appareils sont généralement des problèmes avec le matériel ou moins souvent avec le système d’exploitation. Examinez avec votre administrateur système si l’appareil est intact et si vous pouvez y lire ou écrire des données de test, puis réparez ou remplacez l’appareil endommagé.