Erreur AADSTS750054 : SAMLRequest ou SAMLResponse doit être présent en tant que paramètres de chaîne de requête dans la requête HTTP pour la liaison de redirection SAML

Cet article décrit un problème dans lequel vous recevez le message d’erreur « Erreur AADSTS750054 - SAMLRequest ou SAMLResponse doit être présent en tant que paramètres de chaîne de requête dans la requête HTTP pour la liaison de redirection SAML . » lors de la tentative de connexion à une application configurée pour l’authentification unique (SSO) basée sur SAML qui a été intégrée à Microsoft Entra ID.

Symptômes

Vous recevez une erreur AADSTS750054 lors de la tentative de connexion à une application configurée pour utiliser Microsoft Entra ID pour la gestion des identités à l’aide de l’authentification unique SAML.

Cause

Microsoft Entra ID n’a pas pu identifier la requête SAML dans les paramètres d’URL de la requête HTTP. Cela peut se produire si l’application n’utilise pas la liaison de redirection HTTP lors de l’envoi de la requête SAML à Microsoft Entra ID.

Résolution

L’application doit envoyer la requête SAML encodée dans l’en-tête d’emplacement à l’aide de la liaison de redirection HTTP. Pour plus d’informations sur la façon de l’implémenter, consultez la section Liaison de redirection HTTP dans le document de spécification du protocole SAML.

Le plus souvent, l’erreur est due à l’un des problèmes suivants :

  1. Vérifiez que l’authentification unique est activée côté application.
  2. L’application doit prendre en charge l’authentification unique lancée par le fournisseur de services (parfois appelée authentification unique lancée par le fournisseur de services). L’entrée d’une URL de connexion pour une application qui prend uniquement en charge l’authentification unique lancée par le fournisseur d’identité peut entraîner un rebond de l’application sans réponse SAML.
  3. Vérifiez que l’URL de connexion est correctement configurée.

Utilisation de la fonction Test SSO dans le centre d'administration Microsoft Entra

Le centre d'administration Microsoft Entra peut vous aider à résoudre les erreurs de configuration SAML.

Capture d’écran du test de la fonctionnalité d’authentification unique dans centre d'administration Microsoft Entra.

  1. Dans la centre d'administration Microsoft Entra, accédez à Applications d’entreprise et cliquez sur l’application nécessitant une résolution des problèmes.
  2. Accédez à la page Authentification unique à l’aide du menu de navigation de gauche
  3. Cliquez sur Tester cette application pour utiliser la fonctionnalité Tester l’authentification unique.
  4. Copiez et collez l’erreur reçue dans la section Résolution des erreurs , puis cliquez sur Obtenir des conseils de résolution
  5. Suivez les étapes pour résoudre les erreurs AADSTS750054

Informations supplémentaires

Pour obtenir la liste complète des codes d’erreur d’authentification et d’autorisation Active Directory, consultez Microsoft Entra codes d’erreur d’authentification et d’autorisation.

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