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Le pare-feu du système d’exploitation invité de la machine virtuelle Azure est mal configuré

S’applique à : ✔️ Machine virtuelles Windows

Cet article explique comment corriger un pare-feu de système d’exploitation invité mal configuré sur une machine virtuelle Azure.

Symptômes

  1. L’écran d’accueil de la machine virtuelle indique que la machine virtuelle est entièrement chargée.

  2. Selon la configuration du système d’exploitation invité, un trafic réseau peut ou non atteindre la machine virtuelle.

Cause

Une configuration incorrecte du pare-feu du système invité peut bloquer certains ou tous les types de trafic réseau vers la machine virtuelle.

Solution

Avant de suivre ces étapes, prenez un instantané du disque système de la machine virtuelle affectée comme sauvegarde. Pour plus d’informations, consultez Créer un instantané.

Pour résoudre ce problème, utilisez la console série ou réparez la machine virtuelle en mode hors connexion en attachant le disque système de la machine virtuelle à une machine virtuelle de récupération.

Atténuations en ligne

Connectez-vous à la console série et ouvrez une instance PowerShell. Si la console série n’est pas activée sur la machine virtuelle, accédez à la section « Réparer la machine virtuelle en mode hors connexion » de l’article Azure suivant :

Erreur interne en cas de connexion à une machine virtuelle Azure avec le Bureau à distance

Les règles suivantes peuvent être modifiées pour activer l’accès à la machine virtuelle (via RDP) ou faciliter la résolution du problème :

  • Bureau à distance (TCP-Entrée) : Il sʼagit de la règle standard qui fournit lʼaccès principal à la machine virtuelle en autorisant RDP dans Azure.

  • Gestion à distance de Windows (HTTP-Entrée) : cette règle vous permet de vous connecter à la machine virtuelle à lʼaide de PowerShell. Dans Azure, ce type dʼaccès vous permet dʼutiliser lʼaspect de script et le dépannage à distance.

  • Partage de fichiers et dʼimprimantes (SMB-Entrée) : Cette règle active lʼaccès au partage réseau en tant quʼoption de dépannage.

  • Partage de fichiers et dʼimprimantes (Demande dʼécho - Trafic entrant ICMPv4) : Cette règle vous permet dʼenvoyer une requête ping à la machine virtuelle.

Dans l’instance d’accès à la console série, vous pouvez interroger l’état actuel de la règle de pare-feu.

  • Interrogation avec le nom d’affichage en tant que paramètre :

    netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(DisplayName.*<FIREWALL RULE NAME>)" -context 9,4 | more
    
  • Interrogation avec le port local utilisé par l’application :

    netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(LocalPort.*<APPLICATION PORT>)" -context 9,4 | more
    
  • Interrogation avec le port local utilisé par l’application :

    netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(LocalIP.*<CUSTOM IP>)" -context 9,4 | more
    
  • Si vous voyez que la règle est désactivée, vous pouvez l’activer en exécutant la commande suivante :

    netsh advfirewall firewall set rule name="<RULE NAME>" new enable=yes
    
  • Pour le dépannage, vous pouvez DÉSACTIVER les profils de pare-feu :

    netsh advfirewall set allprofiles state off
    

    Si vous procédez ainsi pour régler correctement le pare-feu, activez-le à nouveau après avoir résolu le problème.

    Note

    Vous n’êtes pas obligé de redémarrer la machine virtuelle pour appliquer ce changement.

  • Essayez à nouveau de vous connecter à la machine virtuelle via RDP.

Atténuations hors connexion

  1. Pour activer ou désactiver des règles de pare-feu, consultez Activer ou désactiver une règle de pare-feu sur le système d’exploitation invité d’une machine virtuelle Azure.

  2. Vérifiez si vous êtes dans le scénario de blocage du trafic entrant par le pare-feu du système d’exploitation invité.

  3. Si vous soupçonnez toujours le pare-feu de bloquer votre accès, consultez Désactiver le pare-feu du système d’exploitation invité dans une machine virtuelle Azure, puis réactivez le pare-feu du système invité à l’aide des règles correctes.

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.