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S’applique à : ✔️ Machine virtuelles Windows
Cet article vous aide à résoudre le problème lorsque vous ne pouvez pas vous connecter à une machine virtuelle Azure, car aucun serveur de licences des services Bureau à distance n’est disponible pour fournir une licence.
Symptômes
Lorsque vous essayez de vous connecter à une machine virtuelle, vous rencontrez les situations suivantes :
La capture d’écran de la VM montre que le système d’exploitation est entièrement chargé et attend des informations d’identification.
Lorsque vous essayez d’établir une connexion de Microsoft RDP (Remote Desktop Protocol), les messages d’erreur suivant s’affichent :
La session distante a été déconnectée, car aucun serveur de licences des services Bureau à distance n’est disponible pour fournir une licence.
Aucun serveur de licences des services Bureau à distance n’est disponible. Les services Bureau à distance cesseront de fonctionner, car cet ordinateur a dépassé la période de grâce et n’a pas contacté au moins un serveur de licences Windows Server 2008 valide. Sélectionnez ce message pour ouvrir la configuration du serveur hôte de session Bureau à distance et utiliser le diagnostic des licences.
Une erreur de licence s’est produite pendant que le client tentait de se connecter (la licence a expiré). Réessayez de vous connecter à l’ordinateur distant.
La connexion RDP semble être bloquée dans lʼétat « Configuration de la session à distance ».
Cause
Ce problème survient si un serveur de licences des services Bureau à distance n’est pas disponible pour fournir une licence permettant de démarrer une session à distance. Il peut avoir plusieurs origines, même si un rôle Hôte de session Bureau à distance a été configuré sur la machine virtuelle :
- Il n’a jamais eu de rôle de licences Bureau à distance dans l’environnement et la période de grâce de 180 jours est écoulée.
- Une licence Bureau à distance a été installée dans l’environnement, mais elle n’a jamais été activée.
- Une licence Bureau à distance a des licences d’accès client (CAL) et elle a été activée. Toutefois, il y a plus d’utilisateurs actifs que de CAL disponibles.
- Aucune licence d’accès client (CAL) n’a été injectée dans une licence Bureau à distance de l’environnement pour configurer la connexion.
- Une licence Bureau à distance a été installée dans l’environnement. Des licences d’accès client sont disponibles, mais elles n’ont pas été configurées correctement.
- Une licence Bureau à distance a des licences d’accès client et elle a été activée. Toutefois, d’autres problèmes sur le serveur de licences des services Bureau à distance l’empêchent de fournir des licences dans l’environnement.
Solution
Pour résoudre ce problème, sauvegardez le disque du système d’exploitation et procédez comme suit :
Connectez-vous à la machine virtuelle à l’aide d’une session d’administration : Pour cela, appliquez l’une des méthodes suivantes :
Exécutez la commande suivante :
mstsc /v:<Server>[:<Port>] /admin
Dans le portail Azure, accédez à la machine virtuelle, sélectionnez Se connecter sous Paramètres. Dans le panneau de droite, sélectionnez Télécharger le fichier RDP pour télécharger un fichier de connexion.
Si vous ne pouvez pas vous connecter à la machine virtuelle à l’aide d’une session d’administration, vous pouvez utiliser la console série de la machine virtuelle sur Azure pour accéder à la machine virtuelle comme suit :
Accédez à la Console série en sélectionnant Support et dépannage>Console série. Si la fonctionnalité est activée sur la machine virtuelle, vous pouvez connecter la machine.
Créez un canal pour une instance CMD. Entrez CMD pour démarrer le canal et en obtenir le nom.
Basculez vers le canal qui exécute l’instance CMD. Dans ce cas, il devrait s’agir du canal 1 :
ch -si 1
Sélectionnez de nouveau Entrée et entrez un nom d’utilisateur et un mot de passe valides ainsi qu’un ID local ou de domaine pour la machine virtuelle.
Vérifiez si un rôle Hôte de session Bureau à distance est activé sur la machine virtuelle. Si le rôle est activé, assurez-vous qu’il fonctionne correctement. Ouvrez une instance CMD avec élévation de privilèges et procédez comme suit :
Utilisez la commande suivante pour vérifier l’état du rôle Hôte de session Bureau à distance :
reg query "HKLM\SOFTWARE\Microsoft\ServerManager\ServicingStorage\ServerComponentCache\RDS-RD-Server" /v InstallState
Si cette commande renvoie la valeur 0, cela signifie que le rôle est désactivé. Passez à l’étape 3.
Utilisez la commande suivante pour vérifier les stratégies et, au besoin, reconfigurez-les :
reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode reg query "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers
Si LicensingMode a une valeur autre que 4, par utilisateur, réglez-le sur 4 :
reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode /t REG_DWORD /d 4
Si la valeur SpecifiedLicenseServers n’existe pas ou si les informations du serveur de licences sont incorrectes, modifiez-la comme suit :
reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "<FQDN / IP License server>"
Après avoir modifié le registre, redémarrez la machine virtuelle.
Si vous n’avez pas de CAL ou si vous n’avez pas besoin de plus de deux utilisateurs simultanés, supprimez le rôle Hôte de session Bureau à distance. Ensuite, RDP sera mis en arrière pour n’autoriser que deux connexions RDP simultanées à la machine virtuelle :
dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services
Si la machine virtuelle a le rôle de licences Bureau à distance et qu’il n’est pas utilisé, vous pouvez également le supprimer :
dism /ONLINE /Disable-feature /FeatureName:Licensing
Assurez-vous que la machine virtuelle peut se connecter au serveur de licences de services Bureau à distance. Vous pouvez tester la connectivité au port 135 entre la machine virtuelle et le serveur de licences :
telnet <FQDN / IP License Server> 135
S’il n’y a aucun serveur de licences des services Bureau à distance dans l’environnement et que vous en souhaitez un, vous pouvez installer un service de rôle Gestionnaire de licences des services Bureau à distance. Configurer ensuite les licences des services Bureau à distance.
Si un serveur de licences des services Bureau à distance est configuré et intègre, assurez-vous qu’il est activé avec des licences d’accès client.
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