Partager via


Un trop grand nombre de sessions administrateur s’affichent lorsque vous essayez de vous connecter à une machine virtuelle Azure Windows

S’applique à : ✔️ Machine virtuelles Windows

Cet article vous aide à résoudre l’erreur « trop de sessions d’administration ouvertes » lorsque vous essayez de vous connecter à une machine virtuelle Windows Azure.

Symptômes

Lorsque vous essayez de vous connecter à une machine virtuelle Windows Azure à l’aide du protocole RDP (Remote Desktop Protocol), vous recevez le message d’erreur suivant :

Trop de sessions d’administration s’ouvrent.

Toutefois, vous pouvez vous connecter à la machine virtuelle à l’aide d’une session RDP administrative (mstsc /admin).

Cause

Le problème se produit si vous avez atteint le nombre maximal autorisé de connexions RDP simultanées.

Résolution

Avant de commencer la résolution des problèmes, sauvegardez le disque du système d’exploitation. Ensuite, procédez comme suit :

  1. Connectez-vous à la machine virtuelle à l’aide de la console série Azure, puis démarrez une session PowerShell. Si la console série Azure ne fonctionne pas, connectez-vous à la machine virtuelle à l’aide de PowerShell distant. Pour plus d’informations, consultez Comment utiliser les outils à distance pour résoudre les problèmes de machine virtuelle Azure.

  2. Après vous être connecté à la machine virtuelle, exécutez la commande suivante pour identifier le paramètre de connexion maximal actuel pour le service RDP :

    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core" /v MaxConnections
    

    Si la valeur n’existe pas, le service utilise le paramètre par défaut qui autorise un nombre illimité de connexions RDP.

    Si la valeur existe, exécutez la commande suivante pour définir la valeur MaxConnections sur 0 pour autoriser des connexions RDP illimitées :

    reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core" /v MaxConnections /t REG_DWORD /d 0xffffffff /f 
    
  3. Redémarrez la machine virtuelle, puis réessayez de vous connecter à la machine virtuelle.

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.