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S’applique à : ✔️ Machine virtuelles Windows
Cet article fournit des étapes pour résoudre les problèmes où Windows ne peut pas démarrer et doit redémarrer en raison d’informations de configuration système incorrectes dans une machine virtuelle Azure (VM).
Symptôme
Quand vous utilisez les Diagnostics de démarrage pour voir la capture d’écran de la machine virtuelle, vous pouvez constater que la machine virtuelle affiche le code #0x00000074 ou BAD_SYSTEM_CONFIG_INFO.
Votre PC a rencontré un problème et doit redémarrer. Vous pouvez le redémarrer. Pour plus d’informations sur ce problème et les solutions possibles, visitez https://windows.com/stopcode Si vous appelez une personne du support, donnez-lui ces informations : Code d’arrêt : BAD_SYSTEM_CONFIG_INFO
Cause
Le code d’arrêt BAD_SYSTEM_CONFIG_INFO se produit si la ruche de registre SYSTEM semble être corrompue. Cette erreur peut être causée par l’une de ces raisons :
- La ruche de registre n’a pas été fermée correctement.
- La ruche de registre est corrompue.
- Il manque des clés ou des valeurs de registre.
Solution
Vue d’ensemble du processus
Conseil
Si vous disposez d’une sauvegarde récente de la machine virtuelle, vous pouvez essayer de restaurer la machine virtuelle à partir de la sauvegarde pour résoudre le problème de démarrage.
Corrigez l’altération de la ruche.
Activez la console série et la collecte d’images mémoire.
Reconstruisez la machine virtuelle.
Note
Lorsque vous rencontrez cette erreur, le système d’exploitation invité (OS) n’est pas opérationnel. Vous effectuerez le dépannage en mode hors connexion pour résoudre ce problème.
Corriger l’altération de la ruche
Corrigez la ruche endommagée en procédant comme suit :
Supprimez la machine virtuelle.
Important
Lorsque vous êtes invité à confirmer la suppression de la machine virtuelle, veillez à décochez l’option Supprimer avec la machine virtuelle associée au type de ressource de disque du système d’exploitation.
Attachez le disque du système d’exploitation en tant que disque de données à une autre machine virtuelle (une machine virtuelle de dépannage). Pour plus d’informations, consultez Attacher un disque de données managé à une machine virtuelle Windows à l’aide du Portail Azure.
Connectez-vous à la machine virtuelle de dépannage.
Sélectionnez Démarrer, puis recherchez et sélectionnez Gestion de l’ordinateur. Dans l’arborescence de la console de l’application Gestion de l’ordinateur, sélectionnez Gestion des disques. Assurez-vous que le disque du système d’exploitation est en ligne et que des lettres de lecteurs sont affectées à ses partitions.
Sur le disque du système d’exploitation que vous avez attaché, accédez au dossier \Windows\System32\config . Copiez tous les fichiers dans un dossier de sauvegarde pour le cas où une restauration serait requise.
Sélectionnez Démarrer, puis recherchez et sélectionnez Éditeur du Registre (regedit.exe).
Dans l’application Éditeur du Registre, sélectionnez la sous-arborescence HKEY_USERS, sélectionnez Hive de>chargement de fichier dans le menu, puis chargez le fichier \Windows\System32\config\SYSTEM.
Si la ruche se charge sans problème, cela signifie que la ruche n’a pas été fermée correctement. Dans ce cas, déchargez la ruche pour déverrouiller le fichier et résoudre le problème.
Note
Si le message d’erreur suivant s’affiche, contactez le support Azure :
Impossible de charger <lecteur> :\Windows\System32\config\SYSTEM : Erreur lors du chargement de Hive
Détachez le disque du système d’exploitation de la machine virtuelle de dépannage. Ensuite, créez une machine virtuelle à partir du disque du système d’exploitation.
Activer la console série et la collecte d’images mémoire
Recommandé : avant de reconstruire la machine virtuelle, activez la console série et la collecte de vidage mémoire en procédant comme suit :
Ouvrez une invite de commandes avec élévation de privilèges exécutée avec les privilèges Administrateur.
Exécutez les commandes BCDEdit suivantes à l’aide des options /ems et /emssettings :
Activez la console série :
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Vérifiez que l’espace libre sur le disque du système d’exploitation est supérieur à la taille de la mémoire (RAM) sur la machine virtuelle.
Si l’espace sur le disque de système d’exploitation est insuffisant, modifiez l’emplacement où le fichier de vidage de la mémoire sera créé et assignez cet emplacement à tout disque de données connecté à la machine virtuelle qui dispose de suffisamment d’espace libre. Pour modifier l’emplacement, remplacez
%SystemRoot%
par la lettre de lecteur du disque de données, telle queF:
, dans les commandes suivantes.Pour activer le fichier de vidage du système d’exploitation, exécutez les commandes charger, ajouter et décharger suivantes pour implémenter la configuration suggérée à l’aide de l’outil reg :
Chargez la ruche du Registre à partir du disque de système d’exploitation endommagé :
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Activer sur ControlSet001 :
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Activer sur ControlSet002 :
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Décharger le disque du système d’exploitation endommagé :
reg unload HKLM\<broken-system>
Reconstruire la VM
Utilisez l’étape 5 des commandes de réparation de VM pour reconstruire la VM.
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