Notes
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Cet article vous aide à résoudre une erreur qui se produit lorsque vous essayez d’importer un fichier de certificat de clé privée SSL (Secure Sockets Layer) (.pfx) dans le magasin de certificats personnel de l’ordinateur local à l’aide du Gestionnaire des services Iis (Microsoft Internet Information Services).
Version du produit d’origine : Internet Information Services
Numéro de base de connaissances d’origine : 919074
Important
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, consultez les informations de Registre Windows pour les utilisateurs avancés.
Symptômes
Vous essayez d’importer un fichier .pfx SSL dans le magasin de certificats personnel de l’ordinateur local. Dans ce cas, vous pouvez rencontrer l’un des symptômes suivants, en fonction de la façon dont vous essayez d’importer le fichier .pfx :
Si vous essayez d’importer le fichier .pfx à l’aide du Gestionnaire IIS, vous recevez le message d’erreur suivant :
Impossible d’importer le fichier pfx. Vous avez entré un mot de passe incorrect pour ce fichier ou le certificat a expiré.
Si vous essayez d’importer le fichier .pfx à l’aide du composant logiciel enfichable MMC (Certificates Microsoft Management Console), vous recevez le message d’erreur suivant :
Une erreur interne s’est produite. Il peut s’agir du profil utilisateur qui n’est pas accessible ou de la clé privée que vous importez peut nécessiter un fournisseur de services de chiffrement qui n’est pas installé sur votre système.
Cause
Ce comportement se produit lorsqu’une ou plusieurs des conditions suivantes sont remplies :
- Vous disposez d’autorisations insuffisantes pour accéder au
DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys
dossier sur l’ordinateur. - Une sous-clé de Registre tierce existe qui empêche IIS d’accéder au fournisseur de services de chiffrement.
- Vous êtes connecté à l’ordinateur à distance via une session Terminal Services. Et le profil utilisateur n’est pas stocké localement sur le serveur sur lequel terminal Services est activé.
Pour résoudre ce comportement, utilisez l’une des résolutions suivantes, en fonction de votre situation.
Résolution 1 : Définir les autorisations correctes pour le dossier MachineKeys
Si vous avez des autorisations insuffisantes pour accéder au DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys
dossier sur l’ordinateur, définissez les autorisations appropriées pour le dossier.
Pour plus d’informations sur la définition des autorisations pour le dossier MachineKeys, consultez Autorisations par défaut pour les dossiers MachineKeys.
Résolution 2 : Supprimer la sous-clé de Registre tierce
Avertissement
Des problèmes graves peuvent survenir si vous modifiez le Registre incorrectement à l’aide de l’Éditeur du Registre ou d’un autre procédé. Ces problèmes peuvent nécessiter la réinstallation du système d’exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous modifiez le Registre à vos propres risques.
Si la sous-clé de Registre suivante existe, supprimez-la :
HKEY_USERS\Default\Software\Microsoft\Cryptography\Providers\Type 001
Après avoir supprimé cette sous-clé de Registre, IIS peut accéder au fournisseur de services de chiffrement.
Résolution 3 : Stocker le profil utilisateur pour la session Terminal Services localement
Si le profil utilisateur de la session Terminal Services n’est pas stocké localement sur le serveur sur lequel les services Terminal Services sont activés, déplacez le profil utilisateur vers le serveur sur lequel terminal services sont activés. Vous pouvez également utiliser des profils itinérants.
État
Ce comportement est normal.