Les scripts côté client ne fonctionnent plus dans Microsoft Dynamics CRM Online après la mise à jour du service de décembre 2012
Cet article vous aide à corriger les erreurs de script après la mise à jour de votre Microsoft Dynamics CRM Online organization vers la mise à jour du service de décembre 2012.
S’applique à : Microsoft Dynamics CRM Online
Numéro de la base de connaissances d’origine : 2804561
Symptômes
Si vos formulaires utilisent l’API cliente V4.0 (crmForm), vous pouvez rencontrer des erreurs de script après la mise à jour de votre Microsoft Dynamics CRM Online organization vers la mise à jour du service de décembre 2012. Vous pouvez voir apparaître une boîte de dialogue indiquant « Non défini », ou vous pouvez voir une erreur dans le coin inférieur gauche du formulaire indiquant « Erreur sur la page ». D’autres erreurs de script peuvent apparaître.
Cause
La mise à jour du service de décembre 2012 pour Microsoft Dynamics CRM introduit un nouveau paramètre système qui contrôle si les composants HTML (HTC) sont inclus dans les formulaires Microsoft Dynamics CRM. Ce paramètre est désactivé par défaut dans Microsoft Dynamics CRM Online.
Les propriétés crmForm suivantes nécessitent HTC :
Propriétés crmForm |
---|
. Enregistrer( |
. SaveAndClose( |
. FormType |
. ObjectTypeCode |
. Objectid |
. ObjectTypeName |
. RequiredLevel |
. SetFocus( |
. FireOnChange |
. Min |
. Max |
. DataValue |
.isDirty |
. Handicapés |
. SelectedOption |
. SelectedText |
. SortingEnum |
. Sorte |
. SelectedIndex |
. InnerText |
. OptionsXml |
. Précision |
. DataXml |
. Texte |
. Valeur |
. DisplayValue |
. WillSubmit |
. DataChangeHandler |
. BypassValidation |
. AllowFormFocus |
._bSaving |
._htcInitCompleted |
. SubmitFormId |
.NO_DATA |
. RefreshOnSave |
. Visible |
. ForceSubmit |
. Forme |
. Timecontrol |
.isInitialized |
.allowblankdate |
. IsMoney |
. IsBaseCurrency |
. CurrencySymbol |
. DevisePrecision |
. IgnoreCurrencySymbol |
. IgnoreRange |
. PrecisionChangeHandler |
. TrimValue |
. Maxlength |
Énumérateur |
Résolution
- Connectez-vous à l’application web Microsoft Dynamics CRM en tant qu’administrateur système.
- Cliquez sur Paramètres, sur Administration, puis sur Paramètres système.
- Cliquez sur l’onglet Personnalisation .
- Cochez la case en regard du paramètre intitulé Inclure la prise en charge de HTC dans Microsoft Dynamics CRM formulaires.
- Cliquez sur OK.
Plus d’informations
L’API crmForm a été déconseillée avec la version Microsoft Dynamics CRM 2011. Pour plus d’informations sur cette rubrique et sur d’autres causes potentielles d’erreurs de script après la mise à jour du service de décembre 2012, consultez les billets de blog suivants :
Commentaires
Envoyer et afficher des commentaires pour