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Cet article fournit une solution à une erreur qui se produit lorsque vous sélectionnez le champ Numéro de bon de commande dans la fenêtre Entrée de bon de commande ou lorsque vous sélectionnez le champ Numéro de reçu dans la fenêtre Entrée de transaction de réception dans Microsoft Dynamics GP.
Note
Avant de suivre les instructions de cet article, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème se produit.
S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 968056
Symptômes
Lorsque vous sélectionnez le champ Numéro de bon de commande dans la fenêtre Entrée de bon de commande dans Microsoft Dynamics GP ou dans Microsoft Business Solutions - Great Plains 8.0, vous recevez le message d’erreur suivant :
Un numéro de bon de commande unique n’a pas pu être attribué. Vérifiez le champ Numéro suivant dans la fenêtre Configuration du traitement des bons de commande.
Ou bien, lorsque vous sélectionnez le champ Reçu N° dans la fenêtre Saisie de transactions de réception dans Microsoft Dynamics GP ou dans Microsoft Business Solutions - Great Plains 8.0, vous recevez le message d’erreur suivant :
Un numéro de reçu unique n’a pas pu être attribué. Vérifiez le champ Numéro suivant dans la fenêtre Configuration du traitement des bons de commande.
Cause
Ce problème a une ou plusieurs des causes suivantes :
Cause 1
Le numéro de bon de commande suivant ou le numéro de reçu suivant dans la fenêtre Installation du traitement des bons de commande a déjà été utilisé. Pour résoudre ce problème, consultez la résolution 1.
Cause 2
Le champ Numéro suivant pour les commandes d'achat ou pour les reçus dans la fenêtre de configuration du traitement des bons de commande ne contient pas suffisamment de zéros de tête pour passer au nombre suivant. Pour résoudre ce problème, consultez la résolution 1 et la résolution 2.
Cause 3
Les options régionales et linguistiques sur la station de travail diffèrent de ces paramètres sur le serveur. Pour résoudre ce problème, consultez la résolution 3.
Cause 4
Les données de la fenêtre Configuration du traitement des bons de commande sont endommagées. Voir la résolution 4.
Résolution
Pour résoudre ce problème, utilisez l’une des résolutions suivantes.
Résolution 1 : Augmenter le numéro de bon de commande suivant ou le numéro de reçu suivant d’un
Pour utiliser cette méthode, procédez comme suit :
Démarrez la console Administrateur de support, Microsoft SQL Query Analyzer ou SQL Server Management Studio. Pour ce faire, utilisez l’une des méthodes suivantes en fonction du programme que vous utilisez.
Méthode 1 : pour le moteur de bureau SQL Server
Si vous utilisez le moteur de bureau SQL Server (également appelé MSDE 2000), démarrez la console Administrateur de support. Pour ce faire, sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Console Administrateur Microsoft, puis sélectionnez Console Administrateur du support.
Méthode 2 : pour SQL Server 2000
Si vous utilisez SQL Server 2000, démarrez SQL Query Analyzer. Pour ce faire, sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server, puis sélectionnez Analyseur de requête.
Méthode 3 : pour SQL Server 2005
Si vous utilisez SQL Server 2005, démarrez SQL Server Management Studio. Pour ce faire, sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2005, puis sélectionnez SQL Server Management Studio.
Méthode 4 : pour SQL Server 2008
Si vous utilisez SQL Server 2008, démarrez SQL Management Studio. Pour ce faire, sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2008, puis sélectionnez SQL Server Management Studio.
Exécutez les scripts suivants sur la base de données de l’entreprise pour déterminer le plus grand numéro de bon de commande utilisé.
SELECT max (PONUMBER) as 'max po number: WORK' FROM POP10100 SELECT max (PONUMBER) as 'max po number: HIST' FROM POP30100
Exécutez les scripts suivants sur la base de données d’entreprise pour déterminer le plus grand nombre de reçus utilisé.
SELECT max (POPRCTNM) as 'max receipt number: WORK' FROM POP10300 SELECT max (POPRCTNM) as 'max receipt number: HIST' FROM POP30300
Exécutez les scripts suivants sur la base de données de l’entreprise pour déterminer le numéro de bon de commande suivant.
SELECT PONUMBER as 'next PO number' FROM POP40100
Exécutez les scripts suivants sur la base de données d’entreprise pour déterminer le numéro de reçu suivant.
SELECT POPRCTNM as 'next receipt number' FROM POP40100
Note
- La table POP10100 est la table de travail des bons de commande.
- La table POP30100 correspond à la table Historique des bons de commande.
- La table POP10300 correspond à la table Travail des reçus d’achat.
- La table POP30300 correspond à la table Historique des reçus d’achat.
- La table POP40100 est la table de configuration des achats.
Dans la fenêtre Installation du traitement des bons de commande, vérifiez que le numéro de bon de commande suivant ou le numéro de reçu suivant est supérieur à la valeur obtenue à l’étape 2.
Utilisez la méthode appropriée pour votre version du programme :
Microsoft Dynamics GP 10.0
Sélectionnez Microsoft Dynamics GP, pointez sur Outils, pointez sur Configurer, pointez sur Achat, puis sélectionnez Traitement des bons de commande.
Microsoft Dynamics GP 9.0 ou Microsoft Great Plains 8.0
Sélectionnez Outils, pointez sur Configurer, pointez sur Achat, puis sélectionnez Traitement des bons de commande.
Résolution 2 : Ajouter des zéros de tête au numéro suivant de bon de commande ou de reçu
Si le numéro de bon de commande ou le numéro de reçu n’est pas incrémenté, ajoutez des zéros initiaux au numéro de bon de commande suivant ou au numéro de reçu suivant. Pour ce faire, procédez comme suit :
Utilisez la méthode appropriée pour votre version du programme :
Microsoft Dynamics GP 10.0
Dans le menu Microsoft Dynamics GP , pointez sur Outils, pointez sur Configurer, pointez sur Achat, puis sélectionnez Traitement des bons de commande.
Microsoft Dynamics GP 9.0 ou Microsoft Great Plains 8.0
Dans le menu Outils , pointez sur Configurer, pointez sur Achat, puis sélectionnez Traitement des bons de commande.
Dans la colonne Numéro Suivant, entrez les zéros initiaux aux valeurs des champs suivants :
- Commandes d’achat
- Reçus
Cliquez sur OK.
Résolution 3 : Modifier les options de format et la langue régionales
Modifiez les options de format régional et la langue afin que les paramètres correspondent aux mêmes paramètres sur le serveur. Pour ce faire, procédez comme suit :
- Sur la station de travail, sélectionnez Démarrer, puis Exécutez.
- Tapez intl.cpl, puis sélectionnez OK.
- Répétez les étapes 1 et 2 sur le serveur.
- Vérifiez que les paramètres de la fenêtre Options régionales et linguistiques de la station de travail correspondent aux mêmes paramètres sur le serveur.
Résolution 4 : Modifier la table de configuration des achats
Modifiez la table de configuration des achats pour résoudre le problème. Vous pouvez utiliser l’option Activer l’insertion d’identité pour éviter les enregistrements en double, ou vous pouvez recréer la table. Pour ce faire, utilisez la méthode appropriée.
Méthode 1 : Éviter les enregistrements dupliqués dans la table de configuration des achats (POP40100)
Pour éviter les enregistrements dupliqués dans la Table de configuration d'achat (POP40100) à l'avenir, sélectionnez l'option Activer l'insertion d'identité lorsque vous utilisez les Data Transformation Services (DTS) ou l'Assistant Importation et Exportation SQL Server pour transférer des données d'une base de données à une autre.
Méthode 2 : recréer la table d'installation d'achat (POP40100)
Remarque
- Avant d'utiliser cette méthode, vous devez demander à tous les utilisateurs de se déconnecter de Microsoft Dynamics GP et de Microsoft Great Plains 8.0.
- Avant d’utiliser cette méthode, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème se produit. Pour recréer la table De configuration d’achat, utilisez l’une des méthodes suivantes.
Méthode 2A : Utiliser le kit d'outils de la bibliothèque de services professionnels (PSTL)
Installez le kit de ressources PSTL. Pour ce faire, procédez comme suit :
Pour plus d’informations sur la bibliothèque d’outils de services professionnels, utilisez l’une des options suivantes :
Clients :
Pour plus d’informations sur pstl, contactez votre partenaire d’enregistrement. Si vous n’avez pas de partenaire enregistré, visitez Microsoft Pinpoint pour identifier un partenaire.Partenaires :
Pour plus d’informations sur PSTL, consultez Partner Network.Copiez le fichier .cnk de la bibliothèque Professional Services Tools vers le répertoire Microsoft Dynamics GP ou le répertoire Microsoft Great Plains 8.0 sur l’ordinateur exécutant Microsoft Dynamics GP ou Microsoft Great Plains 8.0.
Connectez-vous à Microsoft Dynamics GP ou à Microsoft Great Plains 8.0. Lorsque vous êtes invité à inclure un nouveau code, sélectionnez Oui.
Sélectionnez le raccourci du kit de ressources PSTL dans la barre de raccourcis pour initialiser les tables.
Remarque
Si le raccourci du kit de ressources PSTL n’apparaît pas dans la barre de raccourcis, ajoutez le raccourci. Pour ce faire, procédez comme suit :
Utilisez la méthode appropriée pour votre version du programme.
Microsoft Dynamics GP 10.0
Sélectionnez Disposition. Vérifiez que l’option volet de navigation est sélectionnée.
Microsoft Dynamics GP 9.0 ou Microsoft Great Plains 8.0
Sélectionnez Affichage, puis volet de navigation.
Utilisez la méthode appropriée pour votre version du programme.
Microsoft Dynamics GP 10.0
Cliquez avec le bouton droit sur Raccourcis, pointez sur Ajouter, puis cliquez sur Ajouter une fenêtre.
Microsoft Dynamics GP 9.0 ou Microsoft Great Plains 8.0
Sélectionnez Ajouter, puis sélectionnez Autre fenêtre.
Développez Technical Service Tools, développez Project, sélectionnez Professional Services Tools Library, puis sélectionnez Ajouter.
Cliquez sur Terminé.
Lorsque vous êtes invité à entrer le code d’inscription des utilitaires, sélectionnez OK.
Sélectionnez Toolkit, puis sélectionnez Suivant.
Sélectionnez Recréer des objets SQL, puis sélectionnez Suivant.
Dans la liste Séries , sélectionnez Achat.
Dans la liste de table, sélectionnez la table POP40100.
Sélectionnez Recréer la table sélectionnée.
Cochez la case Recréer des données pour les tables sélectionnées.
Sélectionnez Effectuer la maintenance sélectionnée.
Méthode 2B : Exécuter la fonction maintenance SQL
Imprimez le rapport liste d’installation POP pour obtenir les informations d’installation actuelles. Pour ce faire, procédez comme suit :
- Sélectionnez Rapports, pointez sur Achat, puis sélectionnez Configuration/Listes.
- Dans la fenêtre Rapports de configuration d'achat, sélectionnez Paramétrage du processus de commande dans la liste des Rapports, spécifiez l'option du rapport, puis sélectionnez Imprimer.
Note
La table de configuration des achats restera vide tant que les informations ne soient ré-entrées dans la fenêtre de configuration du traitement des bons de commande.
Utilisez la méthode appropriée pour votre version du programme.
Microsoft Dynamics GP 10.0
Pointez sur Maintenance dans le menu Microsoft Dynamics GP, puis sélectionnez SQL.
Microsoft Dynamics GP 9.0 ou Microsoft Great Plains 8.0
Pointez sur Maintenance dans le menu Fichier, puis sélectionnez SQL.
Dans la liste des bases de données, sélectionnez la base de données de l'entreprise que vous utilisez.
Dans la colonne Nom, sélectionnez Table de configuration d'achat.
Sélectionnez les cases à cocher suivantes :
- Recompiler
- Mettre à jour les statistiques
- DROP TABLE
- Créer une table
- Supprimer la procédure automatique
- Créer une procédure automatique
Sélectionnez Processus.