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Fenêtre de consultation du solde du carnet de chèques dans Microsoft Dynamics GP

Cet article fournit des conseils de dépannage concernant l'utilisation de la fenêtre Consultation de solde de chéquier dans Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP, Microsoft Dynamics SL Bank Reconciliation
Numéro de base de connaissances d’origine : 3100541

Symptômes

Pourquoi existe-t-il un solde de début dans la fenêtre d'interrogation du solde du carnet de chèques lorsque vous n’en avez pas saisi ?

Note

Accédez à cette fenêtre, sélectionnez Enquête, pointez sur Financial et sélectionnez Checkbook Balance.

Cause

Le fait d’avoir un solde dans la première ligne de la fenêtre de consultation du solde de chèquier ne signifie pas nécessairement qu'il s'agit du solde initial qui a été saisi. La fenêtre calcule à partir du bas vers le haut. Le calcul commence par le solde actuel du Checkbook, puis ajoute à nouveau les paiements et soustrait les dépôts du bas de la fenêtre en remontant vers le haut. Ainsi, tout ce qui reste est répertorié comme solde restant à la première ligne. Espérons qu'il correspond bien au solde de début que vous avez saisi. Mais si ce n’est pas le cas, il peut être causé par des problèmes plus récents et les données sont endommagées.

Exemple :

Le solde actuel du checkbook aujourd’hui est de 20 000,00 $
Aucun solde d'ouverture n'a été saisi.

La consultation sur le solde du carnet de chèques peut afficher :

ligne 1 - Paiement de 5 000 $, Dépôt - aucun, Solde 33 000 $
ligne 2 - Paiement de 6 000 $, Dépôt - aucun, Solde 28 000 $
ligne 3 - Paiement de 4 000 $, Dépôt - aucun, Solde 22 000 $
ligne 4 - Paiement - aucun, dépôt de 2 000 $, solde de 18 000 << $ calcul commence au bas et passe à la hausse

La fenêtre ci-dessus montre qu’un solde de début de 33 000 $ a été saisi, mais ce n’est pas le cas. Le calcul dans la fenêtre a commencé avec le solde de 20 000 $ d’aujourd’hui, puis a commencé avec la ligne 4 et a soustrait le dépôt de 2 000 $ pour obtenir un nouveau solde de 18 000 $. Ensuite, il est remonté à la ligne 3 et a réintégré le paiement de 4 000 $ pour obtenir 22 000 $, puis a procédé à une série d'additions et de soustractions successives. Quand il est arrivé à la ligne 1, le montant restant est de 33 000 $ en raison de la façon dont la fenêtre calcule, car aucun solde initial n’a été saisi pour ce scénario. Pour l’utilisateur, il se peut qu’il se demande à tort où vient le solde de départ de 33 000 $, et ce n’est pas le cas. Il apparaît simplement sur la ligne Balance pour la ligne 1 en raison de la façon dont les calculs se font vers le haut dans cette fenêtre. L’utilisateur doit maintenant passer en revue les données actuelles pour voir s’il peut trouver un problème avec les données endommagées pour cette quantité. Les conseils sont fournis dans la section suivante.

Résolution

Pour comprendre pourquoi le montant du solde dans la première ligne de la fenêtre d'interrogation du solde du chéquier est incorrect, vous devrez analyser les données. Vous trouverez ci-dessous quelques conseils de dépannage. Mais si vous avez besoin d'aide de la part d'un ingénieur du support technique, cela dépasse ce que nous ferions normalement dans un cas de support régulier, car cela est dû à des données endommagées. Ouvrez un dossier de support et nous allons y jeter un coup d’œil, mais l’ingénieur pourrait devoir vous orienter vers le service de conseil, ce qui est une dépense facturable.

Conseils de dépannage

  • Si vous rencontrez un problème dans la fenêtre de consultation du solde du carnet de chèques, vous avez très probablement un problème dans la fenêtre de rapprochement des relevés bancaires, car le solde du carnet ajusté est calculé de la même manière. Ainsi, la première étape consisterait à déterminer la dernière fois que votre rapprochement bancaire était équilibré. La date endommagée a plus que probablement eu lieu entre maintenant et la dernière fois que vous avez réconcilié. Par conséquent, si vous avez réconcilié votre solde de chéquier à la banque au 31 août et que nous sommes maintenant en octobre, vous devrez examiner les données de septembre et d’octobre afin de rechercher les écarts.

  • Voici quelques scripts SQL que vous pouvez exécuter pour rechercher des données endommagées dans la table Banque Rec. Exécutez-les sur la base de données d’entreprise dans SQL Server Management Studio. Les résultats de ces scripts doivent être examinés plus loin :

    select * from CM20200 where GLPOSTDT = '1900-01-01'
    
    SELECT CHEKBKID, CMTRXNUM, CMTRXTYPE, TRXDATE, TRXAMNT from CM20200 
    group by CHEKBKID, CMTRXNUM, CMTRXTYPE, TRXDATE, TRXAMNT having count (*) > 1
    
    select * from CM20200 where Checkbook_Amount = '0.00000' and TRXAMNT <> '0.00000'
    
  • Demandez aux utilisateurs s'ils se souviennent d'avoir eu des problèmes de comptabilisation avec des lots dans les Comptes fournisseurs, la Paie, le Grand Livre ou les Dépôts dans la Réconciliation Bancaire. Souvent, ils peuvent se souvenir d'une interruption de comptabilisation que vous pouvez examiner plus en détail, ou même d'un problème de maintenance qu'ils ont essayé de corriger et où ils ont saisi des ajustements d'augmentation ou de diminution supplémentaires ou des annulations (et peut-être ne l'ont-ils pas fait correctement). Les utilisateurs sont souvent un endroit idéal pour découvrir les problèmes à examiner plus en détail.