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Type de transaction CM pour un ajustement d’augmentation qui a été incorrectement modifié en chèque (CHQ) après sélection de l'option "Annuler la transaction" dans le rapprochement bancaire.

Cet article fournit une solution à un problème où le type de transaction CM pour un ajustement à la hausse a été modifié incorrectement en Chèque (CHQ) après avoir sélectionné Transaction annulée dans la Réconciliation Bancaire pour Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 2522239

Symptômes

Si une transaction d’ajustement d’augmentation publiée est récupérée dans la fenêtre d'Entrée de transaction bancaire (en saisissant l’ID de chéquier et le numéro) avec l’option « Transaction annulée », puis la fenêtre est fermée au lieu de publier l’annulation ou si le bouton Effacer est utilisé, au lieu d’annuler la transaction sélectionnée, cette transaction est modifiée de l’ajustement d’augmentation (IAJ) à chèque (CHQ).

Note

Ce comportement n’est visible que lorsque les champs Id du Checkbook et Number sont tapés manuellement dans la fenêtre Transaction bancaire, au lieu de les sélectionner dans le bouton Rechercher .

En outre, dans la fenêtre d’enquête sur le solde de chèques, le montant de cette transaction apparaît dans la colonne Paiement, au lieu de la colonne Dépôt, ce qui rend le solde sur la transaction particulière semble incorrect, car le champ Solde dans cette fenêtre d’enquête est calculé dynamiquement. La fenêtre traite le montant comme une réduction de l’équilibre au lieu d’une augmentation. (Toutefois, le solde actuel du carnet de chèques est correct.)

Lorsque le type de transaction est passé de l’IAJ (Augmentation de l'ajustement) au CHQ (Chèque), les systèmes le considèrent désormais comme un chèque et s’il est annulé, le solde du carnet de chèques sera incorrectement augmenté au lieu d'être réduit.

Cause

Lorsqu’un type de transaction autre que Le chèque est sélectionné pour l’annulation dans la fenêtre Entrée de transaction bancaire et que le bouton Effacer est utilisé ou que la fenêtre est fermée au lieu d’annuler la transaction sélectionnée, le type de transaction est remplacé par un type de chèque (CHQ) dans la table CM20200, si le numéro de transaction a été entré manuellement dans le champ Numéro de la fenêtre Entrée de transaction bancaire, au lieu de le sélectionner dans le bouton Rechercher . Si la recherche est utilisée pour localiser la transaction, le type de transaction n’est pas mis à jour lorsque la fenêtre est fermée ou que le bouton Effacer est utilisé. Cela fait apparaître le solde incorrect dans la fenêtre de consultation du registre de chèques.

Note

Ce problème se produit uniquement lorsque le module Canadian Payroll est installé dans une installation canadienne de GP. Il est enregistré en tant que CR #8627.

Résolution

Ce problème se produit uniquement lorsque vous tapez manuellement l’ID de chèque ou le numéro dans la fenêtre Transactions bancaires. Par conséquent, pour contourner ce problème, ne tapez pas le numéro de transaction et utilisez plutôt le bouton Rechercher (loupe) pour sélectionner l’ID de chèque et le numéro de transaction dans la liste.

N’annulez pas la transaction une fois que le type IAJ a changé en CHQ, sinon le solde du carnet de chèques sera incorrectement augmenté. Selon le type de transaction qu’il a été, vous pouvez simplement mettre à jour le type de transaction (CMTRXTYPE) directement dans la table CM20200 avant de l’annuler, mais il doit être testé dans un environnement de test en premier. Si vous avez besoin d’aide supplémentaire pour ce problème, vous pouvez ouvrir un cas avec le support microsoft Dynamics GP et faire référence à CR #8627.