Erreur lorsque vous essayez de démarrer Microsoft Dynamics GP sur un ordinateur sur lequel les imprimantes nommées sont activées : l’application doit fermer

Cet article fournit une solution à un problème où vous ne parvenez pas à démarrer Microsoft Dynamics GP sur un ordinateur sur lequel les imprimantes nommées sont activées.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 909739

Symptômes

Lorsque vous essayez de démarrer Microsoft Dynamics GP, vous pouvez rencontrer le problème suivant. Lorsque vous cliquez sur OK dans la boîte de dialogue Connexion de l’entreprise, Microsoft Dynamics GP se ferme de manière inattendue sans message d’erreur. Ou microsoft Dynamics GP se ferme de façon inattendue et vous recevez plutôt le message d’erreur suivant :

L’application doit se fermer.

Cause

Ce problème se produit si les conditions suivantes sont remplies :

  • Les imprimantes nommées sont activées sur l’ordinateur sur lequel vous essayez de démarrer Microsoft Dynamics GP.
  • L’une des conditions suivantes est remplie :
    • L’imprimante par défaut de la série de tâches Système n’existe plus. Or, l’imprimante par défaut des tâches de l'entreprise n’existe plus.
    • Les pilotes d’imprimante ont été modifiés pour l’imprimante par défaut pour la série de tâches Système ou pour la série de tâches d’entreprise par défaut. Ou, les pilotes d’imprimante ne sont pas valides. Lorsque vous démarrez Microsoft Dynamics GP, l’imprimante par défaut de Microsoft Dynamics GP est remplacée par l’imprimante par défaut pour la série de tâches Système dans la fenêtre Options des imprimantes nommées.

Résolution

Pour résoudre ce problème, désactivez temporairement les imprimantes nommées sur l’ordinateur afin que l’imprimante par défaut de Microsoft Dynamics GP ne soit pas modifiée lorsque vous démarrez le programme. Ensuite, démarrez Microsoft Dynamics GP, puis configurez correctement les imprimantes nommées. Une fois cette opération terminée, activez les imprimantes nommées. Pour ce faire, procédez comme suit :

  1. Double-cliquez sur le fichier Dex.ini.

  2. Dans le fichier, recherchez la ligne suivante :
    ST_SetDefault=TRUE

  3. Remplacez la valeur du paramètre ST_SetDefault par FALSE.

  4. Enregistrez les modifications, puis fermez le fichier.

  5. Démarrez Microsoft Dynamics GP.

  6. Dans le menu Outils , cliquez sur Configurer, sur Système, puis sur Imprimantes nommées.

  7. Modifiez les paramètres de l’imprimante par défaut pour la série de tâches Système afin de spécifier une imprimante qui existe.

  8. Modifiez les paramètres de l’imprimante par défaut pour la série de tâches Société afin de spécifier une imprimante qui existe.

    Note

    Cette étape est facultative. Vous devez uniquement effectuer cette opération si une imprimante par défaut pour la série de tâches d’entreprise est déjà configurée.

  9. Quittez Microsoft Dynamics GP.

  10. Double-cliquez sur le fichier Dex.ini.

  11. Remplacez la valeur du paramètre ST_SetDefault par TRUE.

Note

Vous pouvez désactiver temporairement les imprimantes nommées en plaçant un point-virgule devant le paramètre ST_MachineID= dans le fichier Dex.ini au lieu de définir le paramètre ST_MachineID= sur FALSE.