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Erreur lorsque vous essayez de publier un lot dans Microsoft Dynamics GP : « La procédure stockée glpPostBatch a retourné les résultats suivants : SGBD : 0, Great Plains : 20286 »

Cet article fournit une solution à une erreur qui se produit lorsque vous publiez un lot dans Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 898996

Symptômes

Lorsque vous essayez de publier un lot dans Microsoft Dynamics GP, vous recevez le message d’erreur suivant :

La procédure stockée glpPostBatch a retourné les résultats suivants : SGBD : 0, Great Plains : 20286
glpPostBatch. La sélection sur Batch_Headers a échoué.

Cause

Ce problème se produit pour l’une des raisons suivantes :

  • La publication de la table maîtresse des définitions (SY00500) est endommagée.
  • Problème de procédure stockée manquante ou endommagée pour 'dbo.glpPostBatch'.
  • Déclencheur manquant sur la table SY00500 après l'avoir régénérée.
  • Enregistrement bloqué dans les tables d'activité SY00800/SY00801 de la base de données Dynamics.

Résolution

Note

Avant de suivre les instructions de cet article, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème se produit.

Pour résoudre ce problème, recréez la table maître des définitions de publication (SY00500). Pour ce faire, vous pouvez utiliser l’une des deux options. Les étapes de l’option 1 : utilisez la maintenance des fichiers pour supprimer tous les enregistrements de lot figurant dans la table maître des définitions de publication. Les étapes de l’option 2 : Utiliser l’outil gratuit de la bibliothèque d'outils de services professionnels pour conserver les enregistrements de lots existants à l’aide de la bibliothèque d'outils de services professionnels (PSTL). Cet outil vous aidera à recréer la table maître de définition de publication et à recréer les procédures stockées et les procédures automatiques sans perdre de données.

Option 1 : Utiliser la maintenance des fichiers

  1. Assurez-vous que tous les utilisateurs quittent Microsoft Dynamics GP.

  2. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur SQL.

  3. Dans la liste des bases de données, sélectionnez la base de données de l’entreprise.

  4. Dans la liste des tables, cliquez sur Publication de définitions master. (qui est le tableau SY00500)

  5. Cliquez pour activer les cases à cocher suivantes :

    • Recompiler
    • Mettre à jour les statistiques
    • Supprimer la table
    • Créer une table
    • Supprimer la procédure automatique
    • Créer une procédure automatique
  6. Cliquez sur Traiter.

  7. Recréez les lots pour chaque module dans lequel vous avez des lots non postés. Pour ce faire, suivez les étapes de chaque module.

    • Comptabilité générale

      1. Dans le menu Microsoft Dynamics GP , pointez sur Outils, pointez sur Utilitaires, pointez sur Finances, puis cliquez sur Rapprocher.
      2. Dans la boîte de dialogue Rapprochement des informations financières, cliquez sur la case à cocher Lots puis cliquez sur Rapprocher.
      3. Lorsque vous êtes invité à imprimer le rapport du journal des erreurs, cliquez sur Annuler.
    • Gestion des comptes fournisseurs

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.

      2. Dans la liste Série , cliquez sur Achat.

        Note

        Si vous n’utilisez pas le module multicurrency, passez à l’étape 7.

      3. Dans la liste Tables logiques, sélectionnez Fichiers logiques d’historique des fournisseurs, puis cliquez sur Insérer.

      4. Cliquez sur OK.

      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.

      6. Fermez la boîte de dialogue Rapport d’erreurs de maintenance des fichiers.

      7. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.

      8. Dans la liste Série , cliquez sur Achat.

      9. Dans la liste de Tables logiques, sélectionnez Fichier logique des transactions à payer, puis cliquez sur Insérer.

      10. Cliquez sur OK.

      11. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.

    • Traitement des bons de commande

      1. Dans le menu Fichier , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Série , cliquez sur Achat.
      3. Dans la liste Tables logiques , sélectionnez Transactions d’achat, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
    • Gestion des créances

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Séries , cliquez sur Ventes.
      3. Dans la liste Tables logiques, sélectionnez Fichiers de transactions ouvertes des comptes clients, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
    • Les factures

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Séries , cliquez sur Ventes.
      3. Dans la liste Tables logiques , sélectionnez Travail de facture, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
    • Traitement des commandes commerciales

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Séries , cliquez sur Ventes.
      3. Dans la liste Tables logiques , sélectionnez Sales Work, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
    • Inventaire

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Série , cliquez sur Inventaire.
      3. Dans la liste Tables logiques , sélectionnez Travail de transaction d’inventaire, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
      6. Dans le menu Transactions , pointez sur Inventaire, puis cliquez sur Lots.
      7. Cliquez sur le bouton d’enregistrement suivant pour afficher le premier lot d’inventaire.
      8. Cliquez pour activer la case à cocher Publier dans le registre général.
      9. Répétez les étapes 7 et 8 pour chaque lot.
    • Nomenclature

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.
      2. Dans la liste Série , cliquez sur Inventaire.
      3. Dans la liste Tables logiques, sélectionnez Transactions de facture de matériaux, puis cliquez sur Insérer.
      4. Cliquez sur OK.
      5. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.
    • Comptabilité de projet

      1. Dans le menu Microsoft Dynamics GP , pointez sur Maintenance, puis cliquez sur Vérifier les liens.

      2. Dans la liste Tables logiques, cliquez sur la première table répertoriée et qui correspond à un type de transaction Project Accounting que vous utilisez. Ensuite, cliquez sur Insérer.

        Le tableau suivant répertorie les types de transactions et les tables disponibles dans Project Accounting.

        Type de transaction Table
        Feuille de temps Transactions de feuille de temps PA
        Journal de l’équipement Journal des transactions d'équipement PA
        Journal divers Journal divers PA
        Transfert d’inventaire Transactions de Transfert d’Inventaire PA
        Transactions d’achat Transactions d'achat PA
        Reconnaissance des revenus Transactions de reconnaissance du chiffre d'affaires PA
        Frais des employés Transactions de dépenses des employés PA
        Lots de facturation Transactions de facturation PA
      3. Répétez l’étape 2 en sélectionnant la table applicable suivante répertoriée dans cette étape. Répétez l’étape 2 autant de fois que nécessaire pour insérer toutes les tables applicables. Cliquez ensuite sur OK.

      4. Dans la boîte de dialogue Destination du rapport, cliquez pour activer la case à cocher Écran , puis cliquez sur OK.

Option 2 : Utiliser la boîte à outils gratuite à partir de la bibliothèque d’outils services professionnels

  1. Obtenez l’outil PSTL (Professional Services Tools Library) pour Microsoft Dynamics GP 2010 ou Microsoft Dynamics GP 10.0.

    Pour plus d’informations sur la bibliothèque d’outils de services professionnels, utilisez l’une des options suivantes :

    Clients : Pour plus d’informations sur PSTL, contactez votre partenaire référencé. Si vous n’avez pas de partenaire enregistré, visitez le site Web suivant pour identifier un partenaire : Microsoft Pinpoint

    Partenaires : Pour plus d’informations sur pstl, visitez le site web suivant :

    Vendre Dynamics localement

  2. Installez l’outil PSTL.

  3. Une fois l’installation terminée, démarrez Microsoft Dynamics GP.

  4. Lorsque vous êtes invité à inclure un nouveau code, cliquez sur Oui.

  5. Connectez-vous à Microsoft Dynamics GP en tant qu’administrateur système (sa).

  6. Pour ajouter l’outil PSTL à la barre de raccourcis, cliquez sur Ajouter, cliquez sur Autres fenêtres, développez Outils de service technique, développez Project, cliquez sur Bibliothèque d’outils professionnels, cliquez sur Ajouter, puis sur Terminé.

  7. Dans la barre de raccourcis, cliquez sur Outils de service professionnel.

    Note

    Vous devez attendre la génération des objets SQL.

  8. Lorsque vous recevez l’invite pour entrer des clés d’inscription, cliquez sur Annuler.

    Note

    Vous n’avez pas besoin de clés d’inscription pour utiliser Toolkit.

  9. Cliquez sur Toolkit. Ensuite, cliquez sur Suivant.

  10. Sous Options du kit de ressources, cliquez sur Recréer des objets SQL, puis sur Suivant.

  11. Dans le champ Série , cliquez sur Société.

  12. Dans le champ Tableau , cliquez sur SY00500.

  13. Sous Options de maintenance, activez la case à cocher Recréer la table sélectionnée, puis activez la case à cocher Recréer les données pour les tables sélectionnées.

  14. Cliquez sur Effectuer la maintenance sélectionnée.

  15. Cliquez sur OK lorsque vous recevez les messages suivants :

    La table sera recréée avec des données.
    SY00500 table sera recréée avec des données. Vérifiez qu’une sauvegarde a été effectuée avant de continuer.
    SY00500 a été recréé.

En outre, vous devrez peut-être recréer un déclencheur conseillé par Toolkit. (voir l’option 3).

Option 3

Après avoir regénéré la table SY00500, vérifiez si le « glpBatchHeadersDeletetrigger » existe sur la table. Si ce n’est pas le cas, exécutez un script à partir d’une installation opérationnelle pour le recréer.

sp_helptrigger sy00500

Option 4 : Faire en sorte que tous les utilisateurs se déconnectent complètement de Dynamics GP et effacent les tables d’activité

Ces tables doivent être vides lorsque tous les utilisateurs sont sortis.

SELECT * FROM DYNAMICS..ACTIVITY --shows users currently logged into GP
SELECT * FROM DYNAMICS..SY00800
SELECT * FROM DYNAMICS..SY00801
SELECT * FROM TEMPDB..DEX_LOCK
SELECT * FROM TEMPDB..DEX_SESSION

DELETE DYNAMICS..ACTIVITY
DELETE DYNAMICS..SY00800
DELETE DYNAMICS..SY00801
DELETE TEMPDB..DEX_LOCK
DELETE TEMPDB..DEX_SESSION