Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit une solution à une erreur qui se produit lors de la tentative de suppression d’un lot Cashbook Bank Management à l’aide de Microsoft Dynamics GP.
S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 2252006
Symptômes
Vous recevez le message d’erreur suivant lorsque vous essayez de supprimer un lot Cashbook Bank Management :
L’utilisateur XX est occupé avec le lot YYY
Cause
Le message peut être dû à des enregistrements bloqués dans les tables d’activité Cashbook Bank Management.
Résolution
Pour effacer les enregistrements bloqués, procédez comme suit :
Note
Avant d’utiliser les étapes ci-dessous, veillez à disposer d’une sauvegarde actuelle de la base de données d’entreprise si vous devez effectuer une restauration pour une raison quelconque.
Effacez les tables d’activité à l’aide de la routine Effacer l’activité. Pour ce faire, pointez sur Outils sur le menu Microsoft Dynamics GP, pointez Routines, pointez Financier, pointez Gestion bancaire, puis sélectionnez Effacer l'activité.
Sélectionnez le bouton Effacer l’activité.
Ouvrez SQL Server Management Studio à l’aide de la méthode appropriée :
- Pour SQL Server 2008
Sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2008, puis sélectionnez SQL Server Management Studio. - Pour SQL Server 2005
Sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2005, puis sélectionnez SQL Server Management Studio. - Pour SQL Server 2000
Sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server, puis sélectionnez Analyseur de requête.
- Pour SQL Server 2008
Lorsque tous les utilisateurs sont déconnectés de la base de données d’entreprise, vérifiez qu’il n’existe aucun enregistrement dans la table d’activité CE (CBEU1020) en exécutant l’instruction ci-dessous sur la base de données de l’entreprise :
SELECT * FROM CBEU1020
S’il existe des enregistrements bloqués dans la table ACTIVITÉ CE (CBEU1020), supprimez-les en exécutant l’instruction ci-dessous sur la base de données de l’entreprise :
DELETE CBEU1020