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Cet article traite d’un problème dans lequel Microsoft Entra Connect n’est mis à niveau que partiellement ou la synchronisation de mot de passe et les fonctionnalités d’écriture différée du mot de passe sont désactivées.
Version du produit d’origine : Microsoft Entra ID
Numéro de base de connaissances d’origine : 4038479
Symptômes
Lorsque vous exécutez Microsoft Entra Connect 1.1.443.0 ou une version antérieure, vous rencontrez l’un des problèmes suivants :
- Microsoft Entra Connect n’est mis à niveau que partiellement, le planificateur est suspendu et aucun cycle de synchronisation automatique ne se produit.
- Microsoft Entra Connect est correctement mis à niveau, le planificateur est activé et les modifications d’objet sont synchronisées correctement avec l’ID Microsoft Entra. Toutefois, la fonctionnalité de synchronisation de mot de passe ou la fonctionnalité d’écriture différée de mot de passe est désactivée.
Cause
Un problème dans la fonctionnalité de mise à niveau automatique de Microsoft Entra Connect entraîne la fin du processus Microsoft.Azure.ActiveDirectory.Synchronization.Upgrader.exe en raison d’une exception non gérée. Par conséquent, la mise à niveau automatique ne se termine pas. Pour ce faire, procédez comme suit :
Étape 1 : Déterminer si la mise à niveau automatique a récemment essayé de mettre à niveau Microsoft Entra Connect
Examinez les fichiers journaux dans le %ProgramData%\AADConnect
dossier. Les fichiers journaux dont le titre SyncEngine-AutoUpgrader-[Date]-[Time].log
indique l’heure à laquelle la mise à niveau automatique s’est produite.
Étape 2 : Déterminer si Microsoft Entra Connect est partiellement mis à niveau
Exécutez l’Assistant Microsoft Entra Connect. Si Microsoft Entra Connect est partiellement mis à niveau, vous êtes invité à mettre à niveau Microsoft Entra Connect.
Étape 3 : comparer la version installée de Microsoft Entra Connect à la version dans la configuration du serveur
Pendant la mise à niveau automatique, l’installation actuelle de Microsoft Entra Connect est mise à niveau, puis la version de la configuration du serveur est mise à jour. Si les deux versions ne correspondent pas, Microsoft Entra Connect n’est mis à niveau que partiellement.
Pour vérifier la version de Microsoft Entra Connect installée, ouvrez l’élément Programmes et fonctionnalités dans Panneau de configuration, puis examinez le numéro de version de Microsoft Entra Connect.
Pour vérifier la version de Microsoft Entra Connect dans la configuration du serveur, exécutez la commande suivante dans Windows PowerShell et recherchez la valeur de la propriété Microsoft.Synchronize.ServerConfigurationVersion :
(Get-ADSyncGlobalSettings).Parameters | select Name,Value
Vérifiez l’état du planificateur en exécutant la commande suivante :
Get-ADSyncScheduler
Si la valeur de SchedulerSuspended a la valeur True, le planificateur est suspendu.
Étape 4 : Vérifier que la synchronisation de mot de passe et la réécriture du mot de passe sont activées
Si Microsoft Entra Connect est correctement mis à niveau, ouvrez l’Assistant Microsoft Entra Connect, puis sélectionnez Vérifier votre solution pour vérifier que les fonctionnalités de synchronisation de mot de passe et d’écriture différée de mot de passe sont activées.
Solution de contournement
Pour contourner ce problème, effectuez les étapes suivantes :
- Démarrez l’Assistant Microsoft Entra Connect, puis sélectionnez Mettre à niveau.
- Une fois la mise à niveau terminée, vérifiez que la version installée de Microsoft Entra Connect correspond à la version dans la configuration du serveur.
- Si vous avez précédemment activé la fonctionnalité de synchronisation de mot de passe ou la fonctionnalité d’écriture différée du mot de passe, vérifiez que la fonctionnalité reste activée une fois la mise à niveau terminée.
- Si l’une des fonctionnalités est désactivée après la mise à niveau, sélectionnez Personnaliser les options de synchronisation dans l’Assistant Microsoft Entra Connect, puis activez manuellement la fonctionnalité.
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