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Impossible de se connecter à Azure Protection des données à l’aide de Windows PowerShell

Note

Microsoft Azure Protection des données était précédemment appelé Microsoft Azure Rights Management.

Cet article résout un problème où vous ne pouvez pas vous connecter au service Azure Protection des données à l’aide de Windows PowerShell dans Office 365.

Version du produit d’origine : ID Microsoft Entra, Azure Protection des données
Numéro de base de connaissances d’origine : 2797755

Symptômes

Lorsque vous essayez de vous connecter à Microsoft Azure Protection des données à l’aide de Windows PowerShell dans Microsoft Office 365, vous obtenez un message d’erreur semblable à ce qui suit :

PS C:\> Connect-AipService

Connect-AipService : The attempt to connect to the Azure Information Protection service failed. Verify that the user name and password you are using are correct and try again. If you have continued problems, see http://go.microsoft.com/fwlink/?LinkId=251909.

The correlation ID is 1df4c755-f859-4284-907b-be5d2a551260. Please note and provide this value if asked by support for it.

At line:1 char:1

+ Connect-AipService

+ ~~~~~~~~~~~~~~~~~~

+ CategoryInfo : NotSpecified: (:) [Connect-AipService], ApplicationFailedException

+ FullyQualifiedErrorId : NotSpecified,Microsoft.RightsManagementServices.Online.Admin.PowerShell.ConnectAipServiceCommand

Vous pouvez également voir le message d’erreur suivant :

la référence d’objet n’a pas la valeur d’une instance d’objet.

Cause

Ce problème se produit si une ou plusieurs des conditions suivantes sont remplies :

  • Vous avez entré le nom d’utilisateur ou le mot de passe incorrect.
  • Vous n’êtes pas administrateur d’entreprise.
  • Vous n’avez pas d’abonnement incluant Azure Protection des données.
  • Le réseau vous empêche de vous connecter à Azure Protection des données.
  • Vous utilisez Windows PowerShell 7. L’utilisation de PowerShell 7 entraîne l’erreur « Référence d’objet non définie sur une instance d’un objet ». Pour plus d’informations, consultez Problèmes connus - Azure Protection des données.

Résolution

Note

Si Azure Protection des données n’est pas activé pour votre entreprise, vous utilisez la Centre d’administration Microsoft 365 pour l’activer. Pour plus d’informations sur la procédure à suivre, consultez azure Protection des données feuille de route de déploiement.

Pour résoudre ce problème, vérifiez que les éléments suivants sont vrais :

  • Vérifiez que vous entrez le nom d’utilisateur et le mot de passe appropriés. Pour vérifier que vous les avez correctement entrées, connectez-vous au portail Office 365.
  • Vous devez être administrateur général pour vous connecter à Azure Protection des données.
  • Pour utiliser Azure Protection des données, vous devez disposer d’un abonnement incluant Azure Protection des données.
  • Collaborez avec l’administrateur réseau pour vous assurer que le réseau répond aux exigences de connexion à Azure Protection des données. Les exigences sont les suivantes :
    • Les connexions entrantes et sortantes à *.aadrm.com activer.
    • Les connexions entrantes et sortantes à *.cloudapp.net (rmsoprod*-b-rms*.cloudapp.net) sont activées.
    • Le port 443 est ouvert.
  • Utilisez Windows PowerShell 5. Vous pouvez vérifier la version de PowerShell à l’aide de la $PSVersionTable.PSVersion commande.

Plus d’informations

Pour plus d’informations sur Azure Protection des données, consultez AIPService.

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.