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Erreur de trousseau -25244 (errSecInvalidOwnerEdit) lorsque vous inscrivez un appareil macOS dans Intune

Cet article résout un problème dans lequel vous ne pouvez pas inscrire un appareil macOS dans Microsoft Intune en raison d’entrées de trousseau obsolètes ou endommagées.

Symptômes

Lorsque vous essayez d’inscrire un appareil macOS dans Intune, l’inscription échoue et vous recevez l’erreur suivante :

Votre Mac ne peut pas être inscrit pour l’instant

Dans les journaux du portail d’entreprise, vous recevez des entrées d’erreurs qui ressemblent à ce qui suit :

2018-06-07 18:13:42.795 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) INFO : -[WorkPlaceJoinUtil removeStringDataFromSharedAccessGroup :sharedAccesssGroup :] [Ligne 1546][2018-06-07 18:13:42 +0000]n’a pas pu supprimer l’élément de jointure de l’espace de travail avec l’identificateur « com.microsoft.workplacejoin.registeredUserPrincipalName » du trousseau pour le groupe d’accès partagé : macOS.com.microsoft.workplacejoin avec le code d’erreur :-25244
2018-06-07 18:13:42.795 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) ERROR : [errorCode :-400]-[WorkPlaceJoin clearWorkplaceJoinStateFromDevice :error :] [Ligne 1901][2018-06-07 18:13:42 +0000]n’a pas pu supprimer l’élément de jointure d’espace de travail avec l’identificateur « com.microsoft.workplacejoin.registeredUserPrincipalName » du trousseau pour le groupe d’accès partagé : macOS.com.microsoft.workplacejoin avec le code d’erreur :-252444
2018-06-07 18:13:42.796 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) INFO : --[WorkPlaceJoinUtil removeStringDataFromSharedAccessGroup :sharedAccesssGroup :] [Line 1520][2018-06-07 18:13:42 +0000]macOS.com.microsoft.workplacejoin
2018-06-07 18:13:42.797 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) INFO : -[WorkPlaceJoinUtil removeStringDataFromSharedAccessGroup :sharedAccesssGroup :] [Ligne 1541][2018-06-07 18:13:42 +0000]Élément de données string avec l’identificateur « com.microsoft.workplacejoin.registrationKey » est introuvable dans le groupe d’accès partagé « macOS.com.microsoft.workplacejoin »
2018-06-07 18:13:42.798 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) INFO : -[WorkPlaceJoinUtil removeStringDataFromSharedAccessGroup :sharedAccesssGroup :] [Ligne 1520][2018-06-07 18:13:42 +0000]macOS.com.microsoft.workplacejoin
2018-06-07 18:13:42.824 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) INFO : -[WorkPlaceJoinUtil removeStringDataFromSharedAccessGroup :sharedAccesssGroup :] [Ligne 1546][2018-06-07 18:13:42 +0000]n’a pas pu supprimer l’élément de jointure de l’espace de travail avec l’identificateur « com.microsoft.workplacejoin.discoveryHint » du trousseau pour le groupe d’accès partagé : macOS.com.microsoft.workplacejoin avec le code d’erreur :-252444
2018-06-07 18:13:42.825 INFO com.microsoft.ssp.workplaceJoinSdk TID=23 WorkplaceJoinManager.swift : 796 (workplaceClient(_ :logMessage :)) ERROR : [errorCode :-400]-[WorkPlaceJoin clearWorkplaceJoinStateFromDevice :error :] [Ligne 1927][2018-06-07 18:13:42 +0000]n’a pas pu supprimer l’élément de jointure du lieu de travail avec l’identificateur « com.microsoft.workplacejoin.discoveryHint » du trousseau pour le groupe d’accès partagé : macOS.com.microsoft.workplacejoin avec le code d’erreur :-252444

Cause

Ce problème est dû à des entrées de trousseau obsolètes ou endommagées liées à l’inscription Intune dans le trousseau macOS.

Résolution

Note

Effectuez les étapes suivantes uniquement si vous voyez des entrées d’erreur dans les journaux du portail d’entreprise qui ressemblent aux entrées mentionnées dans la section Symptômes .

Pour résoudre ce problème, effectuez les étapes suivantes :

  1. Connectez-vous à l’appareil en tant qu’administrateur local.

  2. Ouvrez l’accès au trousseau en tapant l’accès au trousseau dans la recherche Spotlight, puis double-cliquez sur Accès au trousseau dans les résultats de la recherche.

  3. Dans la zone de recherche située en haut à droite, tapez l’espace de travail.

  4. Supprimez toutes les clés dans les résultats.

  5. Dans la zone de recherche située en haut à droite, tapez Microsoft.

  6. Recherchez et supprimez les clés suivantes si elles sont présentes :

  7. Dans le volet Trousseau , sélectionnez Connexion, puis sélectionnez Tous les éléments dans le volet Catégorie .

  8. Cliquez sur l’en-tête de colonne Type pour trier les éléments.

  9. Supprimez les éléments qui répondent à l’une des conditions suivantes :

    • Le type est le mot de passe de l’application et le compte est com.microsoft.workplacejoin.thumbprint
    • Le type est le mot de passe de l’application et le compte est com.microsoft.workplacejoin.registeredUserPrincipalName
    • Le type est certificat et émis par MS-Organization-Access
    • Le type est la préférence d’identité et le nom est l’URL STS ADFS, par exemplehttps://adfs<DNSName>.com/adfs/ls
    • Le type est la préférence d’identité et le nom esthttps://enterpriseregistration.windows.net
    • Le type est la préférence d’identité et le nom esthttps://enterpriseregistration.windows.net/
  10. Dans le volet Trousseaux , sélectionnez Système.

  11. Supprimez les éléments qui répondent à la condition suivante :

    Le type est certificat et émis par est SC_Online_Issuing

  12. Désinstallez l’application Portail d’entreprise.

  13. Quittez l’accès au trousseau.

  14. Téléchargez la dernière version du portail d’entreprise à partir de .https://portal.manage.microsoft.com

  15. Réinscrivez l’appareil.