Partager via


« Actualiser tout » ne fonctionne pas après l’exportation des données d’application vers une feuille de calcul dynamique

Symptômes

Vous utilisez la commande Exporter vers Excel pour exporter des données d’application vers une feuille de calcul dynamique. Ensuite, vous ouvrez le fichier téléchargé et actualisez les données en sélectionnant Données>Actualiser tout. Dans ce cas, vous constatez que les données disparaissent et que le classeur apparaît vide. Le message d’erreur suivant peut s’afficher :

Cette requête web n’a retourné aucune donnée. Pour modifier la requête, cliquez sur OK, cliquez sur la flèche de la zone de nom dans la barre de formule, cliquez sur le nom de la plage de données externe pour la requête Web, cliquez avec le bouton droit sur la sélection, puis cliquez sur Modifier la requête.

Capture d’écran montrant que la requête web n’a renvoyé aucune erreur de données qui se produit après l’actualisation des données d’application exportées.

Cause

Ce problème se produit lorsque les données auxquelles vous accédez sont protégées par mot de passe et que le fichier Excel ne peut pas envoyer de mots de passe à des sources de données externes.

Résolution

Pour résoudre ce problème, vous devez modifier et enregistrer la requête web.

  1. Dans le fichier Excel, sélectionnezRequêtes dedonnées> & Connections.

    Capture d’écran montrant l’option Requêtes et Connections dans l’onglet Données.

  2. Le volet Requêtes & Connections s’ouvre à droite de la fenêtre. Sous l’onglet Connections, cliquez avec le bouton droit sur la requête, puis sélectionnez Propriétés.

    Capture d’écran montrant les paramètres Propriétés d’une requête dans le volet Requêtes et Connections.

  3. La fenêtre Propriétés de connexion s’ouvre. Sous l’onglet Définition , sélectionnez Modifier la requête.

    Capture d’écran montrant le bouton Modifier la requête dans le Fenêtre Propriétés connexion.

  4. Si vous y êtes invité, entrez le nom d’utilisateur et le mot de passe. Entrez le même utilisateur et le même mot de passe que vous utilisez pour vous connecter à votre application.

  5. Dans la fenêtre Modifier la requête web , sélectionnez Accéder. Un message d’erreur se produit :

    Impossible d’effectuer cette action

    Capture d’écran montrant le bouton Go dans la fenêtre Modifier la requête web.

  6. Fermez la fenêtre Modifier la requête web .

  7. Cela devrait résoudre le problème. Actualisez à nouveau les données de la feuille de calcul en sélectionnant Données>Actualiser tout.

    Capture d’écran montrant comment actualiser les données de votre application dans Excel.

Si les étapes ci-dessus ne résolvent pas le problème, procédez comme suit :

  1. Entrez le lien suivant dans la barre d’adresses de la fenêtre Modifier la requête web pour accéder à la page Paramètres avancés dans Microsoft Dynamics 365 Customer Engagement. N’oubliez pas de remplacer OrgURL par votre URL organization.

    https://OrgURL/main.aspx?settingsonly=true

  2. Déconnectez-vous à l’aide du lien d’option de profil en haut à droite, puis reconnectez-vous à l’aide de l’identité appropriée.

  3. Une fois connecté, fermez la fenêtre Modifier la requête web , puis, dans le fichier Excel, sélectionnez Données>Actualiser tout. Les données seront actualisées comme prévu.

Voir aussi

Exporter des données vers une feuille de calcul dynamique Excel