Share via


Impossible d’établir une connexion à OLE DB du moteur de base de données Access

Cet article fournit une résolution à un problème dans lequel vous ne pouvez pas établir une connexion au moteur de base de données Access OLE DB dans Microsoft Power Automate pour le bureau.

S’applique à : Power Automate
Numéro de la base de connaissances d’origine : 5004577

Symptômes

Considérez le scénario suivant dans Microsoft Power Automate pour le bureau :

  1. Le fournisseur OLE DB du moteur de base de données Access ne s’affiche pas dans la liste des propriétés de la liaison de données lorsque vous établissez une connexion avec des actions de base de données.

  2. Lorsque vous utilisez un chaîne de connexion directement, le message d’erreur suivant peut s’afficher :

    Impossible de se connecter à la source de données « Microsoft.ACE.OLEDB.1x.0 . » le fournisseur n’est pas inscrit sur l’ordinateur local.

Cause

Ce message d’erreur se produit car le pilote 64 bits approprié n’est pas installé sur votre ordinateur. Notez que Power Automate pour le bureau est basé sur une architecture 64 bits et n’est donc compatible qu’avec les pilotes de base de données 64 bits.

Résolution

Vérifiez que le pilote Access Database 64 bits est installé sur votre ordinateur en accédant à l’application Administrateur de source de données ODBC (64 bits) sur Windows, puis à l’onglet Pilotes . Si vous ne voyez pas « Pilote Microsoft Access » dans la liste, vous devez télécharger et installer la version 64 bits à partir du moteur de base de données Microsoft Access 2016 Redistributable.

Conseil

Si office 32 bits est installé sur vos fenêtres et que vous ne pouvez pas effectuer la mise à niveau vers la version 64 bits d’Office, poursuivez la lecture du reste de l’article.

Suivez les étapes ci-dessous pour que les pilotes Access 32 bits et 64 bits coexistent sur votre ordinateur :

  1. Désinstallez toutes les versions du pilote Access de votre ordinateur.

  2. Accédez à l’éditeur du Registre sur votre bureau (vous pouvez le rechercher dans la barre de recherche) et accédez aux deux chemins d’accès ci-dessous s’ils existent :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

  3. Vérifiez si la clé de Registre « mso.dll » est présente dans les deux chemins ci-dessus. Si la clé est présente, cela signifie que vous n’avez pas désinstallé tous les pilotes. Vérifiez les pilotes sur votre système, désinstallez tous les pilotes Access et vérifiez à nouveau les chemins d’accès des éditeurs du Registre mentionnés à l’étape 2.

  4. Téléchargez une nouvelle version du moteur de base de données Microsoft Access à partir du site web officiel de Microsoft, puis installez le pilote 64 bits à l’aide de l’invite de commandes (CMD) avec la commande AccessDatabaseEngine_x64.exe /quiet pour redistribuable 2016.

  5. Retour à l’éditeur du Registre et supprimez la clé de Registre « mso.dll » et sa valeur dans le chemin d’accès suivant :

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Enfin, installez le pilote 32 bits à l’aide de l’invite de commandes (CMD) avec la commande AccessDatabaseEngine.exe /quiet pour redistribuable 2016. Cela permet aux pilotes 32 bits et 64 bits de coexister sur votre ordinateur.