Partager via


Impossible d’établir une connexion à Access Moteur de base de données OLE DB

Cet article fournit une résolution d’un problème où vous ne pouvez pas établir de connexion à Access Moteur de base de données OLE DB dans Microsoft Power Automate pour le bureau.

S’applique à : Power Automate
Numéro de base de connaissances d’origine : 5004577

Symptômes

Considérez le scénario suivant dans Microsoft Power Automate pour le bureau :

  1. Access Moteur de base de données fournisseur OLE DB ne s’affiche pas dans la liste des propriétés de liaison de données lorsque vous établissez une connexion avec des actions de base de données.

  2. Lorsque vous utilisez un chaîne de connexion directement, vous pouvez recevoir le message d’erreur suivant :

    Impossible de se connecter à la source de données « Microsoft.ACE.OLEDB.1x.0 ». le fournisseur n’est pas inscrit sur l’ordinateur local.

Cause

Ce message d’erreur se produit, car le pilote 64 bits approprié n’est pas installé sur votre ordinateur. Notez que Power Automate pour le bureau est basé sur l’architecture 64 bits et est donc uniquement compatible avec les pilotes de base de données 64 bits.

Solution de contournement

Vérifiez que vous avez installé le pilote de base de données Access 64 bits sur votre ordinateur en accédant à l’application Administrateur de source de données ODBC (64 bits) sur windows, puis sous l’onglet Pilotes. Si vous ne voyez pas « Pilote Microsoft Access » dans la liste, vous devez télécharger et installer la version 64 bits à partir de Microsoft Access Moteur de base de données Redistribuable 2016.

Conseil

Si vous avez installé Office 32 bits sur vos fenêtres et que vous ne pouvez pas effectuer de mise à niveau vers la version 64 bits d’Office, poursuivez la lecture du reste de l’article.

Suivez les étapes ci-dessous pour que les pilotes Access 32 bits et 64 bits coexistent sur votre ordinateur :

  1. Désinstallez toutes les versions du pilote Access de votre ordinateur.

  2. Accédez à l’éditeur de Registre sur votre bureau (vous pouvez le rechercher dans la barre de recherche) et accédez aux deux chemins ci-dessous s’ils existent :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

  3. Vérifiez si la clé de Registre « mso.dll » est présente dans les deux chemins d’accès ci-dessus. Si la clé est présente, cela signifie que vous n’avez pas désinstallé tous les pilotes. Vérifiez les pilotes sur votre système et désinstallez tous les pilotes Access et vérifiez à nouveau les chemins d’accès des éditeurs de Registre mentionnés à l’étape 2.

  4. Téléchargez une nouvelle version de Microsoft Access Moteur de base de données à partir du site web officiel microsoft, puis installez le pilote 64 bits à l’aide de l’invite de commandes (CMD) avec la commande AccessDatabaseEngine_x64.exe /quiet pour redistribuable 2016.

  5. Revenez à l’éditeur de Registre et supprimez la clé de Registre « mso.dll » et sa valeur dans le chemin suivant :

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Enfin, installez le pilote 32 bits à l’aide de l’invite de commandes (CMD) avec la commande AccessDatabaseEngine.exe /quiet pour redistribuable 2016. Cela permettra aux pilotes 32 bits et 64 bits de coexister sur votre ordinateur.