Partager via


Erreur d’informations d’identification non valides lors de l’exécution de flux de bureau dans Power Automate Desktop

Cet article fournit une solution à l’erreur d’informations d’identification non valide qui se produit lorsque vous exécutez un flux de bureau à partir d’un flux cloud dans Microsoft Power Automate pour le bureau.

S’applique à : Power Automate
Numéro de base de connaissances d’origine : 5021155

Symptômes

  • Lorsque vous créez une connexion de flux de bureau, vous recevez le message d’erreur suivant :

    Détails : Échec de la connexion : [ID de l’ordinateur<>]. Il existe un problème avec vos informations d’identification. Vérifiez vos informations d’identification ou utilisez des informations d’identification différentes pour vous connecter à l’ordinateur. ID de corrélation : <ID de corrélation>.

    Capture d’écran de l’erreur d’identifiants invalides que vous pouvez recevoir lors de la création d’une connexion de flux de bureau.

  • Lorsque vous exécutez un flux de bureau, vous recevez le code d’erreur WindowsIdentityIncorrect . Le message associé à ce code d’erreur peut être « Les informations d’identification fournies avec la demande ne sont pas valides » ou quelque chose de plus spécifique.

    {
        "error":{
            "code": "WindowsIdentityIncorrect",
            "message": "The credentials provided with the request are invalid."
        }    
    }
    

Remarque

En cas d’erreur de connexion, le meilleur test consiste à se connecter à la même machine avec le Bureau à distance et à utiliser les mêmes informations d’identification que celles que vous avez utilisées lors de la création du flux de bureau.

Cause

Les messages d’erreur se produisent, car les informations d’identification de la connexion ne peuvent pas s’authentifier sur l’ordinateur cible.

Lorsque vous créez une connexion, Power Automate vérifie que les informations d’identification sont valides. Si les informations d’identification ne s’authentifient pas sur l’ordinateur cible, la connexion ne peut pas être établie et vous recevez une erreur décrivant le problème.

Si vous avez créé votre connexion précédemment, mais que vous rencontrez maintenant une erreur lors de l’exécution de votre flux, cela indique que quelque chose a changé dans votre compte d’utilisateur ou votre ordinateur. Par exemple, votre mot de passe peut avoir expiré.

Résolution

Pour afficher un message d’erreur avec des détails spécifiques sur ce qui s’est passé, vérifiez que Power Automate version 2.24 ou ultérieure est installé. Souvent, cette méthode vous donne suffisamment d’informations pour résoudre le problème. Le tableau suivant présente certains codes d’erreur spécifiques et les résolutions.

Code d’erreur Message d’erreur Cause Résolution
-1073741477 Un utilisateur a demandé un type d’ouverture de session (par exemple, interactif ou réseau) qui n’a pas été accordé. Un administrateur contrôle qui peut se connecter de manière interactive et via le réseau. Le compte d’utilisateur n’a pas de droits d’ouverture de session sur l’ordinateur, ou l’administrateur a modifié les stratégies de l’ordinateur (vérifiez les paramètres d’attribution des droits utilisateur). Pour résoudre ce problème, consultez l’erreur « Le type d’ouverture de session n’a pas été autorisé » lors de l’exécution d’un flux de bureau ou de la création d’une connexion.
-1073445812 L’UPN de l’utilisateur n’est pas au format attendu L’utilisateur s’est connecté à l’aide de DOMAIN\user, mais doit utiliser le format user@domain.com à la place (ou inversement). Essayez de vous connecter en utilisant les formats user@domain.com et DOMAIN\user.
-1073741062 L'authentification par carte à puce est requise et n'a pas été utilisée. Les connexions aux ordinateurs qui nécessitent des connexions à carte à puce ne sont pas prises en charge. Utilisez une machine sans cette exigence.
-1073741715 Informations d’authentification ou de nom d’utilisateur incorrectes Les informations d’identification données ne sont pas correctes. Ce problème peut se produire en raison d’une combinaison utilisateur/mot de passe incorrecte ou d’un format de nom d’utilisateur. 1. Vérifiez que votre nom d’utilisateur et votre mot de passe fonctionnent sur l’ordinateur. Pour ce faire, vous pouvez vous déconnecter et vous reconnecter avec les mêmes informations d’identification.
2. Si cela fonctionne, vérifiez que vous utilisez le format de nom d’utilisateur correct en exécutant la commande dsregcmd /status dans le contexte du compte de connexion de flux de bureau. Vérifiez la Executing Account Name valeur (dans la Diagnostic Data section) dans la sortie et vérifiez qu’elle correspond au nom d’utilisateur utilisé.
3. Si votre ordinateur est joint à Microsoft Entra ou hybride, utilisez le user@domain.com format. Si votre ordinateur est joint à un domaine uniquement, utilisez le DOMAIN\user format.

Pour déterminer le format de nom d’utilisateur correct, vérifiez l’état de jointure de votre ordinateur :
a. Exécutez la commande dsregcmd /status .
b. Recherchez la section Device State dans la sortie :
- Si vous voyez AzureAdJoined : YES, votre machine est associée à Microsoft Entra.
- S’il indique NO après AzureAdJoined mais YES après DomainJoined, votre machine est jointe à un domaine uniquement.
-1073741730 Le domaine n’est pas disponible Vérifiez que vous utilisez le format de nom d’utilisateur approprié pour l’état de jointure de votre machine. Si votre ordinateur est joint à Microsoft Entra ou hybride, utilisez le user@domain.com format. Si votre ordinateur est joint à un domaine uniquement, utilisez le DOMAIN\user format.

Pour déterminer le format de nom d’utilisateur correct, vérifiez l’état de jointure de votre ordinateur :
1. Exécutez la commande dsregcmd /status .
2. Recherchez la section dans la Device State sortie :
- Si vous voyez AzureAdJoined : YES, votre machine est jointe à Microsoft Entra.
- S’il indique NO après AzureAdJoined mais YES après DomainJoined, votre machine est jointe à un domaine uniquement.
-1073741714 La restriction de compte d’utilisateur a empêché l’authentification réussie Les informations de nom d’utilisateur et d’authentification référencées sont valides, mais une restriction de compte d’utilisateur, telle que les restrictions d’heure du jour, a empêché les authentifications réussies. Vérifiez qu’aucune stratégie de restriction de sécurité ou de compte empêche cet utilisateur de se connecter correctement.
-1073741712 Le compte d’utilisateur est limité afin qu’il ne soit pas utilisé pour se connecter à partir de la station de travail source Vérifiez qu’aucune stratégie de restriction de sécurité ou de compte empêche cet utilisateur de se connecter correctement.

Si vous n’avez pas d’erreur plus spécifique associée au problème, le moyen le plus simple de résoudre les problèmes consiste à se connecter à l’ordinateur avec les informations d’identification exactes que vous avez entrées dans votre connexion. Vous pouvez essayer cette méthode en vous connectant à l’ordinateur localement ou via une connexion Bureau à distance. Vous devez recevoir le même message d’erreur que Power Automate reçoit lors de la tentative d’authentification de vos informations d’identification, ce qui doit vous aider à résoudre le problème.

D’autres raisons qui peuvent vous empêcher de vous connecter à l’ordinateur cible (en plus d’utiliser un nom d’utilisateur ou un mot de passe incorrect) :

  • Les codes PIN ne sont pas pris en charge. Veillez à utiliser un mot de passe au lieu d’un code confidentiel Windows Hello.
  • La machine ne peut pas se connecter à son domaine ou à son ID Microsoft Entra (anciennement Azure Active Directory), car elle n’est pas correctement jointe. Pour résoudre ce problème, consultez l’erreur des informations d’identification non valides du flux de bureau lorsque vous utilisez un compte Microsoft Entra.
  • L’ordinateur ne peut pas appeler le point de terminaison d’authentification en raison d’un problème réseau. Veillez à vérifier votre connexion réseau.

Voici quelques raisons courantes pour lesquelles le compte d’utilisateur est configuré de manière incorrecte :

  • L’administrateur a modifié les informations d’identification du compte.
  • Le compte d’utilisateur de domaine n’a pas été propagé à l’ordinateur.
  • Le compte d’utilisateur a perdu des privilèges ou a été désactivé.
  • Le mot de passe du compte d’utilisateur a expiré.

Plus d’informations