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Une erreur de connexion 10054 peut se produire après SQL Server mise à niveau

Après une mise à niveau de Microsoft SQL Server, vous rencontrez une erreur de connexion. L’erreur est susceptible de se poursuivre même après avoir utilisé le compte système local pour le service SQL Server Agent.

Symptômes

Après la mise à niveau de Microsoft SQL Server Standard Edition (STD), SQL Server Agent démarre et s’arrête immédiatement. En outre, vous recevez un ou plusieurs des messages d’erreur suivants :

SQL Server n’accepte pas la connexion (erreur : 10054). En attente d’SQL Server pour autoriser les connexions. L’opération tentée a été : Vérifier la connexion au démarrage.

Erreur SQLServer : 10054, fournisseur SSL : une connexion existante a été fermée de force par l’hôte distant. [SQLSTATE 08001]

Erreur SQLServer : 10054, le client ne peut pas établir la connexion [SQLSTATE 08001]

Cause

Parfois, après une mise à niveau microsoft SQL Server, TLS est désactivé et vous pouvez rencontrer une erreur de connexion. Vérifiez si le protocole TLS est désactivé après l’installation de la mise à niveau.

Résolution

Pour résoudre l’erreur, procédez comme suit :

  1. Activez TLS en définissant les entrées de Registre suivantes :

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.0

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.1

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.2

  2. Redémarrez l’ordinateur pour vous assurer que la modification est appliquée.

Voir aussi

Une connexion existante a été fermée de force par l’hôte distant (erreur de système d’exploitation 10054)