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Le service de l’agent de protection DPM ne peut pas démarrer

Cet article vous aide à résoudre un problème où vous recevez le service DPMRA arrêté avec une erreur spécifique au service 10048 (0x2740) lorsque vous démarrez le service d’agent de protection data Protection Manager (DPM).

Version du produit d’origine : System Center Data Protection Manager
Numéro de base de connaissances d’origine : 947682

Symptômes

Après avoir déployé l’agent de protection DPM dans Microsoft System Center Data Protection Manager, le service de l’agent de protection DPM ne peut pas démarrer sur les serveurs protégés. (Un serveur protégé est un serveur qui contient des sources de données qui sont des membres du groupe de protection.)

Cause

Ce problème peut se produire pour l’une des raisons suivantes :

  • Un autre processus consiste à utiliser le port TCP 5718 et le port TCP 5719. Ces deux ports sont requis par le service de l’agent de protection DPM.
  • Le port TCP 5718 et le port TCP 5719 ne sont pas ouverts pour les applications de pare-feu ou pour les appareils de pare-feu sur l’ordinateur.

Résolution 1

Pour résoudre ce problème, recherchez le processus qui utilise les ports TCP requis. Pour ce faire, procédez comme suit :

  1. Ouvrez une fenêtre d’invite de commandes. Exécutez les commandes suivantes à l’invite de commandes :

    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    

    Note

    Dans cette étape, les sorties de commande de la netstat commande et la tasklist commande sont écrites dans des fichiers texte afin de pouvoir vérifier plus facilement les sorties. Exécutez la tasklist commande avec le /svc commutateur, car le processus qui utilise les ports requis peut être exécuté en tant que service.

  2. Ouvrez les fichiers texte générés à l’étape 1. Pour ce faire, exécutez les commandes suivantes à l’invite de commandes :

    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
    
  3. Dans le fichier Netstat.txt, recherchez toutes les entrées qui correspondent au port TCP 5718 et au port TCP 5719. Notez l’identificateur de processus (PID) pour chaque entrée.

  4. Dans le fichier Tasklist.txt, recherchez les ID que vous avez trouvés à l’étape 3 pour déterminer les processus qui utilisent les ports requis. Si vous ne trouvez pas les ID dans le fichier Tasklist.txt, essayez de trouver les ID dans le fichier Svclist.txt.

  5. Après avoir trouvé le processus qui utilise les ports requis, configurez le programme correspondant pour utiliser d’autres ports disponibles. Si vous ne pouvez pas modifier les ports du programme ou si le programme utilise des ports dynamiquement, vous devez arrêter le programme.

Note

Si une autre application utilise le port ou les ports (5718 et 5719), les ports ne peuvent pas être modifiés. Dans ce cas, vous pouvez, à la place, utiliser l’outil SetAgentcfg.exe. Cet outil permet de modifier les ports par défaut utilisés par l’agent DPM.

Pour modifier les ports utilisés par l’agent DPM, procédez comme suit sur l’ordinateur protégé qui rencontre le problème. Assurez-vous que les ports que vous réaffectez ne seront pas utilisés par d’autres applications.

Note

Pour répertorier le chemin d’installation de DPM, exécutez la commande suivante :

Reg query "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup" /v installpath

  1. Recherchez le fichier SetAgentcfg.exe à partir du serveur DPM. Par défaut, le fichier se trouve à l’emplacement %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe.

  2. Copiez le fichier sur l'ordinateur protégé confronté au problème. Copiez le fichier dans le répertoire DPM\Bin de l'agent. Par défaut, le fichier se trouve à l’emplacement %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  3. Sur l’ordinateur protégé qui rencontre le problème, ouvrez une fenêtre d’invite de commandes d’administration.

  4. Dans la fenêtre d’invite de commandes, accédez au répertoire dans lequel le fichier SetAgentCfg.exe a été copié. Par exemple, passez au répertoire %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  5. Exécutez la commande suivante pour modifier les ports utilisés par l’agent DPM :

    SetAgentCfg e dpmra <port number> <alternate port number>
    
  6. Redémarrez le service DPMRA.

Si ces étapes ne résolvent pas ce problème, déterminez si les applications de pare-feu nécessitent que vous vérifiiez ces ports. Ensuite, ouvrez manuellement les ports.

Résolution 2

Pour réserver des ports TCP 5718 et 5719, suivez les étapes décrites dans Comment réserver une plage de ports éphémères sur un ordinateur exécutant Windows Server 2003 ou Windows 2000 Server.

Plus d’informations

Data Protection Manager et les serveurs protégés ouvrent des connexions via le port TCP 5718 et sur le port TCP 5719 pour activer les opérations Data Protection Manager, telles que la synchronisation et la récupération. Le problème actuel peut se produire sur les serveurs protégés qui exécutent le service Standard système Microsoft Exchange. Ce service utilise dynamiquement les ports TCP. Ce service peut prendre un ou les deux ports requis.

Data Protection Manager utilise également les ports suivants :

  • TCP 135 dynamique
  • Protocole UDP (User Datagram Protocol) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389