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Cet article résout un problème dans lequel vous ne pouvez pas ajouter d’hôtes à System Center 2012 Virtual Machine Manager Service Pack 1 et recevoir l’erreur 415.
Version du produit d’origine : System Center 2012 Virtual Machine Manager Service Pack 1
Numéro de base de connaissances d’origine : 2818420
Symptômes
L’ajout d’hôtes à System Center 2012 Virtual Machine Manager Service Pack 1 échoue et l’erreur 415 peut être présente dans l’historique des travaux VMM. La description de l’erreur est la suivante :
Erreur ( 415 ) Échec de la copie de L’installation de l’agent C :\Program Files :\Microsoft System Center\Virtual Machine Manager\agents\I386\3.1.6011.0\msiInstaller.exe vers \\servername\ADMIN$\msiInstaller.exe.
Action recommandée
- Vérifiez que <le nom de> serveur est en ligne et qu’il n’est pas bloqué par un pare-feu.
- Vérifiez que le partage de fichiers et d’imprimantes est activé sur <le nom du> serveur et qu’il n’est pas bloqué par un pare-feu.
- Assurez-vous qu’il y a suffisamment d’espace libre sur le volume système.
- Vérifiez que le partage ADMIN$ sur <le nom de> serveur existe. Si le partage ADMIN$ n’existe pas, redémarrez <le nom> du serveur, puis réessayez l’opération.
Un élément Détails facultatif peut également être journalisé, qui fournit plus d’informations. Par exemple :
Détails : le processus ne peut pas accéder au fichier, car il est utilisé par un autre processus
Détails : Le nom du compte cible est incorrect
Cause
Cela peut se produire si les ports normalement ouverts pendant l’installation de vmmAgent n’ont pas pu être ouverts et/ou si le rôle Serveur de fichiers n’est pas activé.
Résolution
Étape 1 : Vérifier que le partage Admin$ est présent et accessible par le compte d’identification VMM
Connectez-vous au serveur VMM à l’aide des informations d’identification spécifiées pour le compte d’identification utilisé pour exécuter le travail. Ce compte doit être en mesure de se connecter à \\<servername>\admin$ et de copier un fichier dans ce partage. Si cela échoue, passez à l’étape 2.
Étape 2 : Vérifier que le compte d’identification est un administrateur local sur l’ordinateur cible
Connectez-vous à l’hôte cible et examinez les utilisateurs et groupes locaux. Vérifiez que ce compte est membre du groupe Administrateurs locaux.
Étape 3 : Ouvrir les ports requis
Pour ouvrir les ports requis, ouvrez les paramètres du pare-feu avancé, choisissez Règles de trafic entrant et faites défiler vers le bas de la liste. Vérifiez que les cinq éléments ci-dessous sont tous activés. Dans la première image ci-dessous, seule la gestion à distance de Windows est activée.
L’image ci-dessous montre tous les éléments activés.
Vous pouvez automatiser cette opération en exécutant les commandes suivantes :
netsh advfirewall firewall set rule group="Windows Management Instrumentation (WMI)" new enable="Yes"
netsh advfirewall firewall set rule group="Windows Remote Management" new enable="Yes"
Étape 4 : Activer le rôle de partage de fichiers
Si l’étape 1 ci-dessus n’a pas résolu le problème, activez le rôle Serveur de fichiers . Dans rôles et fonctionnalités, placez un enregistrement dans le serveur de fichiers. Le redémarrage est facultatif, mais recommandé.