Partager via


La restauration du système peut échouer avec le code d’erreur 0x8007045b s’il existe du contenu chiffré dans le point de restauration

Cet article fournit une solution de contournement pour un problème où la restauration du système peut échouer avec le code d’erreur 0x8007045b.

Applicabilité : Windows 10 - Toutes les éditions
Numéro de la base de connaissances d’origine : 3074925

Symptômes

Examinez le cas suivant :

  • Vous utilisez l’application Courrier dans Windows 8.1 ou Windows 8.
  • Vous souhaitez utiliser l’application courrier pour vous connecter à un serveur de messagerie Microsoft Exchange ou Microsoft Office 365. (Pour ce faire, vous devez accepter le Rendre mon PC plus sécurisé stratégies de sécurité appliquées à partir du serveur de messagerie.)
  • Vous effectuez l’une des actions suivantes :
    • Vous utilisez le programme Restauration du système dans Windows pour créer des points de restauration.
    • Vous essayez d’utiliser automatiquement les points de restauration créés par le système.
  • Vous essayez de restaurer le système à l’un des points de restauration après avoir accepté la sécurité appliquée.

Dans ce scénario, la restauration du système peut échouer et vous recevez un message d’erreur semblable à ce qui suit après le redémarrage du système.

La restauration du système n’a pas réussi. Les fichiers système et les paramètres de votre ordinateur n’ont pas été modifiés.

Détails :

La restauration du système n’a pas pu extraire le fichier

C :\Users<User Name>\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe....

À partir du point de restauration.

Une erreur inattendue s’est produite lors de la restauration du système. (0x8007045b)

Cause

Ce problème se produit en raison d’un problème connu dans le programme restauration du système.

Une fois que vous avez configuré l’application de messagerie pour vous connecter à un serveur Exchange ou Office 365 et accepter les stratégies de sécurité Plus sécurisées de mon PC, certains fichiers du profil utilisateur seront chiffrés à l’aide du système de fichiers de chiffrement (EFS). Et ces fichiers seront inclus dans le point de restauration si vous utilisez la restauration système pour créer un point de restauration. Lorsque vous démarrez le programme Restauration du système pour restaurer le système, la restauration du système crée une tâche d’arrêt pour effectuer le travail de restauration réel. Lorsque cette tâche est exécutée, la plupart des services système sont déjà arrêtés. Cela inclut EFS.

Toutefois, si un fichier est chiffré par EFS dans le point de restauration, le programme restauration du système doit appeler le service EFS pour extraire des fichiers de ce type à partir du point de restauration. Toutefois, étant donné que le service EFS est déjà arrêté et ne peut pas être redémarré car le système est arrêté, le processus de restauration échoue avec le code d’erreur 0x8007045b. Ce code signifie ERROR_SHUTDOWN_IN_PROGRESS.

Solution de contournement

Pour contourner ce problème, procédez comme suit pour redémarrer dans Windows RE, puis exécutez le programme restauration du système.

  1. Ouvrez une invite de commandes en tant qu’administrateur, puis exécutez la commande suivante :

    reagentc /boottore
    

    Note

    Si cette commande retourne une erreur Windows RE est désactivée , exécutez la commande suivante pour l’installer, puis réexécutez-la reagentc /enable .

  2. Redémarrez l'ordinateur. L’ordinateur redémarre dans l’environnement Windows RE.

  3. Dans Windows RE, cliquez sur Résoudre les problèmes, sur Options avancées, sur Restauration du système, puis suivez l’invite pour démarrer le programme Restauration du système. Étant donné qu’EFS est toujours en cours d’exécution dans Windows RE et que la restauration du système n’a pas besoin de créer une tâche d’arrêt pour effectuer le travail de restauration dans Windows RE, ce problème spécifique ne se produit pas dans Windows RE. Pour plus d’informations sur la commande REAgentC, consultez Options de ligne de commande REAgentC.