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Cet article explique comment résoudre un problème où les utilisateurs ne peuvent pas se connecter à Windows tant que le pilote incorrect n’est pas supprimé.
S’applique à : Windows 10, version 2004, Windows 10, version 1909, Windows 10, version 1903
Numéro de base de connaissances d’origine : 4563240
Résumé
Si vous utilisez une carte à puce PIV (Personal Identity Verification) ou un appareil multifonction qui utilise des cartes à puce PIV qui s’appuient sur le minidriver de carte à puce de boîte de réception Windows, vous avez peut-être reçu une mise à jour incorrecte du pilote. Lorsque vous essayez d’utiliser une carte à puce pour vous authentifier auprès de Windows, vous pouvez recevoir des messages d’erreur tels que « Cette carte à puce ne peut pas être utilisée » ou « L’opération nécessite une autre carte à puce ».
La mise à jour incorrecte contient l’application de fournisseur « FEITIAN - SmartCard - 1.0.0.3 » qui installe le pilote Feitian xPass Smart Card. Il s’agit d’une mise à jour légitime signée publiée par un partenaire vérifié. Toutefois, il a été ciblé par inadvertance à un ensemble plus large d’appareils que celui prévu à l’origine.
Le pilote a été extrait du système de publication Windows Update. Pour atténuer les effets indésirables, tout utilisateur qui a reçu la mise à jour doit restaurer manuellement le pilote de boîte de réception Windows. Pour plus d’informations, consultez la section « Résolution ».
Symptômes
Vous observez un ou plusieurs des symptômes suivants :
- Vous essayez de vous connecter à Windows à l’aide d’une carte à puce PIV ou d’un appareil (tel qu’un YubiKey) qui prend en charge les cartes à puce PIV et s’appuie sur le Minidriver de la boîte de réception Windows. Toutefois, vous ne pouvez pas vous connecter.
- Vous essayez de vous connecter à Windows à l’aide d’un appareil de carte à puce PIV non-Feitian. Toutefois, vous ne pouvez pas vous connecter. Si l’appareil prend en charge les fonctionnalités Fast Identity Online (FIDO), telles que U2F ou FIDO2, ces fonctionnalités continuent de fonctionner.
- Le pilote de carte à puce xPass non valide n’interface pas correctement avec d’autres appareils non Feitian qui s’appuient sur le pilote de boîte de réception. Cela génère des messages d’erreur tels que « Cette carte à puce ne peut pas être utilisée ».
L’exemple suivant montre les résultats de la commande certutil -scinfo qui s’exécute sur un ordinateur affecté. Les certificats ont été générés dans le cadre d’une inscription Microsoft AD CS. Toutefois, ils ne sont plus en mesure d’interagir avec l’appareil YubiKey PIV après l’installation du pilote xPass Smart Card.
Cause
Le pilote Feitian xPass Smart Card version 1.0.0.3 spécifie SCFILTER\CID_2777BE07-6993-4513-BD80-C184FCB0AB2D comme identificateur compatible dans le fichier .inf de son package de pilotes. Toutefois, le minidriver de carte à puce de boîte de réception Windows pour les cartes à puce PIV (Identity Device (NIST SP 800-73 [PIV])) utilise le même identificateur compatible. Si vous connectez un appareil non Feitian qui utilise le pilote de boîte de réception à votre ordinateur, Windows reconnaît le pilote Feitian comme compatible. Windows télécharge, installe et charge le pilote Feitian.
Pour plus d’informations sur la façon dont Windows sélectionne des pilotes pour un appareil, consultez Vue d’ensemble du processus de sélection de pilotes et comment Windows sélectionne un pilote pour un appareil.
Résolution
Si le pilote Feitian xPass Smart Card a été installé sur votre ordinateur, vous devez le supprimer pour revenir au pilote D’identité de boîte de réception (NIST SP 800-73 [PIV]). Après avoir supprimé le pilote de carte à puce xPass, Windows charge automatiquement le pilote de boîte de réception pour l’appareil.
Pour ce faire, vous pouvez supprimer manuellement le pilote, ou créer et exécuter un script pour le supprimer.
Déterminer si votre ordinateur est affecté
Dans Paramètres, sélectionnez Mises à jour et historique des mises à jour de l’affichage de sécurité>. Vous devez être en mesure d’identifier la mise à jour du pilote dans la liste.
Supprimer manuellement le pilote
Pour supprimer manuellement le pilote, procédez comme suit :
Connectez l’appareil de carte à puce à l’ordinateur.
Démarrez le Gestionnaire de périphériques. Vous pouvez démarrer Gestionnaire de périphériques à partir de Panneau de configuration, ou en appuyant sur Windows + R, puis en entrant devmgmt.msc.
Sélectionnez Cartes à puce, cliquez avec le bouton droit sur carte à puce xPass, puis sélectionnez Désinstaller l’appareil.
Lorsque vous y êtes invité, sélectionnez Supprimer le logiciel de pilote pour cet appareil, puis sélectionnez Désinstaller.
Créer un script pour supprimer le pilote
Pour automatiser la suppression du pilote, créez un script qui peut s’exécuter dans un fichier de commandes. Le script identifie le nom du fichier .inf du pilote et utilise PnPUtil.exe pour supprimer le pilote. Le script peut supprimer le pilote même si une carte à puce ou un appareil de carte à puce n’est pas connecté à l’ordinateur. Pour créer et utiliser un tel script, procédez comme suit :
Créez un fichier de commandes contenant la séquence de commandes suivante :
@echo off for /r %windir%\System32\DriverStore\FileRepository %%i in (*eps_piv_csp11.inf*) do (@echo %%i pnputil /delete-driver %%i /uninstall /force) pause
Sur l’ordinateur concerné, exécutez le fichier batch dans une fenêtre d’invite de commandes d’administration.
Plus d’informations
Si vous avez suivi les étapes de la section « Résolution », mais que vous avez besoin d’aide supplémentaire, accédez au site web Support Microsoft.