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Les certificats sont manquants après avoir mis à jour un appareil vers une version plus récente de Windows 10

Cet article fournit des solutions de contournement pour un problème dans lequel un appareil perd ses certificats système et utilisateur après une mise à jour du système d’exploitation.

S’applique à : Windows 10, version 20H2 ; Windows 10, version 2004 ; Windows 10, version 1909 ; Windows 10, version 1903

Symptômes

Vous disposez d’un appareil qui exécute Windows 10, version 1809 ou ultérieure. L’appareil a également une dernière mise à jour cumulative (LCU) publiée le 16 septembre 2020 ou un LCU ultérieur. Après avoir mis à jour l’appareil vers une version ultérieure de Windows, l’appareil perd ses certificats système et utilisateur.

Cause

Ce comportement peut se produire si la source d’installation ou le support utilisé pour mettre à jour l’appareil est obsolète. La mise à jour n’inclut pas de LCU publiée le 13 octobre 2020 ou version ultérieure. Le comportement affecte généralement les appareils gérés dans les environnements dans lesquels un outil de gestion des mises à jour, tel que Windows Server Update Services (WSUS) ou Microsoft Endpoint Configuration Manager télécharge les mises à jour, puis les distribue aux appareils. Il affecte également les appareils mis à jour à l’aide de supports physiques ou d’images ISO obsolètes.

Ce comportement n’affecte pas les appareils qui utilisent Windows Update for Business ou qui se connectent directement à Windows Update. Tous les appareils qui se connectent à Windows Update doivent toujours recevoir les dernières versions de la mise à jour des fonctionnalités, y compris les derniers LCU, sans aucune étape supplémentaire.

Solution de contournement

Pour résoudre ce problème, effectuez l’une des opérations suivantes :

  • Téléchargez une nouvelle image source à partir du catalogue Microsoft Update ou du Centre de gestion des licences en volume pour remplacer l’image source précédente. Ensuite, utilisez cette image pour mettre à jour l’appareil.
  • Restaurez l’appareil vers la version précédente de Windows, ajoutez l’unité DCU manquante à la mise à jour, puis réinstallez la mise à jour.

Important

  • Le processus de restauration n’affecte pas vos fichiers personnels, mais supprime toutes les applications et pilotes que vous avez installés après avoir installé la mise à jour. Elle inverse également les modifications apportées aux paramètres que vous avez effectués après avoir installé la mise à jour.

  • Par défaut, vous pouvez restaurer une mise à jour uniquement dans les 10 jours suivant l’installation. Vous pouvez modifier cette limite de temps dans une fenêtre d’invite de commandes en exécutant la commande suivante :

    Dism /Online /Set-OSUninstallWindow /Value:<days>
    

    Dans cette commande, <les jours> sont un entier compris entre 2 et 60.

Pour restaurer, procédez comme suit :

  1. Sélectionnez Démarrer>la mise à jour des paramètres>et la récupération de sécurité.>
  2. Sous Revenir à la version précédente de Windows 10, sélectionnez Prise en main.

Pour ajouter la dernière unité DCU à la source de mise à jour, procédez comme suit :

  1. Montez l’image ISO source, puis copiez le fichier Install.wim dans un emplacement accessible en écriture.

    Note

    Si l’image a un fichier Install.esd au lieu d’un fichier Install.wim , utilisez la Dism /Export-Image commande pour convertir le fichier .esd en fichier .wim.

  2. Accédez à l’historique des mises à jour Windows 10 pour rechercher le numéro DCU approprié pour votre version système.

  3. Accédez au catalogue Microsoft Update, puis téléchargez le LCU.

    Note

    • Si vous utilisez WSUS pour gérer les mises à jour, consultez WSUS et le site catalogue. Cet article explique comment utiliser WSUS pour télécharger des mises à jour à partir du catalogue Microsoft Update.
    • Si vous utilisez Microsoft Intune pour gérer les mises à jour, consultez la documentation de gestion des mises à jour logicielles.
  4. Pour ajouter la LCU à l’image, ouvrez une fenêtre d’invite de commandes d’administration, puis exécutez la commande suivante :

    Dism /Add-Package /Image:"C:\Mount\Windows" /PackagePath="windows10.0-kb4586781-x64_bd543ce012ec1695201cdb2d324a2206bd445132.msu" /LogPath=C:\Mount\Dism.log
    
  5. Passez en revue la liste des packages générés par la Dism commande et vérifiez que la liste contient le package. Pour afficher la liste, exécutez la commande suivante :

    Dism /Get-Packages /Image:<Path_to_Image>
    

    Note

    Dans cette commande, <Path_to_Image> est le chemin d’accès et le nom de fichier du fichier image.

  6. Validez et démontez l’image. Pour ce faire, exécutez la commande suivante :

    Dism /Unmount-Image /MountDir:<Path_to_Mount_Directory> /Commit
    

    Note

    Dans cette commande, <Path_to_Mount_Directory> est le chemin d’accès à l’image montée.

  7. (Facultatif) Utilisez le fichier mis à jour pour recréer l’image. Pour ce faire, exécutez la commande suivante :

    Oscdimg –n –d –m "<Source>" "<Target.iso>"
    

    Note

    Dans cette commande, <Source> est l’emplacement des fichiers que vous envisagez de générer dans une image, et <Target.iso> est le nom du fichier image ISO.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.

Référence