Message d’erreur « Windows n’a pas pu analyser ou traiter le fichier de réponses sans assistance pour passer [spécialisé] » lorsque vous effectuez une mise à niveau sur place

Cet article fournit une aide pour corriger une erreur (Windows n’a pas pu analyser ou traiter le fichier de réponses sans assistance pour pass [spécialisation]) qui se produit lorsque vous effectuez une mise à niveau sur place.

Produits concernés : Windows 7 Service Pack 1, Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 2425962

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous exécutez une version de Windows 7 ou de Windows Server 2008 R2 qui a été installée à l’aide d’un fichier Unattend.xml.
  • Vous démarrez l’ordinateur à partir de cette image, puis sélectionnez l’option Réparer la mise à niveau sur place (remplacer l’installation).
  • Vous démarrez la mise à niveau sur place.

Dans ce scénario, vous recevez le message d’erreur suivant : Windows n’a pas pu analyser ou traiter le fichier de réponses sans assistance pour passer [spécialisé].

En règle générale, les fichiers Unattend.xml sont utilisés pour le déploiement d’un environnement OEM ou d’entreprise. Par conséquent, l’image peut contenir un fichier Unattend.xml et vous ne savez peut-être pas que ce fichier est inclus.

Cause

Ce problème se produit parce que le fichier Unattend.xml est appliqué pendant la mise à niveau sur place. Ce scénario n’est pas pris en charge.

Plus d’informations

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde et la restauration du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft : 322756 Comment sauvegarder et restaurer le Registre dans Windows

Lorsque ce comportement se produit, vous ne pouvez pas récupérer le système. Par conséquent, vous devez effectuer une installation propre.

Pour éviter ce comportement, vous pouvez supprimer une sous-clé de Registre avant d’utiliser l’image d’installation OEM pour exécuter une mise à niveau sur place. Pour cela, procédez comme suit :

  1. Connectez-vous à l’ordinateur à l’aide d’un compte d’utilisateur disposant d’autorisations administratives.
  2. Cliquez sur Démarrer, tapez regedit dans la zone de recherche Démarrer , puis dans la liste Programmes , cliquez sur regedit.exe.
  3. Recherchez et cliquez avec le bouton droit sur la sous-clé de Registre suivante : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\FavoritesList\Favorite<XX>

    Remarque

    Dans cette sous-clé, <XX> est un espace réservé pour les nombres commençant par 1.

  4. Cliquez sur Supprimer, sur Oui, puis quittez le Registre Rédacteur.

Statut

Ce comportement est inhérent au produit.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.