Sysprep échoue après la suppression ou la mise à jour des applications du Microsoft Store qui incluent des images Windows intégrées

Cet article décrit un problème qui se produit lorsque vous supprimez ou mettez à jour une application du Microsoft Store provisionnée à l’aide du Microsoft Store, puis que vous exécutez sysprep sur l’ordinateur.

S’applique à : Windows 10 - toutes les éditions, Windows 11
Numéro de la base de connaissances d’origine : 2769827

Introduction

Sysprep est un outil destiné aux administrateurs informatiques qui souhaitent préparer une installation de Windows pour la duplication, l’audit et la livraison aux clients. Les conseils de cet article sont destinés aux agents de support et aux professionnels de l’informatique. Si vous êtes un utilisateur à domicile qui rencontre des problèmes lors de l’utilisation des applications du Microsoft Store, consultez Résoudre les problèmes liés aux applications du Microsoft Store.

Plusieurs applications du Microsoft Store sont intégrées aux images Windows. Ces applications incluent les applications Courrier, Cartes, Messagerie, Bing, Voyage et Actualités, entre autres. Ces applications sont appelées applications approvisionnées . Les applications approvisionnées sont intermédiaires dans l’image et sont planifiées pour être installées pour chaque utilisateur de l’image Windows lors de la première ouverture de session. En plus des applications intégrées, vous pouvez charger de manière indépendante vos propres applications métier du Microsoft Store dans l’image Windows sans avoir à les publier sur le Microsoft Store. Vous pouvez charger Appx de manière test des packages à l’aide de commandes de maintenance en ligne ou hors connexion disponibles dans DISM.exe ou via le module PowerShell DISM.

Symptômes

Plusieurs scénarios sont envisageables :

Scénario 1

  • Vous créez un ordinateur de référence Windows 10 ou Windows 11 personnalisé que vous souhaitez sysprep et capturer.
  • Vous souhaitez supprimer certaines des applicationsAppx (packages) du Microsoft Store approvisionnées de cet ordinateur de référence.
  • Vous exécutez dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> pour déprovisionner les Appx packages.

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14
Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

Scénario 2

  • Vous disposez d’une image Windows existante et plusieurs applications du Microsoft Store sont chargées de manière indépendante dans l’image.
  • Vous souhaitez supprimer certains des packages chargés Appx de côté de votre image et la personnaliser davantage.
  • Vous démarrez sur l’ordinateur de référence et exécutez l’une des commandes PowerShell suivantes pour supprimer l’approvisionnement du Appx package :
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14
Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

Scénario 3

  • Vous créez une image de référence Windows 10 ou Windows 11.
  • Vous vous connectez au Microsoft Store, puis vous mettez à jour les applications intégrées du Microsoft Store à l’aide du Microsoft Store.

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14 Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

En outre, dans le SetupErr.log, vous pouvez remarquer les entrées d’erreur suivantes :

<Date><Time>, Error SYSPRP PackageFullName <> a été installé pour un utilisateur, mais pas provisionné pour tous les utilisateurs. Ce package ne fonctionnera pas correctement dans l’image sysprep.
<Date><Et heure>, Erreur SYSPRP Échec de la suppression des applications pour l’utilisateur actuel : 0x80073cf2.
<Date><Et heure>, erreur SYSPRP Code de sortie du thread RemoveAllApps 0x3cf2.
<Date><Heure>, Erreur [0x0f0082] ACTION SYSPRPPlateforme ::LaunchModule : Échec survenu lors de l’exécution de « SysprepGeneralize » à partir de C:\Windows\System32\AppxSysprep.dll ; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform ::ExecuteAction : Error in executing action ; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform ::ExecuteActionList : Error in execute actions ; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP SysprepSession ::Execute : Error in executing actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml ; dwRet = 0x3cf2
<Date><Time>, Erreur SYSPRP RunPlatformActions :Failed lors de l’exécution d’actions SysprepSession ; dwRet = 0x3cf2
<Date><Time>, Error [0x0f0070] SYSPRP RunExternalDlls : Une erreur s’est produite lors de l’exécution des DLL sysprep du Registre, arrêtant l’exécution de sysprep. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain :Hit failure while processing sysprep generalize internal providers ; hr = 0x80073cf2

Cause

Sysprep a un fournisseur supplémentaire qui est ajouté dans Windows pour propre Appx packages et pour généraliser l’image. Le fournisseur fonctionne uniquement si le Appx package est un package par utilisateur ou un package provisionné tout utilisateur.

  • Le package par utilisateur signifie que le Appx package est installé pour un compte d’utilisateur particulier et n’est pas disponible pour les autres utilisateurs de l’ordinateur.
  • Le package all-user signifie que le Appx a été provisionné dans l’image afin que tous les utilisateurs qui utilisent cette image puissent accéder à l’application.

Si un package tout utilisateur approvisionné dans l’image a été déprovisionné manuellement de l’image, mais n’a pas été supprimé pour un utilisateur particulier, le fournisseur rencontrera une erreur lors du nettoyage de ce package pendant sysprep. Le fournisseur échoue également si un package tout utilisateur approvisionné dans l’image a été mis à jour par l’un des utilisateurs sur cet ordinateur de référence.

Résolution

Pour résoudre ce problème, supprimez le package pour l’utilisateur qui exécute sysprep et supprimez également l’approvisionnement. Pour cela, procédez comme suit.

Remarque

Pour empêcher le Microsoft Store de mettre à jour les applications, débranchez la connexion Internet ou désactivez Mises à jour automatique en mode Audit avant de créer l’image.

  1. Exécutez les applets de commande Windows PowerShell suivantes dans cet ordre:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Remarque

  • Dans la sortie de cette dernière applet de commande, case activée les utilisateurs pour lesquels le package s’affiche comme Installé. Supprimez ces comptes d’utilisateur de l’ordinateur de référence ou connectez-vous à l’ordinateur à l’aide de ces comptes d’utilisateur. Ensuite, exécutez l’applet de commande à l’étape 2 pour supprimer le Appx package.
  • Cette commande répertorie tous les packages publiés par Microsoft et installés par n’importe quel utilisateur de cet ordinateur de référence. Étant donné que l’ordinateur doit être sysprepped, nous partons du principe que ces profils utilisateur ne nécessitent plus le package.
  • Si vous avez approvisionné manuellement des applications qui appartiennent à d’autres éditeurs, exécutez la commande suivante pour les répertorier :

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Supprimez Appx le package en exécutant l’applet de commande suivante :

    Remove-AppxPackage -Package <packagefullname>
    
  2. Supprimez l’approvisionnement en exécutant l’applet de commande suivante :

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Si vous essayez de récupérer suite à un problème de mise à jour, vous pouvez reprovisionner l’application après avoir suivi ces étapes.

Remarque

Le problème ne se produit pas si vous gérez une image hors connexion. Dans ce scénario, l’approvisionnement est automatiquement effacé pour tous les utilisateurs. Cela inclut l’utilisateur qui exécute la commande.

Informations supplémentaires

Pour plus d’informations sur l’ajout et la suppression d’applications, consultez :

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.