Partager via


Sysprep échoue après avoir supprimé ou mis à jour des applications du Microsoft Store qui incluent des images Windows intégrées

Cet article traite d’un problème qui se produit lorsque vous supprimez ou mettez à jour une application Microsoft Store provisionnée à l’aide du Microsoft Store, puis exécutez sysprep sur l’ordinateur.

S’applique à : Windows 10 - toutes les éditions, Windows 11
Numéro de base de connaissances d’origine : 2769827

Introduction

Sysprep est un outil pour les administrateurs informatiques qui souhaitent préparer une installation de Windows pour la duplication, l’audit et la livraison des clients. Les conseils de cet article sont destinés à être utilisés par les agents de support et les professionnels de l’informatique. Si vous êtes un utilisateur à domicile qui rencontre des problèmes lors de l’utilisation d’applications du Microsoft Store, consultez Résoudre les problèmes liés aux applications du Microsoft Store.

Plusieurs applications du Microsoft Store sont intégrées aux images Windows. Ces applications incluent les applications Courrier, Cartes, Messagerie, Bing, Voyage et Actualités, entre autres. Ces applications sont appelées applications approvisionnées . Les applications provisionnées sont intermédiaires dans l’image et sont planifiées pour être installées pour chaque utilisateur de l’image Windows au premier ouverture de session. Outre les applications intégrées, vous pouvez charger côte à côte vos propres applications du Microsoft Store métier dans l’image Windows sans avoir à les publier dans le Microsoft Store. Vous pouvez charger Appx des packages côte à côte à l’aide de commandes de maintenance en ligne ou hors connexion disponibles dans DISM.exe ou via le module PowerShell DISM.

Symptômes

Examinez les scénarios suivants :

Scénario 1

  • Vous créez un ordinateur de référence Windows 10 ou Windows 11 personnalisé que vous souhaitez sysprep et capturer.
  • Vous souhaitez supprimer certaines des applications du Microsoft Store approvisionnées (Appx packages) de cet ordinateur de référence.
  • Vous exécutez dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> pour déprovisionner les Appx packages.

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14
Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

Scénario 2

  • Vous disposez d’une image Windows existante et plusieurs applications du Microsoft Store sont chargées côte à côte dans l’image.
  • Vous souhaitez supprimer certains des packages chargés Appx côté de votre image et le personnaliser davantage.
  • Vous démarrez sur l’ordinateur de référence et exécutez l’une des commandes PowerShell suivantes pour supprimer l’approvisionnement du Appx package :
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14
Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

Scénario 3

  • Vous créez une image de référence Windows 10 ou Windows 11.
  • Vous vous connectez au Microsoft Store, puis mettez à jour les applications intégrées du Microsoft Store à l’aide du Microsoft Store.

Lorsque vous exécutez l’opération sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation du système 3.14 Une erreur irrécupérable s’est produite lors de la tentative de sysprep de l’ordinateur

En outre, dans le SetupErr.log, vous pouvez remarquer les entrées d’erreur suivantes :

<Date><Time>, Error SYSPRP PackageFullName <> a été installé pour un utilisateur, mais pas provisionné pour tous les utilisateurs. Ce package ne fonctionnera pas correctement dans l’image sysprep.
<Heure> de date><, erreur SYSPRP Échec de la suppression des applications pour l’utilisateur actuel : 0x80073cf2.
<Date><Time>, Error SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
<Date><Time>, Error [0x0f0082] SYSPRP ActionPlatform ::LaunchModule : Failure s’est produit lors de l’exécution de « SysprepGeneralize » à partir de C :\Windows\System32\AppxSysprep.dll ; dwRet = 0x3cf2
<Date><Heure>, Erreur SYSPRP ActionPlatform ::ExecuteAction : Erreur lors de l’exécution de l’action ; dwRet = 0x3cf2
<Date><Heure>, Erreur SYSPRP ActionPlatform ::ExecuteActionList : Erreur dans les actions d’exécution ; dwRet = 0x3cf2
<Heure> de date><, erreur SYSPRP SysprepSession ::Execute : erreur lors de l’exécution d’actions à partir de C :\Windows\System32\Sysprep\ActionFiles\Generalize.xml ; dwRet = 0x3cf2
<Heure> de date><, erreur SYSPRP RunPlatformActions :Failed lors de l’exécution d’actions SysprepSession ; dwRet = 0x3cf2
<Date><Time>, Error [0x0f0070] SYSPRP RunExternalDlls :Une erreur s’est produite lors de l’exécution des DLL sysprep du Registre, arrêtant l’exécution de sysprep. dwRet = 0x3cf2
<Heure> de date><, erreur [0x0f00a8] SYSPRP WinMain :Hit failure while processing sysprep generalize internal providers ; hr = 0x80073cf2

Cause

Sysprep dispose d’un fournisseur supplémentaire qui est ajouté dans Windows pour nettoyer Appx les packages et généraliser l’image. Le fournisseur fonctionne uniquement si le Appx package est un package par utilisateur ou un package provisionné à l’utilisateur.

  • Le package par utilisateur signifie que le Appx package est installé pour un compte d’utilisateur particulier et n’est pas disponible pour d’autres utilisateurs de l’ordinateur.
  • Tout package utilisateur signifie que le Appx package a été provisionné dans l’image afin que tous les utilisateurs qui utilisent cette image puissent accéder à l’application.

Si un package all-user approvisionné dans l’image a été déprovisionné manuellement de l’image, mais pas supprimé pour un utilisateur particulier, le fournisseur rencontre une erreur lors du nettoyage de ce package pendant sysprep. Le fournisseur échoue également si un package tout utilisateur approvisionné dans l’image a été mis à jour par l’un des utilisateurs sur cet ordinateur de référence.

Résolution

Pour résoudre ce problème, supprimez le package de l’utilisateur qui exécute sysprep et supprimez également l’approvisionnement. Pour ce faire, procédez comme suit.

Note

Pour empêcher le Microsoft Store de mettre à jour les applications, déconnectez la connexion Internet ou désactivez les mises à jour automatiques en mode Audit avant de créer l’image.

  1. Exécutez les applets de commande PowerShell suivantes :

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Note

  • Dans la sortie de cette dernière applet de commande, vérifiez les utilisateurs pour lesquels le package s’affiche en tant qu’installé. Supprimez ces comptes d’utilisateur de l’ordinateur de référence ou connectez-vous à l’ordinateur à l’aide de ces comptes d’utilisateur. Ensuite, exécutez l’applet de commande à l’étape 2 pour supprimer le Appx package.
  • Cette commande répertorie tous les packages publiés par Microsoft et installés par n’importe quel utilisateur de cet ordinateur de référence. Étant donné que l’ordinateur doit être sysprepped, nous partons du principe que ces profils utilisateur ne nécessitent plus le package.
  • Si vous avez configuré manuellement des applications appartenant à d’autres éditeurs, exécutez la commande suivante pour les répertorier :

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Supprimez Appx le package en exécutant l’applet de commande suivante :

    Remove-AppxPackage -Package <packagefullname>
    
  2. Supprimez le provisionnement en exécutant l’applet de commande suivante :

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Si vous essayez de récupérer à partir d’un problème de mise à jour, vous pouvez reprovisionner l’application après avoir suivi ces étapes.

Note

Le problème ne se produit pas si vous effectuez la maintenance d’une image hors connexion. Dans ce scénario, l’approvisionnement est automatiquement effacé pour tous les utilisateurs. Cela inclut l’utilisateur qui exécute la commande.

Plus d’informations

Pour plus d’informations sur l’ajout et la suppression d’applications, consultez :

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.