Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit une solution à un problème où l’écran noir Windows lors du déverrouillage d’un ordinateur.
S’applique à : Windows 7 Service Pack 1
Numéro de la base de connaissances d’origine : 2431700
Symptômes
Examinez le cas suivant :
- Un ordinateur Windows Vista ou Windows 7 exécute le mode graphique « Aero ».
- L’ordinateur Windows Vista ou Windows 7 est soumis à d’autres restrictions de sécurité et logiciels de sécurité, tels que peut être le cas dans l’entreprise, ou avec des paramètres de sécurité et des logiciels mandatés tels que les exigences DISA ou DoD.
- L’ordinateur est verrouillé et laissé non perturbé suffisamment longtemps pour que l’écran passe en noir, soit 20 minutes avec la stratégie d’alimentation par défaut de « Équilibré ».
- Une personne déverrouille l’ordinateur en entrant ses informations d’identification utilisateur.
Une fois les informations d’identification entrées, l’écran est noir et reste noir pendant 10 minutes ou plus. La machine n’est pas « verrouillée en dur », car l’activité périodique du lecteur de disque peut être notée à partir de la lumière de l’indicateur de lecteur de disque sur l’ordinateur, le cas échéant.
Cause
Un problème lié à une couche de logiciel de sécurité entraîne l’attente d’un délai non spécifié par le Gestionnaire de fenêtres de bureau.
Résolution
Une solution de contournement temporaire consiste à arrêter et désactiver le service « Gestionnaire de sessions du Gestionnaire de sessions du Gestionnaire de fenêtres de bureau ». La désactivation de ce service désactive la fonctionnalité d’affichage graphique « Aero », qui désactive certaines fonctionnalités telles que Aero Peek, Aero Snap, Aero Shake, etc. Pour désactiver ce service :
- Cliquez sur le bouton Démarrer , tapez services.msc , puis appuyez sur entrée, ou cliquez sur l’icône qui apparaît sous Programmes dans la zone Recherche instantanée.
- Recherchez, puis double-cliquez sur le service Gestionnaire de sessions du Gestionnaire de sessions du Gestionnaire de fenêtres de bureau.
- Recherchez la liste déroulante type de démarrage et remplacez la valeur par « disabled ».
- Recherchez et cliquez sur le bouton intitulé « Arrêter ».
- Cliquez sur le bouton Appliquer , puis sur le bouton OK .
Vous pouvez également exécuter les commandes suivantes à partir d’une invite CMD avec élévation de privilèges pour définir les propriétés de service du service Gestionnaire de sessions Du Gestionnaire de session Du Gestionnaire de fenêtres de bureau sur non en cours d’exécution et désactivée :
net stop UxSms sc config UxSms start= disabled
Pour renvoyer les paramètres du service Gestionnaire de session du Gestionnaire de session du Gestionnaire de fenêtres de bureau à normal via la ligne CMD :
sc config UxSms start= auto net start UxSms
Les pilotes d’affichage mis à jour peuvent résoudre ce problème. Vous pouvez déterminer le fabricant de l’adaptateur d’affichage en procédant comme suit :
- Cliquez sur Démarrer, puis dans la zone de texte Rechercher des programmes et dossiers , tapez MSINFO32 (sans guillemets) et appuyez sur Entrée.
Note
L’outil Informations système doit apparaître.
- Dans la section de gauche appelée Résumé système localiser les composants, puis, sous Composants , recherchez et cliquez sur Afficher.
- La section de droite des informations système doit maintenant afficher des informations sur le système d’affichage sur l’ordinateur. L’élément appelé « Name » doit indiquer le type d’adaptateur d’affichage.
- À ce stade, vous pouvez accéder au site web Internet du fournisseur ou au fournisseur de votre ordinateur pour localiser les pilotes mis à jour.
- Dans certains cas, vous pouvez proposer des pilotes vidéo mis à jour en exécutant Windows Update.
- Si vous ne savez pas quels pilotes installer, contactez le fournisseur du matériel de votre ordinateur pour obtenir de l’aide sur la localisation d’un package de pilotes d’affichage mis à jour.
- Cliquez sur Démarrer, puis dans la zone de texte Rechercher des programmes et dossiers , tapez MSINFO32 (sans guillemets) et appuyez sur Entrée.
Une autre solution consiste à découvrir quelle couche de logiciel de sécurité provoque le blocage temporaire, qui restitue l’écran noir et donc inutilisable. Cette couche de logiciels doit être désinstallée ou mise à jour pour empêcher la condition de blocage dans le Gestionnaire de fenêtres de bureau.
Plus d’informations
Un symptôme qui a été noté si cette condition est vraie est que le processus DWM ou Desktop Window Manager consomme une quantité croissante de mémoire, comme indiqué dans le Gestionnaire des tâches.