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Cet article fournit de l’aide pour résoudre une erreur 0xCAA5001C qui se produit lorsque vous accédez à Microsoft Store pour Entreprises sur un ordinateur Windows 10.
S’applique à : Windows 10, version 1903, Windows 10, version 1809, Windows 10, version 1709
Numéro de la base de connaissances d’origine : 3196528
Symptômes
Après vous être connecté à un ordinateur Windows 10, vous essayez d’accéder à Microsoft Store pour Entreprises. Toutefois, l’authentification Microsoft Entra échoue et certains événements sont enregistrés dans le journal Microsoft-Windows-AAD/Operational.
En plus de Microsoft Store pour Entreprises, ce problème peut affecter Enterprise State Roaming.
Cause
Ce problème se produit s’il existe des autorisations ou des attributs de propriété manquants sur une ou les deux clés de Registre suivantes :
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
HKEY_USERS\S-1-5-21-299502267-1950408961-849522115-1818\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion \AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
Note
Faites correspondre le SID signalé pour l’utilisateur dans l’ID d’événement 1098 au chemin d’accès sous HKEY_USERS. Dans cet exemple, il s’agit de S-1-5-21-299502267-1950408961-849522115-1818.
Résolution
Pour résoudre ce problème, effectuez les étapes suivantes :
- Prenez possession de la clé si nécessaire (Propriétaire = SYSTEM).
- Corrigez les autorisations sur ces clés de Registre en activant l’héritage (la résolution d’un problème doit corriger les deux, sauf si plusieurs utilisateurs se connectent au même appareil) :
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
HKEY_USERS\S-1-5-21-299502267-1950408961-849522115-1818\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion \AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
Type | Principal | y accéder | Hérité de | S’applique à |
---|---|---|---|---|
Autoriser | S-1-15-2-1910091885-1573563583-1104941280-2418270861-3411158377-2822700936-2990310272 | Demander la valeur | Aucun(e) | Cette clé uniquement |
Autoriser | SYSTEM | Contrôle total | CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Cette clé et ces sous-clés |
Autoriser | Compte d’utilisateur de domaine (user@contoso.com ) |
Contrôle total | CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Cette clé et ces sous-clés |
Autoriser | Administrateurs (COMPUTER\Administrators) | Contrôle total | CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Cette clé et ces sous-clés |
Autoriser | Créateur propriétaire | Contrôle total | CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Sous-clés uniquement |
Note
Si vous affichez les autorisations de la clé de Registre ~\PSR sous HKEY_USERS{SID}, le champ Hérité affiche l’héritage à partir du chemin d’accès HKEY_USERS{SID}.
Si cela ne résout pas le problème, envisagez d’exécuter Process Monitor lors de l’exécution de la méthode d’authentification pour rechercher ACCESS REFUSÉ dans d’autres domaines du registre ou du système de fichiers susceptible d’entraîner l’échec d’authentification. Si vous en découvrez un, ajoutez-les à cet article.