Partager via


Les services qui dépendent du service d’état ASP.NET ne démarrent pas après la mise à niveau vers .NET Framework 4.0

Cet article fournit une solution de contournement pour un problème où les services qui dépendent du ASP.NET service d’état ne démarrent pas après la mise à niveau vers Microsoft .NET Framework 4.0.

Numéro de la base de connaissances d’origine : 2963657

Symptômes

Examinez le cas suivant :

  • Vous disposez d’un ordinateur exécutant Windows Server.
  • Le service d’état ASP.NET est installé dans le cadre d’Internet Information Services (IIS).
  • Un service installé dépend du service d’état ASP.NET.
  • Vous mettez à niveau Microsoft .NET Framework 3.51 vers .NET Framework 4.0.

Dans ce scénario, vous remarquez qu’après la mise à niveau de .NET Framework, tout service qui dépend du service d’état ASP.NET ne démarre pas et génère l’erreur suivante :

Windows n’a pas pu démarrer le service de nom> de service sur <le <nom> de l’ordinateur.

Erreur 1075 : Le service de dépendance n’existe pas ou a été marqué pour suppression.

Vous remarquerez également que le service d’état ASP.NET n’est plus répertorié dans la console Gestion des services.

Cause

Il s’agit d’un problème connu qui se produit lorsque vous mettez à jour .NET Framework.

Solution de contournement

Pour contourner ce problème, effectuez les étapes suivantes :

  1. Ouvrez le console de gestion Services (services.msc).

  2. Passez au type de démarrage de n’importe quel service qui dépend du service d’état ASP.NET et qui est défini sur Automatique.

  3. À l’invite de commandes d’administration, tapez la commande suivante, puis appuyez sur Entrée :

    %SystemRoot%\ Microsoft.NET\Framework64\v4.0.30319 \aspnet_regiis /iru
    
  4. Redémarrez l'ordinateur.

  5. Ouvrez à nouveau les services console de gestion (services.msc).

  6. Passez au type de démarrage automatique du service ou des services dont le type de démarrage a changé à l’étape 2, qui dépendent du service d’état ASP.NET et dont le type de démarrage est maintenant défini sur Manuel. Redémarrez l’ordinateur, puis vérifiez que le problème est résolu.