Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit de l’aide pour résoudre un conflit WinStoreUI.admx qui se produit lorsque le Magasin central est mis à jour à l’aide de fichiers ADMX Windows 10 version 1511.
S’applique à : Windows Server (toutes les versions prises en charge)
Numéro de base de connaissances d’origine : 3190327
Symptômes
Le fichier WinStoreUI.admx est disponible dans Windows Server 2012 R2, mais n’est pas inclus dans la version initiale de Windows 10. Toutefois, après avoir mis à jour le Magasin central à l’aide des fichiers .admx à partir de Windows 10 version 1511, l’erreur suivante s’affiche dès que vous commencez à modifier un objet de stratégie de groupe (GPO) :
L’espace de noms « Microsoft.Policies.WindowsStore » est déjà défini comme espace de noms cible pour un autre fichier dans le magasin.
La comparaison des fichiers .admx de Windows Server 2012 R2 et Windows 10 version 1511 montre que WindowsStore.admx contient les mêmes informations que WinStoreUI.admx, ainsi que quelques paramètres de stratégie supplémentaires. Après avoir supprimé WinStoreUI.admx, cette erreur ne se produit plus. Toutefois, le jeu de stratégies résultant sur un ordinateur 2012 R2 contient l’erreur suivante :
Une erreur s’est produite lors de la collecte de données pour les modèles d’administration. Les erreurs suivantes ont été rencontrées
Impossible de trouver un fichier de ressources approprié pour \\domain\<sysvol\<domain.dns>> policies\PolicyDefinitions\WinStoreUI.admx(error = 2) : le système ne trouve pas le fichier spécifié.
Cause
Dans Windows 10 Version 1507, le fichier .admx store a été supprimé. Un correctif a restauré le fichier .admx. Toutefois, ce fichier a maintenant un nouveau nom. Une fois la version 1511 installée, lorsque les clients mettent à jour leur Magasin central, ils ont maintenant deux fichiers .admx qui ont des paramètres identiques. Comme cela n’est pas autorisé, l’erreur décrite dans la section « Symptômes » se produit.
Les fichiers .admx sont les suivants :
- Nom du fichier de stratégie de groupe du magasin d’origine : winstoreui.admx
- Nouveau nom de fichier de stratégie de groupe store : windowsstore.admx
Résolution
Ce problème est résolu dans Windows 10 version 1511 et par la mise à jour cumulative la plus récente. Si possible, les clients concernés doivent effectuer une mise à niveau vers cette version. Pour empêcher l’erreur de se produire lorsque vous ouvrez Gpedit.msc et que vous exécutez Gpresult.exe, procédez comme suit :
- Vérifiez que vous disposez de winstoreui.admx et windowsstore.admx dans le Magasin central.
- Supprimez les fichiers winstoreui.admx et winstoreui.adml du Magasin central.
- Vérifiez que l’ouverture de Gpedit.msc et l’exécution de Gpresults.exe fonctionnent sans erreur.