Partager via


Erreur C0190003 après l’installation des mises à jour dans Windows Server 2012 R2

Cet article fournit une solution de contournement pour un problème qui déclenche une erreur lorsque vous redémarrez un ordinateur Windows Server 2012 R2 après avoir installé les mises à jour.

Numéro de base de connaissances d’origine : 3074603

Symptômes

Examinez le cas suivant :

  • Vous essayez d’installer de nombreuses mises à jour à partir de Windows Update. Cela inclut les 3000850 de mise à jour.
  • Vous utilisez un disque de secteur 4K natif en tant que lecteur système.

Toutefois, une fois le processus d’installation de mise à jour terminé et que l’ordinateur est redémarré, vous pouvez recevoir l’un des messages d’erreur suivants :

Erreur C0190003 application de l’opération de mise à jour 21417 de 247778 (fenêtre wow64_microsoft

Erreur irrécupérable C0190003 l’application de l’opération de mise à jour 19505 de 247778 (amd64_microsoft

Note

Le nombre d’opérations et de noms de fichiers peut varier.

Dans ce cas, l’ordinateur ne redémarre pas correctement.

Cause

Pendant le processus d’installation, toutes les opérations de fichier (copie, déplacement et suppression, par exemple) doivent être transactionnelles. Toutefois, s’il existe un grand nombre de fichiers à traiter, le journal des transactions peut devenir complet. Dans ce cas, les transactions sont annulées et le message d’erreur s’affiche.

Solution de contournement

Si vous n’avez pas encore installé les mises à jour, vous pouvez contourner ce problème en augmentant la taille du journal des transactions. Pour ce faire, ouvrez cmd.exe en tant qu’administrateur, puis exécutez la commande suivante :

fsutil resource setlog maxextents 100 C:\

Note

Cette commande augmente le nombre maximal de conteneurs pour le lecteur de démarrage (lecteur C) à 100. (La valeur par défaut est 20.) Si vous définissez la valeur sur 100 et que vous rencontrez toujours la même erreur, vous pouvez essayer un nombre plus élevé.

Si vous avez déjà rencontré le problème décrit dans la section Symptômes , vous pouvez récupérer à partir du problème en procédant comme suit :

  1. Lorsque le message d’erreur s’affiche, appuyez sur le bouton d’alimentation pour désactiver l’ordinateur.

  2. Appuyez sur le bouton d’alimentation, puis appuyez immédiatement sur la touche F8. Le menu Options de démarrage avancées s’affiche.

  3. Sélectionnez Réparer votre ordinateur, puis appuyez sur Entrée.

  4. Dans le menu Choisir une option , sélectionnez Résoudre les problèmes.

  5. Dans le menu Options avancées , sélectionnez Invite de commandes.

  6. Sélectionnez le compte d’administrateur, puis entrez le mot de passe.

  7. À l’invite de commandes (cmd.exe), exécutez la commande suivante :

    Dism /image:C:\ /cleanup-image /revertpendingactions
    
  8. Fermez l'invite de commande.

  9. Dans le menu Choisir une option , sélectionnez Continuer.

État

Microsoft a confirmé qu’il s’agit d’un problème dans Windows Server 2012 R2.

References

Stratégie de support Microsoft pour les disques durs du secteur 4K dans Windows

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.