Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit une solution à un problème où les clients WSUS (Windows Server Update Services) ne peuvent pas installer les mises à jour lorsque Symantec Endpoint Protection est installé sur le même site web.
Numéro de base de connaissances d’origine : 968248
Symptôme
Les clients WSUS n’installent pas les mises à jour approuvées à partir de WSUS.
Symantec Endpoint Protection Manager est en mesure de télécharger les définitions actuelles sur les clients.
Les ordinateurs clients WSUS sont configurés correctement pour se connecter à WSUS et s’affichent sur la console Administration WSUS. Le serveur WSUS est fonctionnel à tous les autres égards.
Cause
WSUS et Symantec Endpoint Protection Manager utilisent tous deux un répertoire virtuel appelé « Contenu ». Si WSUS et Symantec sont tous deux installés sur le même site web par défaut à l’aide du port 80, seul le dernier installé sera en mesure de traiter les mises à jour des clients.
Choisissez l’une des méthodes suivantes pour résoudre ce problème.
Résolution 1 : Déplacer le répertoire de contenu WSUS vers un nouvel emplacement à l’aide de l’utilitaire Wsusutil
Pour déplacer le répertoire de contenu WSUS, procédez comme suit :
Connectez-vous au serveur WSUS à l’aide d’un compte membre du groupe Administrateurs local.
Créez un dossier de destination pour le répertoire de contenu WSUS sur une partition NTFS. Le nouveau dossier de destination doit disposer des mêmes autorisations que celles définies sur le dossier d’origine.
Cliquez sur Démarrer, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu’administrateur.
Accédez au répertoire qui contient l’utilitaire Wsusutil.exe :
cd WSUSInstallDir\Tools
Tapez la commande suivante :
wsusutil movecontent contentpath logfile -skipcopy
Note
L’espace réservé contentpath est la nouvelle racine des fichiers de contenu (le chemin d’accès doit exister) et le fichier journal est le chemin d’accès et le nom du fichier journal à créer.
Appuyez sur Entrée. Wsusutil effectue les opérations suivantes :
Met à jour la base de données WSUS pour faire référence au nouvel emplacement des fichiers de mise à jour.
Garantit que le contenu et les métadonnées sont synchronisés.
Conserve l’ancien répertoire de contenu. Il reste intact et n’est pas supprimé par l’utilitaire.
L’utilisation du
-skipcopy
paramètre garantit que les fichiers du répertoire de contenu existant ne sont pas copiés dans le nouveau dossier de destination WSUS.
Symantec Endpoint Protection Manager peut désormais utiliser le répertoire de contenu par défaut.
Note
Vous devrez peut-être réparer ou réinstaller Symantec Endpoint Protection Manager.
Résolution 2 : Déplacer WSUS vers le port 8530 à l’aide de l’utilitaire Wsusutil
Cette option entraîne l’utilisation d’IIS par le port secondaire, mais tous les fichiers restent en place et seront toujours utilisés. Vous devrez peut-être reconfigurer les paramètres de stratégie de groupe du client WSUS pour le nouveau port.
Pour déplacer WSUS vers le port 8530, procédez comme suit :
Connectez-vous au serveur WSUS à l’aide d’un compte membre du groupe Administrateurs local.
Sur le serveur WSUS, cliquez sur Démarrer, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu’administrateur.
Accédez au répertoire qui contient l’utilitaire Wsusutil.exe :
cd WSUSInstallDir\Tools
Tapez la commande suivante :
wsusutil usecustomwebsite true
Appuyez sur Entrée. WSUS s’exécute désormais sur le port 8530.
Le cas échéant, reconfigurez le paramètre de stratégie de groupe du client WSUS pour le port 8530.
Symantec Endpoint Protection Manager peut désormais utiliser le répertoire de contenu et le port 80 par défaut.
Note
Vous devrez peut-être réparer ou réinstaller Symantec Endpoint Protection Manager.
Résolution 3 : Déplacer Symantec Endpoint Protection Manager vers un autre port
Pour plus d’informations, consultez la documentation Symantec relative aux autres procédures et numéros de port pris en charge.
Collecte de données
Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.