L’accès au partage de serveur de fichiers SMB échoue via l’alias CNAME DNS
Cet article explique comment résoudre les problèmes liés à l’accès à un serveur SMB (Server Message Block) à l’aide d’un nom canonique (CNAME).
Symptômes
Examinez le cas suivant :
- Vous disposez d’un serveur de fichiers SMB, tel qu’un ordinateur Windows Server ou un stockage nas attaché au réseau.
- Le serveur dispose de fichiers et de ressources accessibles à l’aide de leur nom NetBIOS, du système DNS (Domain Name System) complet (FQDN) et de l’alias (CNAME).
- Vous disposez d’un client exécutant Windows 10, Windows 11, Windows Server 2016 ou une version ultérieure de Windows Server.
- Sur le client, vous pouvez utiliser le nom NetBIOS ou le nom de domaine complet pour accéder au partage SMB avec une application ou un compte d’utilisateur.
Dans ce scénario, lorsque vous utilisez le CNAME pour accéder au partage SMB en exécutant l’une des commandes suivantes, la commande échoue.
\\CNAME.contoso.com\share_name
\\CNAME\share_name
NET USE * \\CNAME\share_name
NET USE * \\CNAME.contoso.com\share_name
New-PSDrive -Name "x" -PSProvider "FileSystem" -Root "\\CNAME\share_name" -Persist
New-PSDrive -Name "x" -PSProvider "FileSystem" -Root "\\CNAME.contoso.com\share_name" -Persist
Vous pouvez également recevoir un message d’erreur semblable à l’un des exemples suivants :
\\CNAME.contoso.com\share_name n’est pas accessible. Vous ne disposez peut-être pas des autorisations nécessaires pour utiliser cette ressource réseau. Contactez l’administrateur de ce serveur pour savoir si vous disposez des autorisations d’accès.
La restriction de compte empêche cet utilisateur de se connecter. Par exemple : les mots de passe vides ne sont pas autorisés, les heures de connexion sont limitées ou une restriction de stratégie a été appliquée.
\\CNAME.contoso.com\share_name n’est pas accessible. Vous ne disposez peut-être pas des autorisations nécessaires pour utiliser cette ressource réseau. Contactez l’administrateur de ce serveur pour savoir si vous disposez des autorisations d’accès.
Échec de connexion : le nom du compte cible est incorrect.
Cause
Ce problème peut être dû à l’une des raisons suivantes :
- Problème de configuration ou problème de renforcement du service serveur SMB.
- Le nom de principal de service (SPN, service principal name) pour l’enregistrement d’alias DNS (CNAME) pour le serveur de partage de fichiers est manquant.
Résolution
Pour résoudre ce problème, évitez d’utiliser dns CNAME pour configurer l’autre nom du serveur de fichiers. Au lieu de cela, configurez-le en définissant un alias à l’aide de la commande netdom :
Netdom computername <ComputerOriginalName> /add:<Alias>
Pour plus d’informations, consultez Utilisation des alias de nom d’ordinateur à la place des enregistrements CNAME DNS.