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Les zones DNS ne chargent pas et l’ID d’événement 4000 et 4007 sont enregistrés

Cet article résout un problème lié à l’enregistrement des ID d’événement 4000 et 4007 lorsque les zones DNS ne sont pas chargées sur la console DNS.

Numéro de base de connaissances d’origine : 2751452

Symptômes

L’un des serveurs DNS de votre environnement commence à afficher un problème indiquant que les zones ne sont pas chargées sur la console DNS. Et les ID d’événement 4000 et 4007 sont enregistrés dans les journaux d’événements DNS :

ID d’événement 4000 :

The DNS server was unable to open Active Directory. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

ID d’événement 4007 :

The DNS server was unable to open zone \<zone> in the Active Directory from the application directory partition \<partition name>. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

En outre, lorsque vous essayez d’ouvrir la console DNS, vous obtenez une fenêtre contextuelle donnant accès refusé.

Vous remarquez que le service serveur DNS est opérationnel.

Lorsque vous essayez d’effectuer une opération sur les zones intégrées à AD à l’aide de DNSCMD, vous recevez le message d’erreur Accès refusé .

Cause

Ce problème se produit lorsque ce serveur DC/DNS particulier a perdu son canal sécurisé avec lui-même ou PDC.

Ce problème peut également se produire dans un environnement DC unique où ce serveur DC/DNS contient tous les rôles FSMO et pointe vers lui-même en tant que serveur DNS principal.

Résolution

Si vous disposez d’un autre contrôleur de domaine/serveur DNS présent dans l’environnement, configurez le serveur qui rencontre le problème pour qu’il pointe vers d’autres serveurs DNS actifs dans les propriétés TCP/IP.

  1. Arrêtez le service KDC sur le contrôleur de domaine qui rencontre le problème.

  2. Exécutez la commande suivante avec des droits élevés :

    netdom resetpwd /server:<PDC.domain.com> /userd:<Domain\domain_admin> /passwordd:*
    

    Il vous invite à entrer le mot de passe du compte Administrateur de domaine que vous avez utilisé.

  3. Une fois la commande exécutée, redémarrez le serveur.

Les zones DNS doivent maintenant être chargées.

S’il s’agit du seul contrôleur de domaine dans l’environnement et qu’il n’existe aucun autre serveur DNS disponible, suivez les mêmes étapes, mais remplacez l’adresse PDC.Domain.com IP du serveur (car il s’agit du contrôleur de domaine principal).