Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit une solution de contournement pour le problème où vous risquez de ne pas être en mesure d’établir une connexion VPN en raison d’un conflit de port TCP.
S’applique à : Windows Server 2003
Numéro de base de connaissances d’origine : 885959
Important
Cet article contient des informations sur la modification du Registre. Avant d’effectuer cette opération, veillez à sauvegarder le Registre et à bien comprendre comment le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows
Symptômes
Lorsque vous essayez d’utiliser une connexion de réseau privé virtuel (VPN) sur un ordinateur Microsoft Windows Server 2003, vous pouvez recevoir le message d’erreur suivant :
Erreur 633 : le modem (ou un autre appareil de connexion) est déjà utilisé ou n’est pas configuré correctement.
Cause
Ce problème peut se produire si le port TCP utilisé par la connexion VPN est déjà utilisé par un autre programme. La connexion VPN utilise le port TCP 1723 pour établir une connexion. Si un autre programme utilise déjà ce port, vous ne pouvez pas établir de connexion VPN.
Solution de contournement
Avertissement
L’utilisation incorrecte de l’Éditeur du Registre peut entraîner des problèmes graves dont la résolution peut impliquer la réinstallation du système d’exploitation. Microsoft ne peut pas vous garantir que vous pourrez résoudre les problèmes qui résulteront d'une mauvaise utilisation de l'éditeur du registre. Son utilisation est sous votre entière responsabilité.
Pour contourner ce problème, appliquez l’une des méthodes suivantes :
- Réservez explicitement le port TCP utilisé pour la connexion VPN. Pour ce faire, procédez comme suit :
- Cliquez sur Démarrer, cliquez sur Exécuter, tapez regedit.exe dans la zone Ouvrir, puis cliquez sur OK.
- Dans l’Éditeur du Registre, recherchez, puis cliquez sur la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
- Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Valeur à plusieurs chaînes.
- Renommez la valeur multi-chaîne « ReservedPorts », puis double-cliquez sur ReservedPorts.
- Dans la zone de données Valeur, tapez 1723-1723, puis cliquez sur OK.
- Quittez l'Éditeur du Registre.
- Utilisez la commande netstat pour rechercher le programme qui utilise le port 1723. Ensuite, terminez le processus de ce programme. Pour ce faire, procédez comme suit :
Cliquez sur Démarrer, cliquez sur Exécuter, tapez cmd.exe dans la zone Ouvrir, puis cliquez sur OK.
À l'invite de commandes, tapez la commande suivante et appuyez sur Entrée :
netstat -aon
Dans la sortie affichée, identifiez l’ID de processus du programme, le cas échéant, qui utilise le port TCP 1723.
À l'invite de commandes, tapez la commande suivante et appuyez sur Entrée :
taskkill /PID PID /F
Note
La commande taskkill met fin au processus qui correspond au numéro d’ID de processus. L’option
/F
est utilisée pour mettre fin avec force au processus.À l’invite de commandes, tapez quitter, puis appuyez sur Entrée pour quitter l’invite de commandes.
- Redémarrez votre ordinateur. Il peut entraîner l’utilisation du port TCP 1723 par le programme qui utilise un autre port.