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Résoudre les problèmes de la console du serveur DirectAccess : DNS

La résolution de noms et la configuration correcte du serveur DNS sont essentielles aux fonctionnalités de DirectAccess.

Erreur « DNS ne fonctionne pas correctement »

Lorsque vous configurez d’abord DirectAccess ou apportez des modifications ultérieures à la configuration du serveur DNS, vous remarquerez peut-être que l’état des opérations pour DNS est affiché comme Critique et que l’état des opérations est affiché en tant que réactivité du serveur.

Capture d’écran de l’erreur de réactivité du serveur DNS.

DNS : Ne fonctionne pas correctement
Erreur :
Aucun des serveurs <DNS d’entreprise ipv6_address_of_the_DNS_server> utilisés par les clients DirectAccess pour la résolution de noms répond.

Ce problème peut affecter la connectivité du client DirectAccess aux ressources d’entreprise.

Cause

  • Une erreur se produit lorsque vous affectez un serveur DNS à un suffixe DNS spécifique. Si l’administrateur DirectAccess spécifie l’adresse IPv4 d’un serveur DNS d’entreprise interne, cela est incorrect. L’adresse IPv4 du serveur DNS doit être l’adresse affectée à l’interface réseau interne du serveur DirectAccess.
  • Les serveurs <DNS d’entreprise ipv6_address_of_the_DNS_server> ne répondent pas.

Résolution

Pour résoudre ce problème, assurez-vous que le serveur DNS est en ligne et répond aux demandes de résolution de noms. Ensuite, vérifiez les paramètres du serveur DNS.

Note

L’état des opérations est mis à jour en fonction de l’intervalle d’actualisation configuré. Cliquer sur Actualiser pour mettre à jour manuellement l’état ne met pas à jour l’état de la résolution DNS et les vérifications d’accessibilité ICMP.

La meilleure façon de s’assurer que le serveur DNS est configuré correctement pour DirectAccess consiste à supprimer l’entrée existante, puis à sélectionner Détecter.

Capture d’écran de la détection dans les adresses du serveur DNS.

Une adresse IPv6 est ajoutée automatiquement. Il s’agit de l’adresse IPv6 du service DNS64 qui s’exécute sur le serveur DirectAccess. Il s’agit de la façon dont le serveur DNS doit être configuré pour une opération DirectAccess correcte.

Capture d’écran de IPv6 ajoutée automatiquement.

Une fois les modifications enregistrées et appliquées, le serveur DNS doit répondre à nouveau, et l’état doit revenir à Working.

Erreur DNS64

DirectAccess est une technologie IPv6 uniquement. Les clients DirectAccess communiquent avec le serveur DirectAccess à l’aide des technologies IPv6. Cette communication utilise les technologies de transition IPv6. Par exemple, il utilise l’encapsulation IPV6 dans les paquets IPv4.

La communication entre le client et le serveur se produit à l’aide d’IPv6. La recherche de noms se produit également à l’aide d’IPv6 et d’une requête AAAA. Par conséquent, si un serveur interne a une adresse IPv6, le client peut facilement démarrer la communication.

Toutefois, si le serveur interne n’a configuré que IPv4, NAT64 ou DNS64 doit disposer d’une communication IPv6 sur un réseau IPv4 connhection.

Vous pouvez vérifier la configuration DNS64 sur le serveur en vérifiant la clé de Registre suivante :

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\RemoteAccess\Config\DefaultDnsServers

Exécutez la netsh int ipv6 commande pour afficher les adresses. Vous pouvez voir les liaisons de ces adresses aux interfaces. Dans un déploiement behind-NAT qui a deux interfaces, la liaison est généralement visible sur l’interface interne.