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Cet article fournit une solution à un problème où le système d’exploitation avec le mode débogage activé peut se bloquer si aucun débogueur n’est connecté.
Numéro de base de connaissances d’origine : 2816225
Symptômes
Sur un ordinateur exécutant Windows 7 ou Windows Server 2008 R2, après avoir installé les outils de débogage pour Windows, le système d’exploitation avec le mode débogage activé peut se bloquer si une application lève une exception en mode utilisateur.
Cause
Lorsque le mode débogage est activé et que le débogueur n’est pas connecté en raison de l’exception de mode utilisateur, le système se bloque en attendant qu’un débogueur intervienne à partir du point d’arrêt.
Résolution
Pour résoudre ce problème, désactivez le mode débogage à l’aide de l’une des méthodes suivantes :
Utilisation des paramètres de configuration système
- À l’aide de la touche clavier, Touche Windows+R pour ouvrir la zone d’exécution .
- Tapez MSCONFIG , puis appuyez sur Entrée.
- Sélectionnez l’onglet Démarrage , puis sélectionnez Options avancées.
- Décochez la case Debug .
- Cliquez sur OK.
- Sélectionnez Apply (Appliquer), puis OK.
- Redémarrez l'ordinateur.
Utilisation de l’interface de ligne de commande
- Ouvrez une invite de commandes avec élévation de privilèges.
- Tapez la commande suivante, puis appuyez sur Entrée :
bcdedit -debug off - Redémarrez l’ordinateur.
Plus d’informations
Note
Windows ne doit pas être exécuté en mode Débogage permanent. Le mode débogage est activé pour la connexion au débogage du noyau à l’aide de débogueurs tels que les outils de débogage pour Windows (WinDbg) et doit être désactivé une fois l’objectif accompli.
Certains systèmes Windows 7 peuvent être fournis avec le commutateur DEBUG activé, veillez à le désactiver.
Pour télécharger les outils de débogage pour Windows et plus d’informations, consultez Télécharger le Kit de pilotes Windows (WDK).